LTE Uplink (R&S FSW-K10x)
Contents
  • Welcome to the LTE Measurement Application
  • Measurements and Result Displays
  • Measurement Basics
  • Configuration
  • Analysis
  • Remote Control
  • List of Commands
Top


Welcome to the LTE Measurement Application

LTE Uplink (R&S FSW-K10x) > Welcome to the LTE Measurement Application
Welcome to the LTE Measurement Application

The R&S FSW-K101 and -K105 are firmware applications that add functionality to perform measurements on LTE signals according to the 3GPP standard to the R&S FSW.

This user manual contains a description of the functionality that the application provides, including remote control operation. All functions not discussed in this manual are the same as in the base unit and are described in the R&S FSW User Manual. The latest version is available for download at the product homepage

http://www2.rohde-schwarz.com/product/FSW.html.

Installation

Find detailed installing instructions in the Getting Started or the release notes of the R&S FSW.

Contents
  • Starting the LTE Measurement Application
  • Understanding the Display Information


Starting the LTE Measurement Application

LTE Uplink (R&S FSW-K10x) > Welcome to the LTE Measurement Application > Starting the LTE Measurement Application
Starting the LTE Measurement Application

The LTE measurement application adds a new application to the R&S FSW.

To activate the application

  1. Press the MODE key on the front panel of the R&S FSW.

    A dialog box opens that contains all operating modes and applications currently available on your R&S FSW.

  2. Select the "LTE" item.

    The R&S FSW opens a new measurement channel for the LTE measurement application.

LTE PC software and LTE measurement application

If you are using the EUTRA/LTE PC Software in combination with an R&S FSW, the "Mode" dialog box also contains a item for this software. It is labeled "LTE Software" and opens the PC software on the R&S FSW.

A comprehensive description of the functionality of this software is provided in a separate manual available for download on the internet.

For details see "Operating Modes" .

The measurement is started immediately with the default settings. It can be configured in the "Overview" dialog box, which is displayed when you select the "Overview" softkey from any menu.

For more information see "Configuration".


Understanding the Display Information

LTE Uplink (R&S FSW-K10x) > Welcome to the LTE Measurement Application > Understanding the Display Information
Understanding the Display Information

The following figure shows a measurement diagram during analyzer operation. All different information areas are labeled. They are explained in more detail in the following sections.

1 = Toolbar
2 = Channel bar
3 = Diagram header
4 = Result display
5 = Subwindows (if more than one MIMO data stream is displayed at the same time)
5 = Status bar
6 = Softkeys
Channel bar information

In the LTE measurement application, the R&S FSW shows the following settings:

Information displayed in the channel bar in the LTE measurement application
Ref Level | Reference level
Att | Mechanical and electronic RF attenuation
Freq | Frequency
Mode | LTE standard
MIMO | Number of Tx and Rx antennas in the measurement setup
Capture Time | Signal length that has been captured
Frame Count | Number of frames that have been captured
Selected Slot | Slot considered in the signal analysis
Selected Subframe | Subframe considered in the signal analysis

In addition, the channel bar also displays information on instrument settings that affect the measurement results even though this is not immediately apparent from the display of the measured values (e.g. transducer or trigger settings). This information is displayed only when applicable for the current measurement. For details see the R&S FSW Getting Started manual.

Window title bar information

The information in the window title bar depends on the result display.

The "Constellation Diagram", for example, shows the number of points that have been measured.

Status bar information

Global instrument settings, the instrument status and any irregularities are indicated in the status bar beneath the diagram. Furthermore, the progress of the current operation is displayed in the status bar.

Regarding the synchronization state, the application shows the following labels.
  • Sync OK
    The synchronization was successful. The status bar is green.
  • Sync Failed
    The synchronization was not successful. The status bar is red.
    There can be three different synchronization errors.
    – Sync Failed (Cyclic Prefix): The cyclic prefix correlation failed.
    – Sync Failed (P-SYNC): The P-SYNC correlation failed.
    – Sync Failed (S-SYNC): The S-SYNC correlation failed.


Measurements and Result Displays

LTE Uplink (R&S FSW-K10x) > Measurements and Result Displays
Measurements and Result Displays

The LTE measurement application measures and analyzes various aspects of an LTE signal.

It features several measurements and result displays. Measurements represent different ways of processing the captured data during the digital signal processing. Result displays are different representations of the measurement results. They may be diagrams that show the results as a graph or tables that show the results as numbers.

Selecting measurements
►

Press the MEAS key.

The application opens a dialog box that contains several buttons.

Each button represents a set of result displays that thematically belong together and that have a particular display configuration. If these predefined display configurations do not suit your requirements you can add or remove result displays as you like. For more information about selecting result displays see "Selecting result displays".

Depending on what button you select, the application changes the way the R&S FSW capture and processes the raw signal data.

  • When you select "EVM" or "Time Alignment", the application processes the I/Q data of the signal. For more information on available I/Q result displays see "I/Q Measurements".
    When you select one of the result displays available for I/Q measurements, you can combine the result displays available for I/Q measurements in any way.
  • When you select "Channel Power ACLR" or "Spectrum Emission Mask", the application performs a frequency sweep. For more information see "Frequency Sweep Measurements".
    When you select one of the frequency sweep measurements, you can combine the result displays available for the frequency sweep measurements in any way. Note that you can not display the ACLR and SEM at the same time.
Selecting result displays
►

Select the [image] icon in the toolbar or press the "Display Config" softkey in the "Measurement" menu.

The application enters the SmartGrid configuration mode.

For more information on the SmartGrid functionality see the R&S FSW Getting Started.

In the default state of the application, it shows several conventional result displays.
  • Capture Memory
  • EVM vs Carrier
  • Power Spectrum
  • Result Summary
  • Constellation Diagram

From that predefined state, add and remove result displays as you like.

Numeric result displays

The application allows you to customize the number of columns for some numeric result displays, for example the Allocation Summary.

To change the displayed columns, tap somewhere in the header row of the table.

The application opens a dialog box to add or remove columns.

Performing measurements

By default, the application measures the signal continuously. In "Continuous Sweep" mode, the application captures and analyzes the data again and again. The amount of data depends on the capture time (I/Q measurements) or the sweep time (frequency sweep measurements). In "Single Sweep" mode, the application stops measuring after it has captured the data once. The amount of data again depends on the capture time or the sweep time.

You can also repeat a measurement based on the data that has already been captured with the "Refresh" function. This is useful if you want to apply different modulation settings to the same I/Q data, for example.

For more information see "Single Sweep/ RUN SINGLE" , "Continuous Sweep/RUN CONT" and "Continue Single Sweep" .

Contents
  • I/Q Measurements
  • Frequency Sweep Measurements


I/Q Measurements

LTE Uplink (R&S FSW-K10x) > Measurements and Result Displays > I/Q Measurements
I/Q Measurements
└ Capture Buffer
└ EVM vs Carrier
└ EVM vs Symbol
└ EVM vs Subframe
└ Power Spectrum
└ Inband Emission
└ Spectrum Flatness
└ Spectrum Flatness SRS
└ Channel Group Delay
└ Spectrum Flatness Difference
└ Constellation Diagram
└ CCDF
└ Allocation Summary
└ Bit Stream
└ Result Summary
└ Marker Table


Capture Buffer

LTE Uplink (R&S FSW-K10x) > Measurements and Result Displays > I/Q Measurements > Capture Buffer
Capture Buffer

The Capture Buffer result display shows the complete range of captured data for the last data capture. The x-axis represents time. The maximum value of the x-axis is equal to the Capture Time. The y-axis represents the amplitude of the captured I/Q data in dBm (for RF input).

A green vertical line at the beginning of the green bar in the Capture Buffer display marks the subframe start. Additionally, the diagram contains the "Start Offset" value. This value is the time difference between the subframe start and capture buffer start.

When you zoom into the diagram, you will see that the bar may be interrupted at certain positions. Each small bar indicates the useful parts of the OFDM symbol.

Remote command:

Selecting the result display: LAY:ADD ? '1',LEFT,CBUF

Querying results: TRACe:DATA?

Querying the subframe start offset: FETCh:​SUMMary:​TFRame?


EVM vs Carrier

LTE Uplink (R&S FSW-K10x) > Measurements and Result Displays > I/Q Measurements > EVM vs Carrier
EVM vs Carrier

Starts the EVM vs Carrier result display.

This result display shows the Error Vector Magnitude (EVM) of the subcarriers. With the help of a marker, you can use it as a debugging technique to identify any subcarriers whose EVM is too high.

The results are based on an average EVM that is calculated over the resource elements for each subcarrier. This average subcarrier EVM is determined for each analyzed slot in the capture buffer.

If you analyze all slots, the result display contains three traces.
  • Average EVM
    This trace shows the subcarrier EVM averaged over all slots.
  • Minimum EVM
    This trace shows the lowest (average) subcarrier EVM that has been found over the analyzed slots.
  • Maximum EVM
    This trace shows the highest (average) subcarrier EVM that has been found over the analyzed slots.

If you select and analyze one slot only, the result display contains one trace that shows the subcarrier EVM for that slot only. Average, minimum and maximum values in that case are the same. For more information see "Subframe Selection"

The x-axis represents the center frequencies of the subcarriers. On the y-axis, the EVM is plotted either in % or in dB, depending on the "EVM Unit".

Remote command:

Selecting the result display: LAY:ADD ? '1',LEFT,EVCA

Querying results: TRACe:DATA?


EVM vs Symbol

LTE Uplink (R&S FSW-K10x) > Measurements and Result Displays > I/Q Measurements > EVM vs Symbol
EVM vs Symbol

Starts the EVM vs Symbol result display.

This result display shows the Error Vector Magnitude (EVM) of the OFDM symbols. You can use it as a debugging technique to identify any symbols whose EVM is too high.

The results are based on an average EVM that is calculated over all subcarriers that are part of a particular OFDM symbol. This average OFDM symbol EVM is determined for all OFDM symbols in each analyzed slot.

If you analyze all subframes, the result display contains three traces.
  • Average EVM
    This trace shows the OFDM symbol EVM averaged over all slots.
  • Minimum EVM
    This trace shows the lowest (average) OFDM symbol EVM that has been found over the analyzed slots.
  • Maximum EVM
    This trace shows the highest (average) OFDM symbol EVM that has been found over the analyzed slots.

If you select and analyze one slot only, the result display contains one trace that shows the OFDM symbol EVM for that slot only. Average, minimum and maximum values in that case are the same. For more information see "Subframe Selection"

The x-axis represents the OFDM symbols, with each symbol represented by a dot on the line. The number of displayed symbols depends on the Subframe Selection and the length of the cyclic prefix. Any missing connections from one dot to another mean that the R&S FSW could not determine the EVM for that symbol. In case of TDD signals, the result display does not show OFDM symbols that are not part of the measured link direction.

On the y-axis, the EVM is plotted either in % or in dB, depending on the "EVM Unit".

Remote command:

Selecting the result display: LAY:ADD ? '1',LEFT,EVSY

Querying results: TRACe:DATA?


EVM vs Subframe

LTE Uplink (R&S FSW-K10x) > Measurements and Result Displays > I/Q Measurements > EVM vs Subframe
EVM vs Subframe

Starts the EVM vs Subframe result display.

This result display shows the Error Vector Magnitude (EVM) for each subframe. You can use it as a debugging technique to identify a subframe whose EVM is too high.

The result is an average over all subcarriers and symbols of a specific subframe.

The x-axis represents the subframes, with the number of displayed subframes being 10.

On the y-axis, the EVM is plotted either in % or in dB, depending on the "EVM Unit".

Remote command:

Selecting the result display: LAY:ADD ? '1',LEFT,EVSU

Querying results: TRACe:DATA?


Power Spectrum

LTE Uplink (R&S FSW-K10x) > Measurements and Result Displays > I/Q Measurements > Power Spectrum
Power Spectrum

Starts the Power Spectrum result display.

This result display shows the power density of the complete capture buffer in dBm/Hz. The displayed bandwidth depends on bandwidth or number of resource blocks you have set.

For more information see "Channel Bandwidth / Number of Resource Blocks".

The x-axis represents the frequency. On the y-axis the power level is plotted.

Remote command:

Selecting the result display: LAY:ADD ? '1',LEFT,PSPE

Querying results: TRACe:DATA?


Inband Emission

LTE Uplink (R&S FSW-K10x) > Measurements and Result Displays > I/Q Measurements > Inband Emission
Inband Emission

Starts the Inband Emission result display.

This result display shows the relative power of the unused resource blocks (yellow trace) and the inband emission limit lines (red trace) specified by the LTE standard document 3GPP TS36.101.

The measurement is evaluated over the currently selected slot in the currently selected subframe. The currently selected subframe depends on your selection.

Note that you have to select a specific subframe and slot to get valid measurement results.

You can also display the inband emissions for the allocated resource block in addition to the unused resource blocks when you select the Inband Emissions All result display.

Remote command:

Selecting the result display: LAY:ADD ? '1',LEFT,IE

Selecting the result display: LAY:ADD ? '1',LEFT,IEA

Qurying results: TRACe:DATA?


Spectrum Flatness

LTE Uplink (R&S FSW-K10x) > Measurements and Result Displays > I/Q Measurements > Spectrum Flatness
Spectrum Flatness

Starts the Spectrum Flatness result display.

This result display shows the relative power offset caused by the transmit channel.

The measurement is evaluated over the currently selected slot in the currently selected subframe.

The currently selected subframe depends on your selection.

The x-axis represents the frequency. On the y-axis, the channel flatness is plotted in dB.

Note that the limit lines are only displayed if you match the Operating Band to the center frequency. Limits are defined for each operating band in the standard. The shape of the limit line is different when "Extreme Conditions" are on.

Remote command:

Selecting the result display: LAY:ADD ? '1',LEFT,SFL

Querying results: TRACe:DATA?


Spectrum Flatness SRS

LTE Uplink (R&S FSW-K10x) > Measurements and Result Displays > I/Q Measurements > Spectrum Flatness SRS
Spectrum Flatness SRS

The Spectrum Flatness SRS display shows the amplitude of the channel transfer function based on the sounding reference signal.

The measurement is evaluated over the currently selected slot in the currently selected subframe. The slot and subframe selection may be changed in the general settings.

Remote command:

Selecting the result display: LAY:ADD ? '1',LEFT,SFSR

Querying results: TRACe:DATA


Channel Group Delay

LTE Uplink (R&S FSW-K10x) > Measurements and Result Displays > I/Q Measurements > Channel Group Delay
Channel Group Delay

Starts the Channel Group Delay result display.

This result display shows the group delay of each subcarrier.

The measurement is evaluated over the currently selected slot in the currently selected subframe.

The currently selected subframe depends on your selection.

The x-axis represents the frequency. On the y-axis, the group delay is plotted in ns.

Remote command:

Selecting the result display: LAY:ADD ? '1',LEFT,GDEL

Querying results: TRACe:DATA?


Spectrum Flatness Difference

LTE Uplink (R&S FSW-K10x) > Measurements and Result Displays > I/Q Measurements > Spectrum Flatness Difference
Spectrum Flatness Difference

Starts the Spectrum Flatness Difference result display.

This result display shows the level difference in the spectrum flatness result between two adjacent physical subcarriers.

The measurement is evaluated over the currently selected slot in the currently selected subframe.

The currently selected subframe depends on your selection.

The x-axis represents the frequency. On the y-axis, the power is plotted in dB.

Remote command:

Selecting the result display: LAY:ADD ? '1',LEFT,SFD

Querying results: TRACe:DATA?


Constellation Diagram

LTE Uplink (R&S FSW-K10x) > Measurements and Result Displays > I/Q Measurements > Constellation Diagram
Constellation Diagram

Starts the Constellation Diagram result display.

This result display shows the inphase and quadrature phase results and is an indicator of the quality of the modulation of the signal.

In the default state, the result display evaluates the full range of the measured input data. You can filter the results by changing the evaluation range.

The constellation diagram also contains information about the current evaluation range. In addition, it shows the number of points that are displayed in the diagram.

Remote command:

Selecting the result display: LAY:ADD ? '1',LEFT,CONS

Querying results: TRACe:DATA?


CCDF

LTE Uplink (R&S FSW-K10x) > Measurements and Result Displays > I/Q Measurements > CCDF
CCDF

Starts the Complementary Cumulative Distribution Function (CCDF) result display.

This result display shows the probability of an amplitude exceeding the mean power. For the measurement, the complete capture buffer is used.

The x-axis represents the power relative to the measured mean power. On the y-axis, the probability is plotted in %.

Remote command:

Selecting the result display: LAY:ADD ? '1',LEFT,CCDF

Querying results: TRACe:DATA?


Allocation Summary

LTE Uplink (R&S FSW-K10x) > Measurements and Result Displays > I/Q Measurements > Allocation Summary
Allocation Summary

Starts the Allocation Summary result display.

This result display shows the results of the measured allocations in tabular form.

The rows in the table represent the allocations. A set of allocations form a subframe. The subframes are separated by a dashed line. The columns of the table contain the follwing information:

  • Subframe
    Shows the subframe number.
  • Allocation ID
    Shows the type / ID of the allocation.
  • Number of RB
    Shows the number of resource blocks assigned to the current PDSCH allocation.
  • Offset RB
    Shows the resource block offset of the allocation.
  • Modulation
    Shows the modulation type.
  • Power
    Shows the power of the allocation in dBm.
  • EVM
    Shows the EVM of the allocation. The unit depends on your selection.

Note: Contents of the Allocation Summary
The number of columns shown in the Allocation Summary is variable. To add or remove a column, click on the header row of the table once. The application opens a dialog box to select the columns which you'd like to display.

Remote command:

Selecting the result display: LAY:ADD ? '1',LEFT,ASUM

Querying results: TRACe:DATA?


Bit Stream

LTE Uplink (R&S FSW-K10x) > Measurements and Result Displays > I/Q Measurements > Bit Stream
Bit Stream

Starts the Bit Stream result display.

This result display shows the demodulated data stream for each data allocation. Depending on the "Bit Stream Format", the numbers represent either bits (bit order) or symbols (symbol order).

Selecting symbol format shows the bit stream as symbols. In that case the bits belonging to one symbol are shown as hexadecimal numbers with two digits. In the case of bit format, each number represents one raw bit.

Symbols or bits that are not transmitted are represented by a "-".

If a symbol could not be decoded because the number of layers exceeds the number of receive antennas, the application shows a "#" sign.

The table contains the following information:

  • Subframe
    Number of the subframe the bits belong to.
  • Allocation ID
    Channel the bits belong to.
  • Codeword
    Code word of the allocation.
  • Modulation
    Modulation type of the channels.
  • Symbol Index or Bit Index
    Shows the position of the table row's first bit or symbol within the complete stream.
  • Bit Stream
    The actual bit stream.
Remote command:

Selecting the result display: LAY:ADD ? '1',LEFT,BSTR

Querying results: TRACe:DATA?


Result Summary

LTE Uplink (R&S FSW-K10x) > Measurements and Result Displays > I/Q Measurements > Result Summary
Result Summary

The Result Summary shows all relevant measurement results in numerical form, combined in one table.

Remote command:

LAY:ADD ? '1',LEFT,RSUM

Contents of the result summary

The table is split in two parts. The first part shows results that refer to the complete frame. It also indicates limit check results where available. The font of 'Pass' results is green and that of 'Fail' results is red.

Note that the contents of the table depend on whether you are measuring in PUCCH/PUSCH or PRACH analysis mode. For more information see "Analysis Mode".

In addition to the red font, the application also puts a red star ( [image]) in front of failed results.

Note: The EVM results on a frame level (first part of the table) are calculated as defined by 3GPP at the edges of the cyclic prefix.
The other EVM results (lower part of the table) are calculated at the optimal timing position in the middle of the cyclic prefix.
Because of inter-symbol interference, the EVM calculated at the edges of the cyclic prefix is higher than the EVM calculated in the middle of the cyclic prefix.

EVM PUSCH QPSK | Shows the EVM for all QPSK-modulated resource elements of the PUSCH channel in the analyzed frame. FETCh:​SUMMary:​EVM:​USQP[:​AVERage]?
EVM PUSCH 16QAM | Shows the EVM for all 16QAM-modulated resource elements of the PUSCH channel in the analyzed frame. FETCh:​SUMMary:​EVM:​USST[:​AVERage]?
EVM PUSCH 64QAM | Shows the EVM for all 64QAM-modulated resource elements of the PUSCH channel in the analyzed frame. FETCh:​SUMMary:​EVM:​USSF[:​AVERage]?
EVM DRMS PUSCH QPSK | Shows the EVM of all DMRS resource elements with QPSK modulation of the PUSCH in the analyzed frame. FETCh:​SUMMary:​EVM:​SDQP[:​AVERage]?
EVM DRMS PUSCH 16QAM | Shows the EVM of all DMRS resource elements with 16QAM modulation of the PUSCH in the analyzed frame. FETCh:​SUMMary:​EVM:​SDST[:​AVERage]?
EVM DRMS PUSCH 64QAM | Shows the EVM of all DMRS resource elements with 64QAM modulation of the PUSCH in the analyzed frame. FETCh:​SUMMary:​EVM:​SDSF[:​AVERage]?
EVM PUCCH | Shows the EVM of all resource elements of the PUCCH channel in the analyzed frame. FETCh:​SUMMary:​EVM:​UCCH[:​AVERage]?
EVM DMRS PUCCH | Shows the EVM of all DMRS resource elements of the PUCCH channel in the analyzed frame. FETCh:​SUMMary:​EVM:​UCCD[:​AVERage]?
EVM PRACH | Shows the EVM of all resource elements of the PRACH channel in the analyzed frame. FETCh:​SUMMary:​EVM:​UPRA[:​AVERage]?

By default, all EVM results are in %. To view the EVM results in dB, change the "EVM Unit".

The second part of the table shows results that refer to a specifc selection of the frame.

The statistic is always evaluated over the slots.

The header row of the table contains information about the selection you have made (like the subframe).

EVM All | Shows the EVM for all resource elements in the analyzed frame. FETCh:​SUMMary:​EVM[:​ALL][:​AVERage]?
EVM Phys Channel | Shows the EVM for all physical channel resource elements in the analyzed frame. A physical channel corresponds to a set of resource elements carrying information from higher layers. PUSCH, PUCCH and PRACH are physical channels. For more information see 3GPP 36.211. FETCh:​SUMMary:​EVM:​PCHannel[:​AVERage]?
EVM Phys Signal | Shows the EVM for all physical signal resource elements in the analyzed frame. The reference signal is a physical signal. For more information see 3GPP 36.211. FETCh:​SUMMary:​EVM:​PSIGnal[:​AVERage]?
Frequency Error | Shows the difference in the measured center frequency and the reference center frequency. FETCh:​SUMMary:​FERRor[:​AVERage]?
Sampling Error | Shows the difference in measured symbol clock and reference symbol clock relative to the system sampling rate. FETCh:​SUMMary:​SERRor[:​AVERage]?
I/Q Offset | Shows the power at spectral line 0 normalized to the total transmitted power. FETCh:​SUMMary:​IQOFfset[:​AVERage]?
I/Q Gain Imbalance | Shows the logarithm of the gain ratio of the Q-channel to the I-channel. FETCh:​SUMMary:​GIMBalance[:​AVERage]?
I/Q Quadrature Error | Shows the measure of the phase angle between Q-channel and I-channel deviating from the ideal 90 degrees. FETCh:​SUMMary:​QUADerror[:​AVERage]?
Power | Shows the average time domain power of the allocated resource blocks of the analyzed signal. FETCh:​SUMMary:​POWer[:​AVERage]?
Crest Factor | Shows the peak-to-average power ratio of captured signal. FETCh:​SUMMary:​CRESt[:​AVERage]?


Marker Table

LTE Uplink (R&S FSW-K10x) > Measurements and Result Displays > I/Q Measurements > Marker Table
Marker Table

Displays a table with the current marker values for the active markers.

Remote command:

LAY:ADD? '1',RIGH, MTAB, see LAYout:​ADD[:​WINDow]?

Results:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?


Frequency Sweep Measurements

LTE Uplink (R&S FSW-K10x) > Measurements and Result Displays > Frequency Sweep Measurements
Frequency Sweep Measurements

The Spectrum Emission Mask (SEM) and Adjacent Channel Leakage Ratio (ACLR) measurements are the only frequency sweep measurements available for the LTE measurement application. They do not use the I/Q data all other measurements use. Instead those measurements sweep the frequency spectrum every time you run a new measurement. Therefore it is not possible to to run an I/Q measurement and then view the results in the frequency sweep measurements and vice-versa. Also because each of the frequency sweep measurements uses different settings to obtain signal data it is not possible to run a frequency sweep measurement and view the results in another frequency sweep measurement.

Frequency sweep measurements are available if RF input is selected.

└ ACLR
└ Spectrum Mask
└ Multi Carrier ACLR


ACLR

LTE Uplink (R&S FSW-K10x) > Measurements and Result Displays > Frequency Sweep Measurements > ACLR
ACLR

Starts the Adjacent Channel Leakage Ratio (ACLR) measurement.

The ACLR measurement analyzes the power of the transmission (TX) channel and the power of the two neighboring channels (adjacent channels) to the left and right of the TX channel. Thus, the ACLR measurement provides information about the power in the adjacent channels as well as the leakage into these adjacent channels.

The x-axis represents the frequency with a frequency span that relates to the specified EUTRA/LTE channel and adjacent channel bandwidths. On the y-axis, the power is plotted in dBm.

By default the ACLR settings are based on the selected LTE Channel Bandwidth. You can change the assumed adjacent channel carrier type and, if required, customize the channel setup to your needs. For more information see the documentation of the R&S FSW.

The power for the TX channel is an absolute value in dBm. The power of the adjacent channels are values relative to the power of the TX channel.

In addition, the ACLR measurement results are also tested against the limits defined by 3GPP. In the diagram, the limits are represented by horizontal red lines.

ACLR table

A table above the result display contains information about the measurement in numerical form:

  • Channel
    Shows the channel type (TX, Adjacent or Alternate Channel).
  • Bandwidth
    Shows the bandwidth of the channel.
  • Spacing
    Shows the channel spacing.
  • Lower / Upper
    Shows the relative power of the lower and upper adjacent and alternate channels
  • Limit
    Shows the limit of that channel, if one is defined.
Remote command:

Selecting the result display:

CONF:MEAS ACLR

Querying results:

CALCulate<n>:MARKer<m>:FUNCtion:POWer:RESult[:CURRent]?

TRACe:DATA?


Spectrum Mask

LTE Uplink (R&S FSW-K10x) > Measurements and Result Displays > Frequency Sweep Measurements > Spectrum Mask
Spectrum Mask

Starts the Spectrum Emission Mask (SEM) result display.

The Spectrum Emission Mask measurement shows the quality of the measured signal by comparing the power values in the frequency range near the carrier against a spectral mask that is defined by the 3GPP specifications. In this way, you can test the performance of the DUT and identify the emissions and their distance to the limit.

In the diagram, the SEM is represented by a red line. If any measured power levels are above that limit line, the test fails. If all power levels are inside the specified limits, the test is passed. The application labels the limit line to indicate whether the limit check has passed or failed.

The x-axis represents the frequency with a frequency span that relates to the specified EUTRA/LTE channel bandwidths. On the y-axis, the power is plotted in dBm.

A table above the result display contains the numerical values for the limit check at each check point:

  • Start / Stop Freq Rel
    Shows the start and stop frequency of each section of the Spectrum Mask relative to the center frequency.
  • RBW
    Shows the resolution bandwidth of each section of the Spectrum Mask
  • Freq at Δ to Limit
    Shows the absolute frequency whose power measurement being closest to the limit line for the corresponding frequency segment.
  • Power Abs
    Shows the absolute measured power of the frequency whose power is closest to the limit. The application evaluates this value for each frequency segment.
  • Power Rel
    Shows the distance from the measured power to the limit line at the frequency whose power is closest to the limit. The application evaluates this value for each frequency segment.
  • Δ to Limit
    Shows the minimal distance of the tolerance limit to the SEM trace for the corresponding frequency segment. Negative distances indicate the trace is below the tolerance limit, positive distances indicate the trace is above the tolerance limit.
Remote command:

Selecting the result display: CONF:MEAS ESP

Querying results: TRACe:DATA?


Multi Carrier ACLR

LTE Uplink (R&S FSW-K10x) > Measurements and Result Displays > Frequency Sweep Measurements > Multi Carrier ACLR
Multi Carrier ACLR

Starts the Multi Carrier Adjacent Channel Leakage Ratio (MC ACLR) measurement.

The MC ACLR measurement is basically the same as the ACLR measurement: it measures the power of the transmission channels and neighboring channels and their effect on each other. Instead of measuring a single carrier, the MC ACLR measures an aggregated carrier (two component carriers that form a single channel). Note that the component carriers have to be next to each other.

In its default state, the MC ACLR measurement measures three neighboring channels above and below the carrier. One of the neighboring channels is assumed to be an EUTRA channel (for example LTE) and the other two are assumed to be UTRA channels (for example WCDMA). Note that you can configure a different neighboring channel setup with the tools provided by the measurement. These tools are the same as those provided in the Spectrum application. For more information, please refer to the documentation of the R&S FSW.

The configuration in its default state complies with the test specifications defined in 3GPP 36.521.

The x-axis represents the frequency with a frequency span that relates to the LTE channel characteristics and adjacent channel bandwidths. Note that the application automatically determines the center frequency of the measurement according to the frequencies of the carriers.

On the y-axis, the power is plotted in dBm. The power for the TX channels is an absolute value in dBm. The power of the adjacent channels are values relative to the power of the TX channel. The power of the channels is automatically tested against the limits defined by 3GPP.

The result display contains several additional elements.
  • Blue and green lines:
    Represent the bandwidths of the carriers (blue lines) and those of the neighboring channels (green lines). Note that the channels may overlap each other.
  • Blue and green bars:
    Represent the integrated power of the transmission channels (blue bars) and neighboring channels (green bars).

MC ACLR table

A table above the result display contains information about the measurement in numerical form:
  • Channel
    Shows the type of channel.
    The first two rows represent the aggregated carrier (CA EUTRA Ref and Total: both rows show the characteristics of the aggregated channel and thus are basically the same). Regarding its characteristics, the two carriers are regarded as a single channel.
    The other rows represent the neighboring channels (one E-UTRA and two UTRA channels).
  • Bandwidth
    Shows the bandwidth of the channel.
    The bandwidth of the carrier is the sum of the two component carriers.
  • Offset
    Frequency offset relative to the center frequency of the aggregated carrier.
  • Power / Lower / Upper
    Shows the power of the carrier and the power of the lower and upper neighboring channels relative to the power of the aggregated carrier.
Remote command:

Selecting the result display:

CONF:MEAS MCAC

Querying results:

CALCulate<n>:MARKer<m>:FUNCtion:POWer:RESult[:CURRent]?

TRACe:DATA?

Querying limit check results:

CALCulate<n>:​LIMit<k>:​ACPower:​ACHannel:​RESult?

CALCulate<n>:​LIMit<k>:​ACPower:​ALTernate:​RESult?

CALCulate<n>:​LIMit<k>:​FAIL?


Measurement Basics

LTE Uplink (R&S FSW-K10x) > Measurement Basics
Measurement Basics

This chapter provides background information on the measurements and result displays available with the LTE Analysis Software.

Contents
  • Symbols and Variables
  • Overview
  • The LTE Uplink Analysis Measurement Application
  • SRS EVM Calculation


Symbols and Variables

LTE Uplink (R&S FSW-K10x) > Measurement Basics > Symbols and Variables
Symbols and Variables

The following chapters use various symbols and variables in the equations that the measurements are based on. The table below explains these symbols for a better understanding of the measurement principles.

al,kâl,k | data symbol (actual, decided)
Al,k | data symbol after DFT-precoding
Δf, Δ [image] coarse | carrier frequency offset between transmitter and receiver (actual, coarse estimate)
Δfres | residual carrier frequency offset
ζ | relative sampling frequency offset
Hl,k, [image] l,k | channel transfer function (actual, estimate)
i | time index
îcoarse, îfine | timing estimate (coarse, fine)
k | subcarrier index
l | SC-FDMA symbol index
NDS | number of SC-FDMA data symbols
NFFT | length of FFT
Ng | number of samples in cyclic prefix (guard interval)
Ns | number of Nyquist samples
NTX | number of allocated subcarriers
Nk,l | noise sample
n | index of modulated QAM symbol before DFT precoding
Φl | common phase error
ri | received sample in the time domain
R'k,l | uncompensated received sample in the frequency domain
rn,l | equalized received symbols of measurement path after IDFT
T | duration of the useful part of an SC-FDMA symbol
Tg | duration of the guard interval
Ts | total duration of SC-FDMA symbol


Overview

LTE Uplink (R&S FSW-K10x) > Measurement Basics > Overview
Overview

The digital signal processing (DSP) involves several stages until the software can present results like the EVM.

The contents of this chapter are structered like the DSP.


The LTE Uplink Analysis Measurement Application

LTE Uplink (R&S FSW-K10x) > Measurement Basics > The LTE Uplink Analysis Measurement Application
The LTE Uplink Analysis Measurement Application

The block diagram in figure "Block diagram for the LTE UL measurement application" shows the general structure of the LTE uplink measurement application from the capture buffer containing the I/Q data up to the actual analysis block.

After synchronization a fully compensated signal is produced in the reference path (purple) which is subsequently passed to the equalizer. An IDFT of the equalized symbols yields observations for the QAM transmit symbols an.l from which the data estimates ân,l are obtained via hard decision. Likewise a user defined compensation as well as equalization is carried out in the measurement path (cyan) and after an IDFT the observations of the QAM transmit symbols are provided. Accordingly, the measurement path might still contain impairments which are compensated in the reference path. The symbols of both signal processing paths form the basis for the analysis.

Block diagram for the LTE UL measurement application
Contents
  • Synchronization
  • Analysis


Synchronization

LTE Uplink (R&S FSW-K10x) > Measurement Basics > The LTE Uplink Analysis Measurement Application > Synchronization
Synchronization

In a first step the areas of sufficient power are identified within the captured I/Q data stream which consists of the receive samples ri. For each area of sufficient power, the analyzer synchronizes on subframes of the uplink generic frame structure [3]. After this coarse timing estimation, the fractional part as well as the integer part of the carrier frequency offset (CFO) are estimated and compensated. In order to obtain an OFDM demodulation via FFT of length NFFT that is not corrupted by ISI, a fine timing is established which refines the coarse timing estimate.

A phase tracking based on the reference SC-FDMA symbols is performed in the frequency domain. The corresponding tracking estimation block provides estimates for

  • the relative sampling frequency offset ζ
  • the residual carrier frequency offset Δfres
  • the common phase error Φl

According to references [7] and [8], the uncompensated samples R'k,l in the DFT-precoded domain can be stated as

with

  • the DFT precoded data symbol Ak,l on subcarrier k at SC-FDMA symbol l,
  • the channel transfer function Hk,l,
  • the number of Nyquist samples NS within the total duration TS,
  • the duration of the useful part of the SC-FDMA symbol T=TS-Tg
  • the independent and Gaussian distributed noise sample Nk,l

Within one SC-FDMA symbol, both the CPE and the residual CFO cause the same phase rotation for each subcarrier, while the rotation due to the SFO depends linearly on the subcarrier index. A linear phase increase in symbol direction can be observed for the residual CFO as well as for the SFO.

The results of the tracking estimation block are used to compensate the samples R'k,l completely in the reference path and according to the user settings in the measurement path. Thus the signal impairments that are of interest to the user are left uncompensated in the measurement path.

After having decoded the data symbols in the reference path, an additional data-aided phase tracking can be utilized to refine the common phase error estimation.


Analysis

LTE Uplink (R&S FSW-K10x) > Measurement Basics > The LTE Uplink Analysis Measurement Application > Analysis
Analysis

The analysis block of the EUTRA/LTE uplink measurement application allows to compute a variety of measurement variables.

EVM

The most important variable is the error vector magnitude which is defined as

for QAM symbol n before precoding and SC-FDMA symbol l. Since the normalized average power of all possible constellations is 1, the equation can be simplified to

The average EVM of all data subcarriers is then

for NDS SC-FDMA data symbols and the NTX allocated subcarriers.

I/Q imbalance

The I/Q imbalance contained in the continuous received signal r(t) can be written as

where s(t) is the transmit signal and I and Q are the weighting factors describing the I/Q imbalance. We define that I:=1 and Q:=1+ΔQ.

The I/Q imbalance estimation makes it possible to evaluate the

and the

based on the complex-valued estimate [image].

Basic in-band emissions measurement

The in-band emissions are a measure of the interference falling into the non-allocated resources blocks.

The relative in-band emissions are given by

where TS is a set |TS| of SC-FDMA symbols with the considered modulation scheme being active within the measurement period, ΔRB is the starting frequency offset between the allocated RB and the measured non-allocated RB (e.g. ΔRB=1 or ΔRB=-1 for the first adjacent RB), c is the lower edge of the allocated BW, and Y(t,f) is the frequency domain signal evaluated for in-band emissions. NRB is the number of allocated RBs .

The basic in-band emissions measurement interval is defined over one slot in the time domain.

Other measurement variables

Without going into detail, the EUTRA/LTE uplink measurement application additionally provides the following results:

  • Total power
  • Constellation diagram
  • Group delay
  • I/Q offset
  • Crest factor
  • Spectral flatness


SRS EVM Calculation

LTE Uplink (R&S FSW-K10x) > Measurement Basics > SRS EVM Calculation
SRS EVM Calculation

In order to calculate an accurate EVM, a channel estimation needs to be done prior to the EVM calculation. However, the channel estimation requires a minimum of two resource elements containing reference symbols on a subcarrier. Depending on the current Channel Estimation Range setting, this means that either at least two reference symbols ("Pilot Only") or one reference symbol and at least one data symbol ("Pilot and Payload") need to be available on the subcarrier the EVM is to be measured.

For PUSCH, PUCCH and PRACH regions, these conditions are normally fulfilled because the DMRS (= Demodulation Reference Signal) is already included. However, the SRS may also be located on subcarriers which do not occupy any other reference symbols (see figure "No EVM can be measured for the SRS").

No EVM can be measured for the SRS

In this case it is not reasonable to calculate an EVM and no SRS EVM value will be displayed for the corresponding subframe.

If the SRS subcarriers contain two DMRS symbols (or one DMRS and one PUSCH for "Pilot and Payload" channel estimation range) the SRS EVM can be measured (see figure "The EVM of the complete SRS can be measured").

The EVM of the complete SRS can be measured

The SRS allocation might cover subcarriers which partly fulfill the conditions mentioned above and partly do not. In this case the EVM value given in the Allocation Summary will be calculated based only on the subcarriers which fulfill the above requirements (see figure "The EVM for parts of the SRS can be measured").

The EVM for parts of the SRS can be measured


Configuration

LTE Uplink (R&S FSW-K10x) > Configuration
Configuration

LTE measurements require a special application on the R&S FSW, which you activate using the MODE key on the front panel.

For details see "Operating Modes" .

When you activate a measurement channel in the LTE application, a measurement for the input signal is started automatically with the default configuration. The "LTE" menu is displayed and provides access to the most important configuration functions.

Automatic refresh of preview and visualization in dialog boxes after configuration changes

The R&S FSW supports you in finding the correct measurement settings quickly and easily - after each change in settings in dialog boxes, the preview and visualization areas are updated immediately and automatically to reflect the changes. Thus, you can see if the setting is appropriate or not before accepting the changes.

Unavailable hardkeys

Note that the SPAN, BW, TRACE, LINES and MKR FUNC keys have no contents and no function in the LTE application.

Contents
  • Configuration Overview
  • Configuring I/Q Measurements
  • Configuring Frequency Sweep Measurements


Configuration Overview

LTE Uplink (R&S FSW-K10x) > Configuration > Configuration Overview
Configuration Overview

Throughout the measurement channel configuration, an overview of the most important currently defined settings is provided in the "Overview". The "Overview" is displayed when you select the "Overview" icon, which is available at the bottom of all softkey menus.

In addition to the main measurement settings, the "Overview" provides quick access to the main settings dialog boxes. The individual configuration steps are displayed in the order of the data flow. Thus, you can easily configure an entire measurement channel from input over processing to output and analysis by stepping through the dialog boxes as indicated in the "Overview".

In particular, the "Overview" provides quick access to the following configuration dialog boxes (listed in the recommended order of processing):

  1. Signal Description

    See "Defining Signal Characteristics".

  2. Input / Frontend

    See "Defining Level Characteristics".

  3. Trigger / Signal Capture

    See "Triggering Measurements"

    See "Configuring the Data Capture"

  4. Tracking

    See "Tracking".

  5. Demodulation

    see "Signal Demodulation".

  6. Evaluation Range

    See "Evaluation Range".

  7. Analysis

    See "Analysis".

  8. Display Configuration

    See "I/Q Measurements".

In addition, the dialog box provides the "Select Measurement" button that serves as a shortcut to select the measurement type.

Note that the "Overview" dialog box for frequency sweep measurement is similar to that of the Spectrum mode.

For more information see "Configuration Overview" .

To configure settings
►

Select any button in the "Overview" to open the corresponding dialog box.

Select a setting in the channel bar (at the top of the measurement channel tab) to change a specific setting.

└ Preset Channel
└ Specifics for


Preset Channel

LTE Uplink (R&S FSW-K10x) > Configuration > Configuration Overview > Preset Channel
Preset Channel

Select the "Preset Channel" button in the lower lefthand corner of the "Overview" to restore all measurement settings in the current channel to their default values.

Note that the PRESET key on the front panel restores the entire instrument to its default values and thus closes all measurement channels on the R&S FSW (except for the default Spectrum application channel)!

Remote command:

SYSTem:​PRESet:​CHANnel[:​EXECute]


Specifics for

LTE Uplink (R&S FSW-K10x) > Configuration > Configuration Overview > Specifics for
Specifics for

The measurement channel may contain several windows for different results. Thus, the settings indicated in the "Overview" and configured in the dialog boxes vary depending on the selected window.

Select an active window from the "Specifics for" selection list that is displayed in the "Overview" and in all window-specific configuration dialog boxes.

The "Overview" and dialog boxes are updated to indicate the settings for the selected window.


Configuring I/Q Measurements

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements
Configuring I/Q Measurements
Contents
  • Defining Signal Characteristics
  • Configuring MIMO Setups
  • Configuring Subframes
  • Defining Global Signal Characteristics
  • Configuring the Demodulation Reference Signal
  • Configuring the Sounding Reference Signal
  • Defining the PUSCH Structure
  • Defining the PUCCH Structure
  • Defining the PRACH Structure
  • Selecting the Input and Output Source
  • Defining Level Characteristics
  • Configuring the Data Capture
  • Triggering Measurements
  • Tracking
  • Signal Demodulation


Defining Signal Characteristics

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining Signal Characteristics
Defining Signal Characteristics

The general signal characteristics contain settings to describe the general physical attributes of the signal. They are part of the "Signal Description" tab of the "Signal Description" dialog box.

└ Selecting the LTE Mode
└ Using Test Models
└ Channel Bandwidth / Number of Resource Blocks
└ Cyclic Prefix
└ Configuring TDD Frames
└ Configuring the Physical Layer Cell Identity
└ Operating Band Index
└ Extreme Conditions


Selecting the LTE Mode

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining Signal Characteristics > Selecting the LTE Mode
Selecting the LTE Mode

The standard defines the LTE mode you are testing.

The choices you have depend on the set of options you have installed.

  • option FSx-K100(PC) enables testing of 3GPP LTE FDD signals on the downlink
  • option FSx-K101(PC) enables testing of 3GPP LTE FDD signals on the uplink
  • option FSx-K102(PC) enables testing of 3GPP LTE MIMO signals on the downlink
  • option FSx-K104(PC) enables testing of 3GPP LTE TDD signals on the downlink
  • option FSx-K105(PC) enables testing of 3GPP LTE TDD signals on the uplink
FDD and TDD are duplexing methods.
  • FDD mode uses different frequencies for the uplink and the downlink.
  • TDD mode uses the same frequency for the uplink and the downlink.
Downlink (DL) and Uplink (UL) describe the transmission path.
  • Downlink is the transmission path from the base station to the user equipment. The physical layer mode for the downlink is always OFDMA.
  • Uplink is the transmission path from the user equipment to the base station. The physical layer mode for the uplink is always SC-FDMA.

The application shows the currently selected LTE mode (including the bandwidth) in the channel bar.

Remote command:

Link direction: CONFigure[:​LTE]:​LDIRection

Duplexing mode: CONFigure[:​LTE]:​DUPLexing


Using Test Models

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining Signal Characteristics > Using Test Models
Using Test Models

Test models are descriptions of LTE signals that you can use for particular test scenarios.

The "Test Models" dialog box contains functionality to select, manage and create test models.
  • "Specification"
    The "Specification" tab contains predefined test models as defined by 3GPP.
    Predefined test models are supported in downlink mode.
  • "User Defined"
    The "User Defined" tab contains functionality to manage custom test models.
    Custom test models are supported in downlink and uplink mode.
    To create a custom test model, describe a signal as required and then save it via the "Test Models" dialog box.
    Here, you can also restore custom test models and delete ones you do not need anymore.

Predefined test models (E-TM)

In case of downlink signals, the 3GPP standard (TS 36.141) already defines several EUTRA test models (E-TM) for specific test scenarios. These test models are split into three main groups (E-TM1, E-TM2 and E-TM3) and are defined by the following characteristics.
  • single antenna port, single code word, single layer and no precoding
  • duration of one frame
  • normal cyclic prefix
  • localized virtual resource blocks, no intra-subframe hopping for PDSCH
  • UE-specific reference signal not used

The data content of the physical channels and signals are defined in the 3GPP standard. Each E-TM is defined for for all bandwidths defined in the standard (1.4 MHz / 3 MHz / 5 MHz / 10 MHz / 15 MHz / 20 MHz).

Test scenarios for E-TM as defined by 3GPP
  • E-TM1.1
    BS output power
    Unwanted emissions
    Transmitter intermodulation
    RS absolute accuracy
  • E-TM1.2
    ACLR
    Operating band unwanted emissions
  • E-TM2
    Total power dynamic range (lower OFDM symbol power limit at min. power)
    EVM of single 64QAM PRB allocation (at min. power)
    Frequency error (at min. power)
  • E-TM3.1
    Output power dynamics
    Transmitted signal quality (frequency error and EVM for 64QAM modulation at max. power)
  • E-TM3.2
    Transmitted signal quality
    – Frequency error
    – EVM for 16QAM modulation
  • E-TM3.3
    Transmitted signal quality
    – Frequency error
    – EVM for QPSK modulation


Channel Bandwidth / Number of Resource Blocks

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining Signal Characteristics > Channel Bandwidth / Number of Resource Blocks
Channel Bandwidth / Number of Resource Blocks

Specifies the channel bandwidth and number of resource blocks (RB).

The channel bandwidth and number of resource blocks (RB) are interdependent. Currently, the LTE standard recommends six bandwidths (see table below).

The application also calculates the FFT size, sampling rate, occupied bandwidth and occupied carriers from the channel bandwidth. Those are read only.

For more information about configuring aggregated carriers for MC ACLR measurements see "Carrier Aggregation".

The application shows the currently selected LTE mode (including the bandwidth) in the channel bar.

Remote command:

CONFigure[:​LTE]:​UL[:​CC<cci>]:​BW


Cyclic Prefix

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining Signal Characteristics > Cyclic Prefix
Cyclic Prefix

The cyclic prefix serves as a guard interval between OFDM symbols to avoid interferences. The standard specifies two cyclic prefix modes with a different length each.

The cyclic prefix mode defines the number of OFDM symbols in a slot.

  • Normal
    A slot contains 7 OFDM symbols.
  • Extended
    A slot contains 6 OFDM symbols.
    The extended cyclic prefix is able to cover larger cell sizes with higher delay spread of the radio channel.
  • Auto
    The application automatically detects the cyclic prefix mode in use.
Remote command:

CONFigure[:​LTE]:​UL:​CYCPrefix


Configuring TDD Frames

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining Signal Characteristics > Configuring TDD Frames
Configuring TDD Frames

TDD frames contain both uplink and downlink information separated in time with every subframe being responsible for either uplink or downlink transmission. The standard specifies several subframe configurations or resource allocations for TDD systems.

TDD UL/DL Allocations

Selects the configuration of the subframes in a radio frame in TDD systems.

The UL/DL configuration (or allocation) defines the way each subframe is used: for uplink, downlink or if it is a special subframe. The standard specifies seven different configurations.

U = uplink
D = downlink
S = special subframe

Conf. of Special Subframe

In combination with the cyclic prefix, the special subframes serve as guard periods for switches from uplink to downlink. They contain three parts or fields.
  • DwPTS
    The DwPTS is the downlink part of the special subframe. It is used to transmit downlink data.
  • GP
    The guard period makes sure that there are no overlaps of up- and downlink signals during a switch.
  • UpPTS
    The UpPTS is the uplink part of the special subframe. It is used to transmit uplink data.

The length of the three fields is variable. This results in several possible configurations of the special subframe. The LTE standard defines 10 different configurations for the special subframe. However, configurations 8 and 9 only work for a normal cyclic prefix.

If you select configurations 8 or 9 using an extended cyclic prefix or automatic detection of the cyclic prefix, the application will show an error message.

Remote command:

Subframe: CONFigure[:​LTE]:​UL:​TDD:​UDConf

Special subframe: CONFigure[:​LTE]:​UL:​TDD:​SPSC


Configuring the Physical Layer Cell Identity

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining Signal Characteristics > Configuring the Physical Layer Cell Identity
Configuring the Physical Layer Cell Identity

The cell ID, cell identity group and physical layer identity are interdependent parameters. In combination they are responsible for synchronization between network and user equipment.

The physical layer cell ID identifies a particular radio cell in the LTE network. The cell identities are divided into 168 unique cell identity groups. Each group consists of 3 physical layer identities. According to

N(1) = cell identity group, {0...167}
N(2) = physical layer identity, {0...2}

there is a total of 504 different cell IDs.

If you change one of these three parameters, the application automatically updates the other two.

The Cell ID determines

  • the reference signal grouping hopping pattern
  • the reference signal sequence hopping
  • the PUSCH demodulation reference signal pseudo-random sequence
  • the cyclic shifts for PUCCH formats 1/1a/1b and sequences for PUCCH formats 2/2a/2b
  • the pseudo-random sequence used for scrambling
  • the pseudo-random sequence used for type 2 PUSCH frequency hopping

The application shows the currently selected cell ID in the channel bar.

Remote command:

Cell ID: CONFigure[:​LTE]:​UL:​PLC:​CID

Cell Identity Group: CONFigure[:​LTE]:​UL:​PLC:​CIDGroup

Identity: CONFigure[:​LTE]:​UL:​PLC:​PLID


Operating Band Index

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining Signal Characteristics > Operating Band Index
Operating Band Index

Selects one of the 40 operating bands for spectrum flatness measurements as defined in TS 36.101.

The operating band defines the frequency band and the dedicated duplex mode.

Remote command:

[SENSe][:​LTE]:​SFLatness:​OBANd


Extreme Conditions

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining Signal Characteristics > Extreme Conditions
Extreme Conditions

Turns extreme conditions on and off.

If you turn the extreme conditions on, the software will modify the limit lines for the limit check of the spectral flatness measurement.

Remote command:

[SENSe][:​LTE]:​SFLatness:​ECONditions


Configuring MIMO Setups

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring MIMO Setups
Configuring MIMO Setups

The MIMO Configuration contains settings to configure MIMO test setups.

└ MIMO Configuration


MIMO Configuration

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring MIMO Setups > MIMO Configuration
MIMO Configuration

Selects the antenna configuration and test conditions for a MIMO system.

The MIMO configuration selects the number of transmit antennas for selected channels in the system.

In setups with multiple antennas, the antenna selection defines the antenna you'd like to test. Note that as soon as you have selected a transmission on more than one antenna for one of the channels, the corresponding number of antennas becomes available for testing.

Antenna 1 | Tests antenna 1 only.
Antenna 2 | Tests antenna 2 only.
Remote command:

CONFigure[:​LTE]:​UL:​MIMO:​ASELection


Configuring Subframes

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring Subframes
Configuring Subframes

An LTE frame consists of 10 subframes. Each individual subframe may have a different resource block configuration. This configuration is shown in the "Subframe Configuration Table".

The application supports two ways to determine the characteristics of each subframe.
  • Automatic demodulation of the channel configuration and detection of the subframe characteristics.
    In case of automatic demodulation, the contents of the table are determined according to the signal currently evaluated.
    For more information see "Auto Demodulation".
  • Custom configuration of the configuration of each subframe.
    In case of manual configuration, you can customize the table according to the signal that you expect. The signal is demodulated even if the signal does not fit the decription in the table or, in case of Physical Detection, only if the frame fits the description in the table.
    Remote command:
    Conf. subframes: CONFigure[:​LTE]:​UL:​CSUBframes
Frame number offset

A frame number offset is also supported. The frame number offset assigns a number to the demodulated frame in order to identify it in a series of transmitted (and captured) frames. You can define this frame in the Global Settings.

Remote command:

CONFigure[:​LTE]:​UL:​SFNO

Contents
  • General Subframe Configuration
  • Individual Subframe Configuration
  • Enhanced Settings


General Subframe Configuration

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring Subframes > General Subframe Configuration
General Subframe Configuration
└ Auto Demodulation
└ Subframe Configuration Detection


Auto Demodulation

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring Subframes > General Subframe Configuration > Auto Demodulation
Auto Demodulation

Turns automatic demodulation on and off.

If active, the R&S FSW automatically detects the characteristics of each subframe in the signal (resource allocation of the signal).

Two methods of detection are supported:
  • Auto Demodulation, DMRS Auto Detection (Off)
    This method automatically determines the characteristics for each subframe as shown in the Subframe Configuration Table.
    The table is populated accordingly.
  • Subframe Configuration & DMRS
    Auto Demodulation, DMRS Auto Detection (On)
    This method automatically detects the PUSCH and SRS (i.e. no PUCCH can be detected).
    To determine these characteristics, the software detects the CAZAC base parameters. Thus, the DMRS configuration parameters are not required for the synchronization and therefore are not available using this method.
    Note however that it is not possible to derive the DMRS configuration parameters from the CAZAC base parameters so that the disabled DMRS configuration parameters do not reflect the current parameters used for the synchronization. Also note that it can happen that the software successfully synchronizes on non-3GPP signals without a warning.

Automatic demodulation is not available if the Suppressed Interference Synchronization is active.

Remote command:

[SENSe][:​LTE]:​UL:​DEMod:​ACON


Subframe Configuration Detection

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring Subframes > General Subframe Configuration > Subframe Configuration Detection
Subframe Configuration Detection

Turns the detection of the subframe configuration on and off.

Upon activation, the software compares the current demodulated LTE frame to the subframe configuration you have set. Only if the signal is consistent with the configuration, the software will further analyze the LTE frame.

If inactive, the software analyzes the signal even if it is not consistent with the current subframe configuration.

Subframe configuration detection is available if you are using a Predefined subframe configuration.

Remote command:

[SENSe][:​LTE]:​UL:​FORMat:​SCD


Individual Subframe Configuration

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring Subframes > Individual Subframe Configuration
Individual Subframe Configuration

The "Subframe Configuration Table" contains the characteristics for each subframe. The software supports a maximum uplink LTE frame size of 10 subframes. The subframe number in the table depends on the number of "Configurable Subframes" that you have defined or that have been detected in case of automatic demodulation.

Each row of the table represents one subframe.

└ Subframe Number
└ Enable PUCCH
└ Enable PUSCH
└ Modulation
└ Enhanced Settings
└ Number of RB
└ Offset RB


Subframe Number

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring Subframes > Individual Subframe Configuration > Subframe Number
Subframe Number

Shows the number of a subframe.

Note that, depending on the TDD configuration, some subframes may not be available for editing. The R&S FSW labels those subframes "(not used)".


Enable PUCCH

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring Subframes > Individual Subframe Configuration > Enable PUCCH
Enable PUCCH

Turns the PUCCH in the corresponding subframe on and off.

Remote command:

CONFigure[:​LTE]:​UL:​SUBFrame<subframe>:​ALLoc:​CONT


Enable PUSCH

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring Subframes > Individual Subframe Configuration > Enable PUSCH
Enable PUSCH

Turns the PUSCH in the corresponding subframe on and off.

If you turn on a PUSCH, "Modulation", "Number of RBs" and "Offset RB" become available.

Remote command:

CONFigure[:​LTE]:​UL:​SUBFrame<subframe>:​ALLoc:​CONT


Modulation

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring Subframes > Individual Subframe Configuration > Modulation
Modulation

Selects the modulation scheme for the corresponding PUSCH allocation.

The modulation scheme is either QPSK, 16QAM or 64QAM.

Remote command:

CONFigure[:​LTE]:​UL:​SUBFrame<subframe>:​ALLoc:​MODulation


Enhanced Settings

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring Subframes > Individual Subframe Configuration > Enhanced Settings
Enhanced Settings

Opens a dialog box to configure enhanced functionality for selected channels in each subframe.

For more information see Enhanced Settings.


Number of RB

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring Subframes > Individual Subframe Configuration > Number of RB
Number of RB

Sets the number of resource blocks the PUSCH allocation covers. The number of resource blocks defines the size or bandwidth of the PUSCH allocation.

Remote command:

CONFigure[:​LTE]:​UL:​SUBFrame<subframe>:​ALLoc:​RBCount


Offset RB

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring Subframes > Individual Subframe Configuration > Offset RB
Offset RB

Sets the resource block at which the PUSCH allocation begins.

Make sure not to allocate PUSCH allocations into regions reserved for PUCCH allocations.

Remote command:

CONFigure[:​LTE]:​UL:​SUBFrame<subframe>:​ALLoc:​RBOFfset


Enhanced Settings

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring Subframes > Enhanced Settings
Enhanced Settings

The "Enhanced Settings" contain functionality to define enhanced characteristics for selected channels.

└ Enhanced PUSCH Configuration
└ Enhanced Demodulation Reference Signal Configuration
└ Enhanced PUCCH Configuration


Enhanced PUSCH Configuration

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring Subframes > Enhanced Settings > Enhanced PUSCH Configuration
Enhanced PUSCH Configuration

Configures the PUSCH in individual subframes.

Note: The Codeword to Layer Mapping and Spatial Multiplexing are not yet supported.

Resource Allocation Type 1

Turns a clustered PUSCH allocation an and off. If on, a second row is added to the corresponding allocation. This second row represents the second cluster.

You can define the number of resource block and the offset resource block for each cluster. All other parameters (power, modulation etc.) are the same for both clusters.

Remote command:

CONFigure[:​LTE]:​UL:​SUBFrame<subframe>:​ALLoc:​RATO


Enhanced Demodulation Reference Signal Configuration

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring Subframes > Enhanced Settings > Enhanced Demodulation Reference Signal Configuration
Enhanced Demodulation Reference Signal Configuration

Configures the Demodulation Reference Signal in individual subframes.

n(2)_DMRS

Defines the part of the demodulation reference signal index that is part of the uplink scheduling assignment. Thus, this part of the index is valid for corresponding UE and subframe only.

The index applies when multiple shifts within a cell are used. It is used for the calculation of the DMRS sequence.

Cyclic Shift Field

If "Activate-DMRS-With OCC" is on, the "Cyclic Shift Field" becomes available to define the cyclic shift field.

The Cyclic Shift Field is signalled by the PDCCH downlink channel in DCI format 0 and 4. It selects n(2)_DMRS and the orthogonal sequence (OCC) for signals according to LTE release 10.

If the "Cyclic Shift Field" is off, the demodulation reference signal is configured by the n(2)_DMRS parameter.

Remote command:

CONFigure[:​LTE]:​UL:​SUBFrame<subframe>:​ALLoc:​PUSCh:​NDMRs

CONFigure[:​LTE]:​UL:​SUBFrame<subframe>:​ALLoc:​PUSCh:​CSField


Enhanced PUCCH Configuration

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring Subframes > Enhanced Settings > Enhanced PUCCH Configuration
Enhanced PUCCH Configuration

Configures the PUSCH in individual subframes.

n_PUCCH

Defines the n_PUCCH parameter for the selected subframe.

Available only if you have selected "Per Subframe" for the "N_PUCCH".

PUCCH Format

Selects the PUCCH format for the selected subframe.

Available only if you have selected "Per Subframe" for the Format.

Remote command:

n_PUCCH: CONFigure[:​LTE]:​UL:​SUBFrame<subframe>:​ALLoc:​PUCCh:​NPAR

Format: CONFigure[:​LTE]:​UL:​SUBFrame<subframe>:​ALLoc:​PUCCh:​FORMat


Defining Global Signal Characteristics

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining Global Signal Characteristics
Defining Global Signal Characteristics

The global settings contain settings that apply to the complete signal.

The global signal settings are part of the "Advanced Settings" tab of the "Signal Description" dialog box.

└ Frame Number Offset
└ UE ID/n_RNTI


Frame Number Offset

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining Global Signal Characteristics > Frame Number Offset
Frame Number Offset

Defines a frame number offset for the analyzed frame.

The frame number offset assigns a number to the demodulated frame in order to identify it in a series of transmitted (and captured) frames.

Remote command:

CONFigure[:​LTE]:​UL:​SFNO


UE ID/n_RNTI

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining Global Signal Characteristics > UE ID/n_RNTI
UE ID/n_RNTI

Sets the radio network temporary identifier (RNTI) of the UE.

Remote command:

CONFigure[:​LTE]:​UL:​UEID


Configuring the Demodulation Reference Signal

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring the Demodulation Reference Signal
Configuring the Demodulation Reference Signal

The demodulation reference signal (DRS) settings contain settings that define the physical attributes and structure of the demodulation reference signal. This reference signal helps to demodulate the PUSCH.

The demodulation reference signal settings are part of the "Advanced Settings" tab of the "Signal Description" dialog box.

└ Relative Power PUSCH
└ Group Hopping
└ Sequence Hopping
└ Relative Power PUCCH
└ n(1)_DMRS
└ Delta Sequence Shift
└ Activate-DMRS-With OCC


Relative Power PUSCH

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring the Demodulation Reference Signal > Relative Power PUSCH
Relative Power PUSCH

Defines the power of the DMRS relative to the power level of the PUSCH allocation in the corresponding subframe (PDMRS_Offset).

The effective power level of the DMRS depends on the allocation of the subframe and is calculated as follows.

PDMRS = PUE + PPUSCH + PDMRS_Offset

The relative power of the DMRS is applied to all subframes.

The power of the PUSCH (PPUSCH) may be different in each subframe.

Remote command:

CONFigure[:​LTE]:​UL:​DRS[:​PUSCh]:​POWer


Group Hopping

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring the Demodulation Reference Signal > Group Hopping
Group Hopping

Turns group hopping for the demodulation reference signal on and off.

The group hopping pattern is based on 17 hopping patterns and 30 sequence shift patterns. It is generated by a pseudo-random sequence generator.

If on, PUSCH and PUCCH use the same group hopping pattern.

Remote command:

CONFigure[:​LTE]:​UL:​DRS:​GRPHopping


Sequence Hopping

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring the Demodulation Reference Signal > Sequence Hopping
Sequence Hopping

Turns sequence hopping for the uplink demodulation reference signal on and off.

Sequence hopping is generated by a pseudo-random sequence generator.

Remote command:

CONFigure[:​LTE]:​UL:​DRS:​SEQHopping


Relative Power PUCCH

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring the Demodulation Reference Signal > Relative Power PUCCH
Relative Power PUCCH

Defines the power of the DMRS relative to the power level of the PUCCH allocation in the corresponding subframe (PDMRS_Offset).

The effective power level of the DMRS depends on the allocation of the subframe and is calculated as follows.

PDMRS = PUE + PPUCCH + PDMRS_Offset

The relative power of the DMRS is applied to all subframes.

The power of the PUCCH (PPUCCH) may be different in each subframe.

Remote command:

CONFigure[:​LTE]:​UL:​DRS:​PUCCh:​POWer


n(1)_DMRS

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring the Demodulation Reference Signal > n(1)_DMRS
n(1)_DMRS

The n_DMRS parameter can be found in 3GPP TS36.211 V8.5.0, 5.5.2.1.1 Reference signal sequence.

Remote command:

CONFigure[:​LTE]:​UL:​DRS:​NDMRs


Delta Sequence Shift

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring the Demodulation Reference Signal > Delta Sequence Shift
Delta Sequence Shift

Defines the delta sequence shift ΔSS.

The standard defines a sequence shift pattern fss for the PUCCH. The corresponding sequence shift pattern for the PUSCH is a function of fssPUCCH and the delta sequence shift.

For more information refer to 3GPP TS 36.211, chapter 5.5.1.3 "Group Hopping".

Remote command:

CONFigure[:​LTE]:​UL:​DRS:​DSSHift


Activate-DMRS-With OCC

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring the Demodulation Reference Signal > Activate-DMRS-With OCC
Activate-DMRS-With OCC

Turns the configuration of the demodulation reference signal on a subframe basis via the "Cyclic Shift Field" on and off.

If on, the "Cyclic Shift Field" becomes available. Otherwise, the demodulation reference signal is configured by the n(2)_DMRS parameter.

Remote command:

CONFigure[:​LTE]:​UL:​DRS:​AOCC


Configuring the Sounding Reference Signal

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring the Sounding Reference Signal
Configuring the Sounding Reference Signal

The sounding reference signal (SRS) settings contain settings that define the physical attributes and structure of the sounding reference signal.

The sounding reference signal settings are part of the "Advanced Settings" tab of the "Signal Description" dialog box.

└ Present
└ SRS Subframe Conf.
└ SRS MaxUpPts
└ SRS Bandwidth B_SRS
└ Hopping BW b_hop
└ SRS Cyclic Shift N_CS
└ SRS Rel Power
└ SRS BW Conf. C_SRS
└ Conf. Index I_SRS
└ Transm. Comb. k_TC
└ Freq. Domain Pos. n_RRC
└ A/N + SRS Simultaneous TX


Present

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring the Sounding Reference Signal > Present
Present

Includes or excludes the sounding reference signal (SRS) from the test setup.

Remote command:

CONFigure[:​LTE]:​UL:​SRS:​STAT


SRS Subframe Conf.

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring the Sounding Reference Signal > SRS Subframe Conf.
SRS Subframe Conf.

Defines the subframe configuration of the SRS.

The subframe configuration of the SRS is specific to a cell. The UE sends a shortened PUCCH/PUSCH in these subframes, regardless of whether the UE is configured to send an SRS in the corresponding subframe or not.

Remote command:

CONFigure[:​LTE]:​UL:​SRS:​SUConfig


SRS MaxUpPts

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring the Sounding Reference Signal > SRS MaxUpPts
SRS MaxUpPts

Turns the parameter srs_MaxUpPts on and off.

srs_MaxUpPts controls the SRS transmission in the UpPTS field in TDD systems. If on, the SRS is transmitted in a frequency range of the UpPTS field that does not overlap with resources reserved for PRACH preamble 4 transmissions.

To avoid an overlap, the number of SRS resource blocks otherwise determined by C_SRS and B_SRS is reconfigured.

Remote command:

CONFigure[:​LTE]:​UL:​SRS:​MUPT


SRS Bandwidth B_SRS

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring the Sounding Reference Signal > SRS Bandwidth B_SRS
SRS Bandwidth B_SRS

Defines the parameter BSRS.

BSRS is a UE specific parameter that defines the bandwidth of the SRS. The SRS either spans the entire frequency bandwidth or uses frequency hopping when several narrowband SRS cover the same total bandwidth.

The standard defines up to four bandwidths for the SRS. The most narrow SRS bandwidth (BSRS = 3) spans four resource blocks and is available for all channel bandwidths. The other three values of BSRS define more wideband SRS bandwidths. Their availability depends on the channel bandwidth.

The availability of SRS bandwidths additionally depends on the bandwidth configuration of the SRS (CSRS).

For more information refer to 3GPP TS 36.211, chapter 5.5.3.2 "Mapping to Physical Resources" for the Sounding Reference Signal.

Remote command:

CONFigure[:​LTE]:​UL:​SRS:​BSRS


Hopping BW b_hop

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring the Sounding Reference Signal > Hopping BW b_hop
Hopping BW b_hop

Defines the parameter bhop.

bhop is a UE specific parameter that defines the frequency hopping bandwidth. SRS frequency hopping is active if bhop < BSRS.

For more information refer to 3GPP TS 36.211, chapter 5.5.3.2 "Mapping to Physical Resources" for the Sounding Reference Signal.

Remote command:

CONFigure[:​LTE]:​UL:​SRS:​BHOP


SRS Cyclic Shift N_CS

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring the Sounding Reference Signal > SRS Cyclic Shift N_CS
SRS Cyclic Shift N_CS

Defines the cyclic shift (nCS) used for the generation of the SRS CAZAC sequence.

Because the different shifts of the same Zadoff-Chu sequence are orthogonal to each other, applying different SRS cyclic shifts can be used to schedule different UE to simultaneously transmit their SRS.

Remote command:

CONFigure[:​LTE]:​UL:​SRS:​CYCS


SRS Rel Power

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring the Sounding Reference Signal > SRS Rel Power
SRS Rel Power

Defines the power of the SRS relative to the power of the corresponding UE (PSRS_Offset).

The effective power level of the SRS is calculated as follows.

PSRS = PUE + PSRS_Offset

The relative power of the SRS is applied to all subframes.

Remote command:

CONFigure[:​LTE]:​UL:​SRS:​POWer


SRS BW Conf. C_SRS

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring the Sounding Reference Signal > SRS BW Conf. C_SRS
SRS BW Conf. C_SRS

Defines the bandwidth configuration of the SRS.

The bandwidth configuration is a cell specific parameter that, in combination with the SRS bandwidth and the channel bandwidth, defines the length of the souunding reference signal sequence. For more information on the calculation refer to 3GPP TS 36.211 chapter 5.5.3 "Sounding Reference Signal".

Remote command:

CONFigure[:​LTE]:​UL:​SRS:​CSRS


Conf. Index I_SRS

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring the Sounding Reference Signal > Conf. Index I_SRS
Conf. Index I_SRS

Defines the configuration index of the SRS.

The configuration index ISRS is a cell specific parameter that determines the SRS periodicity (TSRS) and the SRS subframe offset (Toffset). The effects of the configuration index on TSRS and Toffset depends on the duplexing mode.

For more information refer to 3GPP TS 36.213, Table 8.2-1 (FDD) and 8.2-2 (TDD).

Remote command:

CONFigure[:​LTE]:​UL:​SRS:​ISRS


Transm. Comb. k_TC

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring the Sounding Reference Signal > Transm. Comb. k_TC
Transm. Comb. k_TC

Defines the transmission comb kTC.

The transmission comb. is a UE specific parameter. For more information refer to 3GPP TS 36.211, chapter 5.5.3.2 "Mapping to Physical Resources" for the Sounding Reference Signal.

Remote command:

CONFigure[:​LTE]:​UL:​SRS:​TRComb


Freq. Domain Pos. n_RRC

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring the Sounding Reference Signal > Freq. Domain Pos. n_RRC
Freq. Domain Pos. n_RRC

Defines the parameter nRRC.

nRRC is a UE specific parameter and determines the starting physical resource block of the SRS transmission.

For more information refer to 3GPP TS 36.211, chapter 5.5.3.2 "Mapping to Physical Resources" for the Sounding Reference Signal.

Remote command:

CONFigure[:​LTE]:​UL:​SRS:​NRRC


A/N + SRS Simultaneous TX

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring the Sounding Reference Signal > A/N + SRS Simultaneous TX
A/N + SRS Simultaneous TX

Turns simultaneous transmission of the Sounding Reference Signal (SRS) and ACK/NACK messages (via PUCCH) on and off.

By turning the parameter on, you allow for simultaneous transmission of PUCCH and SRS in the same subframe.

If off, the SRS not transmitted in the subframe for which you have configured simultaneous transmission of PUCCH and SRS.

Note that simultaneous transmission of SRS and PUCCH is available only if the PUCCH format is either 1, 1a, 1b or 3. The other PUCCH formats contain CQI reports which are not transmitted with the SRS.

Remote command:

CONFigure[:​LTE]:​UL:​SRS:​ANST


Defining the PUSCH Structure

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining the PUSCH Structure
Defining the PUSCH Structure

The PUSCH structure settings contain settings that describe the physical attributes and structure of the PUSCH.

The PUSCH structure settings are part of the "Advanced Settings" tab of the "Signal Description" dialog box.

└ Frequency Hopping Mode
└ Number of Subbands
└ PUSCH Hopping Offset
└ Info. in Hopping Bits


Frequency Hopping Mode

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining the PUSCH Structure > Frequency Hopping Mode
Frequency Hopping Mode

Selects the frequency hopping mode of the PUSCH.

Several hopping modes are supported.
  • None
    No frequency hopping.
  • Inter Subframe Hopping
    PUSCH changes the frequency from one subframe to another.
  • Intra Subframe Hopping
    PUSCH also changes the frequency within a subframe.
Remote command:

CONFigure[:​LTE]:​UL:​PUSCh:​FHMode


Number of Subbands

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining the PUSCH Structure > Number of Subbands
Number of Subbands

Defines the number of subbands reserved for PUSCH.

For more information refer to 3GPP TS 36.211, chapter 5.5.3.2 "Mapping to Physical Resources" for the Sounding Reference Signal.

Remote command:

CONFigure[:​LTE]:​UL:​PUSCh:​NOSM


PUSCH Hopping Offset

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining the PUSCH Structure > PUSCH Hopping Offset
PUSCH Hopping Offset

Defines the PUSCH Hopping Offset NRBHO.

The PUSCH Hopping Offset determines the first physical resource block and the maximum number of physical resource blocks available for PUSCH transmission if PUSCH frequency hopping is active.

Remote command:

CONFigure[:​LTE]:​UL:​PUSCh:​FHOFfset


Info. in Hopping Bits

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining the PUSCH Structure > Info. in Hopping Bits
Info. in Hopping Bits

Defines the information available in the hopping bits according to the PDCCH DCI format 0 hopping bit definition.

The information in the hopping bits determines whether type 1 or type 2 hopping is used in the subframe and, in case of type 1, additionally determines the exact hopping function to use.

For more information on PUSCH frequency hopping refer to 3GPP TS36.213.

Remote command:

CONFigure[:​LTE]:​UL:​PUSCh:​FHOP:​IIHB


Defining the PUCCH Structure

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining the PUCCH Structure
Defining the PUCCH Structure

The PUCCH structure settings contain settings that describe the physical attributes and structure of the PUCCH.

The PUCCH structure settings are part of the "Advanced Settings" tab of the "Signal Description" dialog box.

└ No. of RBs for PUCCH
└ N(1)_cs
└ Delta Shift
└ Format
└ N(2)_RB
└ N_PUCCH


No. of RBs for PUCCH

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining the PUCCH Structure > No. of RBs for PUCCH
No. of RBs for PUCCH

Defines the number of resource blocks reserved for PUCCH.

The resource blocks for PUCCH are always allocated at the edges of the LTE spectrum.

In case of an even number of PUCCH resource blocks, half of the available PUCCH resource blocks is allocated on the lower, the other half on the upper edge of the LTE spectrum (outermost resource blocks).

In case of an odd number of PUCCH resource blocks, the number of resource blocks on the lower edge is one resource block larger than the number of resource blocks on the upper edge of the LTE spectrum.

Remote command:

CONFigure[:​LTE]:​UL:​PUCCh:​NORB


N(1)_cs

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining the PUCCH Structure > N(1)_cs
N(1)_cs

Defines the number of cyclic shifts used for PUCCH format 1/1a/1b in a resource block used for a combination of the formats 1/1a/1b and 2/2a/2b.

Only one resource block per slot can support a combination of the PUCCH formats 1/1a/1b and 2/2a/2b.

The number of cyclic shifts available for PUCCH format 2/2a/2b N(2)_cs in a block with combination of PUCCH formats is calculated as follows.

N(2)_cs = 12 - N(1)_cs - 2

For more information refer to 3GPP TS36.211, chapter 5.4 "Physical Uplink Control Channel".

Remote command:

CONFigure[:​LTE]:​UL:​PUCCh:​N1CS


Delta Shift

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining the PUCCH Structure > Delta Shift
Delta Shift

Defines the delta shift parameter.

The delta shift is the difference between two adjacent PUCCH resource indices with the same orthogonal cover sequence (OC).

It determines the number of available sequences in a resource block that can be used for PUCCH formats 1/1a/1b.

For more information refer to 3GPP TS36.211, chapter 5.4 "Physical Uplink Control Channel".

Remote command:

CONFigure[:​LTE]:​UL:​PUCCh:​DESHift


Format

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining the PUCCH Structure > Format
Format

Selects the format of the PUCCH.

You can define the PUCCH format for all subframes or define the PUCCH format for each subframe individually.

  • F1, F1a, F1b, F2, F2a, F2b, F3
    Selects the PUCCH format globally for every subframe.
  • Per Subframe
    You can select the PUCCH format for each subframe separately in the Enhanced Settings of the "Subframe Configuration".

Note that formats F2a and F2b are only supported for normal cyclic prefix length.

For more information refer to 3GPP TS36.211, table 5.4-1 "Supported PUCCH Formats".

Remote command:

CONFigure[:​LTE]:​UL:​PUCCh:​FORMat


N(2)_RB

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining the PUCCH Structure > N(2)_RB
N(2)_RB

Defines bandwidth in terms of resource blocks that are reserved for PUCCH formats 2/2a/2b transmission in each subframe.

Since there can be only one resource block per slot that supports a combination of the PUCCH formats 1/1a/1b and 2/2a/2b, the number of resource block(s) per slot available for PUCCH format 1/1a/1b is determined by N(2)_RB.

For more information refer to 3GPP TS36.211, chapter 5.4 "Physical Uplink Control Channel".

Remote command:

CONFigure[:​LTE]:​UL:​PUCCh:​N2RB


N_PUCCH

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining the PUCCH Structure > N_PUCCH
N_PUCCH

Defines the resource index for PUCCH format 1/1a/1b respectively 2/2a/2b.

It is also possible to define NPUCCH on a subframe level by selecting the "Per Subframe" menu item. For more information see "Configuring Subframes".

Remote command:

CONFigure[:​LTE]:​UL:​PUCCh:​NPAR


Defining the PRACH Structure

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining the PRACH Structure
Defining the PRACH Structure

The PRACH structure settings contain settings that describe the physical attributes and structure of the PUCCH.

The PRACH structure settings are part of the "Advanced Settings" tab of the "Signal Description" dialog box.

└ PRACH Configuration
└ Restricted Set
└ Frequency Offset
└ PRACH Preamble Mapping
└ Ncs Conf
└ Logical Root Sequ. Idx
└ Sequence Index (v)


PRACH Configuration

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining the PRACH Structure > PRACH Configuration
PRACH Configuration

Sets the PRACH configuration index as defined in the 3GPP TS 36.211, i.e. defines the subframes in which random access preamble transmission is allowed.

The preamble format is automatically derived form the PRACH Configuration.

Remote command:

CONFigure[:​LTE]:​UL:​PRACh:​CONF


Restricted Set

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining the PRACH Structure > Restricted Set
Restricted Set

Selects whether a restricted preamble set (high speed mode) or the unrestricted preamble set (normal mode) will be used.

Remote command:

CONFigure[:​LTE]:​UL:​PRACh:​RSET


Frequency Offset

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining the PRACH Structure > Frequency Offset
Frequency Offset

For preamble formats 0-3, sets the PRACH Frequency Offset as defined in the 3GPP TS 36.211, i.e. determines the first physical resource block available for PRACH expressed as a physical resource block number.

Remote command:

CONFigure[:​LTE]:​UL:​PRACh:​FOFFset


PRACH Preamble Mapping

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining the PRACH Structure > PRACH Preamble Mapping
PRACH Preamble Mapping

The frequency resource index fRA and the half frame indicator t1RA are neccessary to clearly specify the physical resource mapping of the PRACH in case a PRACH configuration index has more than one mapping alternative.

If you turn on the "Auto Preamble Mapping", the software automatically detects fRA and t1RA.

The values for both parameters are defined in table '5.7.1-4: Frame structure type 2 random access preamble mapping in time and frequency' (3GPP TS 36.211 v10.2.0).

The frequency resource index and half frame indicator are available in TDD mode.

Remote command:

CONFigure[:​LTE]:​UL:​PRACh:​APM

CONFigure[:​LTE]:​UL:​PRACh:​FRINdex

CONFigure[:​LTE]:​UL:​PRACh:​HFINdicator


Ncs Conf

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining the PRACH Structure > Ncs Conf
Ncs Conf

Selects the Ncs configuration, i.e. determines the Ncs value set according to TS 36.211, table 5.7.2.-2 and 5.7.2-3.

Remote command:

CONFigure[:​LTE]:​UL:​PRACh:​NCSC


Logical Root Sequ. Idx

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining the PRACH Structure > Logical Root Sequ. Idx
Logical Root Sequ. Idx

Selects the logical root sequence index.

The logical root sequence index is used to generate preamble sequences. It is provided by higher layers.

Remote command:

CONFigure[:​LTE]:​UL:​PRACh:​RSEQ


Sequence Index (v)

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining the PRACH Structure > Sequence Index (v)
Sequence Index (v)

Defines the sequence index (v).

The sequence index controls which of the 64 preambles available in a cell is used.

If you select the "Auto" menu item, the software automatically selects the required sequence index.

Remote command:

CONFigure[:​LTE]:​UL:​PRACh:​SINDex


Selecting the Input and Output Source

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Selecting the Input and Output Source
Selecting the Input and Output Source

The application supports several input sources and outputs.

For a comprehensive description of the supported input sources please refer to the documentation of the R&S FSW base unit ("Data Input and Output" ).


Defining Level Characteristics

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining Level Characteristics
Defining Level Characteristics

Amplitude settings define the expected level characteristics of the signal at the RF input.

└ Defining a Reference Level
└ Attenuating the Signal
└ Preamplifier (option B24)
└ Input Coupling
└ Impedance


Defining a Reference Level

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining Level Characteristics > Defining a Reference Level
Defining a Reference Level

The reference level is the power level the analyzer expects at the RF input. Keep in mind that the power level at the RF input is the peak envelope power in case of signals with a high crest factor like LTE.

To get the best dynamic range, you have to set the reference level as low as possible. At the same time, make sure that the maximum signal level does not exceed the reference level. If it does, it will overload the A/D converter, regardless of the signal power. Measurement results may deteriorate (e.g. EVM). This applies especially for measurements with more than one active channel near the one you are trying to measure (± 6 MHz).

Note that the signal level at the A/D converter may be stronger than the level the application displays, depending on the current resolution bandwidth. This is because the resolution bandwidths are implemented digitally after the A/D converter.

You can specify the reference level in several units and define an arithmetic level offset. A level offset is useful if the signal is attenuated or amplified before it is fed into the analyzer. All displayed power level results will be shifted by this value. Note however, that the reference value ignores the level offset. Thus, it is still mandatory to define the actual power level that the analyzer has to handle as the reference level.

You can also use automatic detection of the reference level with the "Auto Level" function.

If active, the application measures and sets the reference level to its ideal value.

Automatic level detection also optimizes RF attenuation.

The application shows the current reference level (including RF and external attenuation) in the channel bar.

Remote command:

Manual: DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel

Automatic: [SENSe:​]ADJust:​LEVel

Offset: DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel:​OFFSet

Unit: CALCulate<n>:​UNIT:​POWer


Attenuating the Signal

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining Level Characteristics > Attenuating the Signal
Attenuating the Signal

Attenuation of the signal may become necessary if you have to reduce the power of the signal that you have applied. Power reduction is necessary, for example, to prevent an overload of the input mixer.

The LTE measurement application provides several attenuation modes.

  • Mechanical (or RF) attenuation is always available. The mechanical attenuator controls attenuation at the RF input.
  • If you have equipped your R&S FSW with option R&S FSW-B25, it also provides electronic attenuation. Note that the frequency range may not exceed the specification of the electronic attenuator for it to work.
    For both methods, the application provides automatic detection of the ideal attenuation level. Alternatively, you can define the attenuation level manually. The range is from 0 dB to 79 dB (RF attenuation) or 30 dB (electronic attenuation) in 1 dB steps.

For more information on attenuating the signal see the manual of the R&S FSW.

The application shows the attenuation level (mechanical and electronic) in the channel bar.

Remote command:

RF attenuation: INPut:​ATTenuation

RF attenuation: INPut:​ATTenuation:​AUTO

Electronic attenuation: INPut<n>:​EATT:​STATe

Electronic attenuation: INPut<n>:​EATT:​AUTO

Electronic attenuation: INPut<n>:​EATT


Preamplifier (option B24)

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining Level Characteristics > Preamplifier (option B24)
Preamplifier (option B24)

If option R&S FSW-B24 is installed, a preamplifier can be activated for the RF input signal.

You can use a preamplifier to analyze signals from DUTs with low input power.

For R&S FSW 26 or higher models, the input signal is amplified by 30 dB if the preamplifier is activated.

For R&S FSW 8 or 13 models, the following settings are available:

"Off" | Deactivates the preamplifier.
"15 dB" | The RF input signal is amplified by about 15 dB.
"30 dB" | The RF input signal is amplified by about 30 dB.
Remote command:

INPut:​GAIN:​STATe

INPut:​GAIN[:​VALue]


Input Coupling

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining Level Characteristics > Input Coupling
Input Coupling

The RF input of the R&S FSW can be coupled by alternating current (AC) or direct current (DC).

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17) or from the Analog Baseband Interface (R&S FSW-B71).

AC coupling blocks any DC voltage from the input signal. This is the default setting to prevent damage to the instrument. Very low frequencies in the input signal may be distorted.

However, some specifications require DC coupling. In this case, you must protect the instrument from damaging DC input voltages manually. For details, refer to the data sheet.

Remote command:

INPut:​COUPling


Impedance

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Defining Level Characteristics > Impedance
Impedance

The reference impedance for the measured levels of the R&S FSW can be set to 50 Ω or 75 Ω.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a 75 Ω adapter of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

This value also affects the unit conversion.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17) or from the Analog Baseband Interface (R&S FSW-B71). For analog baseband input, an impedance of 50 Ω is always used.

Remote command:

INPut:​IMPedance


Configuring the Data Capture

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring the Data Capture
Configuring the Data Capture

The data capture settings contain settings that control the data capture.

The data capture settings are part of the "Signal Capture" tab of the "Trigger/Signal Capture" dialog box.

└ Capture Time
└ Swap I/Q
└ Overall Frame Count
└ Auto According to Standard
└ Number of Frames to Analyze


Capture Time

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring the Data Capture > Capture Time
Capture Time

Defines the capture time.

The capture time corresponds to the time of one sweep. Hence, it defines the amount of data the application captures during one sweep.

By default, the application captures 20.1 ms of data to make sure that at least one complete LTE frame is captured in one sweep.

The application shows the current capture time in the channel bar.

Remote command:

[SENSe]:​SWEep:​TIME


Swap I/Q

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring the Data Capture > Swap I/Q
Swap I/Q

Swaps the real (I branch) and the imaginary (Q branch) parts of the signal.

Remote command:

[SENSe]:​SWAPiq


Overall Frame Count

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring the Data Capture > Overall Frame Count
Overall Frame Count

Turns the manual selection of the number of frames to capture (and analyze) on and off.

If the overall frame count is active, you can define a particular number of frames to capture and analyze. The measurement runs until all required frames have been analyzed, even if it takes more than one sweep. The results are an average of the captured frames.

If the overall frame count is inactive, the R&S FSW analyzes all complete LTE frames currently in the capture buffer.

The application shows the current frame count in the channel bar.

Remote command:

[SENSe][:​LTE]:​FRAMe:​COUNt:​STATe


Auto According to Standard

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring the Data Capture > Auto According to Standard
Auto According to Standard

Turns automatic selection of the number of frames to capture and analyze on and off.

If active, the R&S FSW evaluates the number of frames as defined for EVM tests in the LTE standard.

If inactive, you can set the number of frames you want to analyze.

This parameter is not available if the overall frame count is inactive.

Remote command:

[SENSe][:​LTE]:​FRAMe:​COUNt:​AUTO


Number of Frames to Analyze

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Configuring the Data Capture > Number of Frames to Analyze
Number of Frames to Analyze

Sets the number of frames that you want to capture and analyze.

If the number of frames you have set last longer than a single sweep, the R&S FSW continues the measurement until all frames have been captured.

The parameter is read only if

  • the overall frame count is inactive,
  • the data is captured according to the standard.
Remote command:

[SENSe][:​LTE]:​FRAMe:​COUNt


Triggering Measurements

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Triggering Measurements
Triggering Measurements

The trigger functionality of the LTE measurement application is the same as that of the R&S FSW. For a comprehensive description of the available trigger settings see the documentation of the R&S FSW.

Note that some trigger sources available in Spectrum mode are not available in the LTE application. Note also that the Preview and Gate functionality are only available for frequency sweep measurements (ACLR and SEM).

Gated frequency sweep measurements

The application automatically selects the correct gate settings (delay and length) according to the TDD configuration.

The trigger settings are part of the "Trigger" tab of the "Trigger/Signal Capture" dialog box.

For more information on triggering measurements see "Trigger and Gate Configuration" .


Tracking

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Tracking
Tracking

The tracking settings contain settings that compensate for various common measurement errors that may occur.

└ Phase
└ Timing


Phase

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Tracking > Phase
Phase

Specifies whether or not the measurement results should be compensated for common phase error. When phase compensation is used, the measurement results will be compensated for phase error on a per-symbol basis.

"Off" | Phase tracking is not applied.
"Pilot Only" | Only the reference signal is used for the estimation of the phase error.
"Pilot and Payload" | Both reference signal and payload resource elements are used for the estimation of the phase error.
Remote command:

[SENSe][:​LTE]:​UL:​TRACking:​PHASe


Timing

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Tracking > Timing
Timing

Specifies whether or not the measurement results should be compensated for timing error. When timing compensation is used, the measurement results will be compensated for timing error on a per-symbol basis.

Remote command:

[SENSe][:​LTE]:​UL:​TRACking:​TIME


Signal Demodulation

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Signal Demodulation
Signal Demodulation
└ Analysis Mode
└ Channel Estimation Range
└ EVM with Exclusion Period
└ Analyze TDD Transient Slots
└ Compensate DC Offset
└ Scrambling of Coded Bits
└ Suppressed Interference Synchronization
└ Multicarrier Filter


Analysis Mode

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Signal Demodulation > Analysis Mode
Analysis Mode

Selects the channel analysis mode.

You can select from "PUSCH/PUCCH" mode and "PRACH" mode.

PUSCH/PUCCH mode analyzes the PUSCH and PUCCH. This is the default.

PRACH mode analyzes the PRACH only. In PRACH analysis mode no subframe or slot selection is available. Instead you can select a particular preamble that the results are shown for. Note that PRACH analysis mode does not support all result displays.

Remote command:

[SENSe][:​LTE]:​UL:​DEMod:​MODE


Channel Estimation Range

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Signal Demodulation > Channel Estimation Range
Channel Estimation Range

Selects the method for channel estimation.

You can select if only the pilot symbols are used to perform channel estimation or if both pilot and payload carriers are used.

Remote command:

[SENSe][:​LTE]:​UL:​DEMod:​CESTimation


EVM with Exclusion Period

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Signal Demodulation > EVM with Exclusion Period
EVM with Exclusion Period

Turns exclusion periods for EVM measurements as defined in 3GPP TS 36.521 on and off.

The exclusion period affects the PUSCH data EVM of the first and last symbol.

The software automatically determines the length of the exclusion period according to 3GPP TS 36.521-1.

The exclusion period has no effect on the EVM vs Carrier and EVM vs Symbol x Carrier result displays.

Remote command:

[SENSe][:​LTE]:​UL:​DEMod:​EEPeriod


Analyze TDD Transient Slots

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Signal Demodulation > Analyze TDD Transient Slots
Analyze TDD Transient Slots

Includes or excludes the transient slots present after a switch from downlink to uplink in the analysis.

If on, the transient slots are not included in the measurement.

Remote command:

[SENSe][:​LTE]:​UL:​DEMod:​ATTSlots


Compensate DC Offset

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Signal Demodulation > Compensate DC Offset
Compensate DC Offset

Turns DC offset compensation when calculating measurement results on and off.

According to 3GPP TS 36.101 (Annex F.4), the R&S FSW removes the carrier leakage (I/Q origin offset) from the evaluated signal before it calculates the EVM and in-band emissions.

Remote command:

[SENSe][:​LTE]:​UL:​DEMod:​CDCoffset


Scrambling of Coded Bits

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Signal Demodulation > Scrambling of Coded Bits
Scrambling of Coded Bits

Turns the scrambling of coded bits for the PUSCH on and off.

The scrambling of coded bits affects the bitstream results.

Source for bitstream results if scrambling for coded bits is on and off
Remote command:

[SENSe][:​LTE]:​UL:​DEMod:​CBSCrambling


Suppressed Interference Synchronization

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Signal Demodulation > Suppressed Interference Synchronization
Suppressed Interference Synchronization

Turns suppressed interference synchronization on and off.

If active, the synchronization on signals containing more than one user equipment (UE) is more robust. Additionally, the EVM is lower in case the UEs have different frequency offsets. Note that Auto Demodulation is not supported in this synchronization mode and the EVM may be higher in case only one UE is present in the signal.

Remote command:

[SENSe][:​LTE]:​UL:​DEMod:​SISYnc


Multicarrier Filter

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring I/Q Measurements > Signal Demodulation > Multicarrier Filter
Multicarrier Filter

Turns the suppression of interference of neighboring carriers on and off.

Remote command:

[SENSe][:​LTE]:​UL:​DEMod:​MCFilter


Configuring Frequency Sweep Measurements

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring Frequency Sweep Measurements
Configuring Frequency Sweep Measurements

After starting one of the frequency sweep measurements, the application automatically loads the configuration required by measurements according to the 3GPP standard: the spectral mask as defined in the 3GPP standard for SEM measurements and the channel configuration defined in the standard for the ACLR measurement.

If you need a different measurement configuration, you can change all parameters as required. Except for the dialog box decribed below, the measurement configuration menus for the frequency sweep measurements are the same as in the Spectrum application.

Please refer to the User Manual of the R&S FSW for a detailed description on how to configure ACLR and SEM measurements.

Contents
  • ACLR Signal Description
  • SEM Signal Description
  • MC ACLR Signal Description


ACLR Signal Description

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring Frequency Sweep Measurements > ACLR Signal Description
ACLR Signal Description

The signal description for ACLR measurements contains settings to describe general physical characteristics of the signal you are measuring.

►

Press the MEAS CONFIG key.

►

Press the "Signal Description" softkey.

The application opens the "Signal Description" dialog box.

For more information on the LTE Mode, Test Model and Channel Bandwidth see "Selecting the LTE Mode", "Using Test Models" and "Channel Bandwidth / Number of Resource Blocks".

└ Assumed Adjacent Channel Carrier


Assumed Adjacent Channel Carrier

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring Frequency Sweep Measurements > ACLR Signal Description > Assumed Adjacent Channel Carrier
Assumed Adjacent Channel Carrier

Selects the assumed adjacent channel carrier for the ACLR measurement.

The supported types are EUTRA of same bandwidth, 1.28 Mcps UTRA, 3.84 Mcps UTRA and 7.68 Mcps UTRA.

Note that not all combinations of LTE Channel Bandwidth settings and Assumed Adj. Channel Carrier settings are defined in the 3GPP standard.

Remote command:

[SENSe]:​POWer:​ACHannel:​AACHannel


SEM Signal Description

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring Frequency Sweep Measurements > SEM Signal Description
SEM Signal Description

The signal description for SEM measurements contains settings to describe general physical characteristics of the signal you are measuring.

►

Press the MEAS CONFIG key.

►

Press the "Signal Description" softkey.

The application opens the "Signal Description" dialog box.

For more information on the LTE Mode, Test Model, Channel Bandwidth and Cyclic Prefix see "Selecting the LTE Mode", "Using Test Models", "Channel Bandwidth / Number of Resource Blocks" and "Cyclic Prefix".

└ SEM Requirement


SEM Requirement

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring Frequency Sweep Measurements > SEM Signal Description > SEM Requirement
SEM Requirement

Selects the type of spectrum emission mask used for the Out of Band emission measurement.

The software supports general and specific (additional) spectrum emission masks. The specific spectrum emission masks contain additional SEM requirements. The additional requirements masks to use for the measurement depend on the network signalled value "NS_03", "NS_04", "NS_06" or "NS_07".

If "NS_06" or "NS_07" is indicated in the cell, use SEM requirement "NS_06_07".

Remote command:

[SENSe]:​POWer:​SEM:​UL:​REQuirement


MC ACLR Signal Description

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring Frequency Sweep Measurements > MC ACLR Signal Description
MC ACLR Signal Description

The signal description for MC ACLR measurements contain settings to describe general physical characteristics of the signal you are measuring.

►

Press the MEAS CONFIG key.

►

Press the "Signal Description" softkey.

The application opens the "Signal Description" dialog box.

You can configure the characteristics of the carriers in the "Carrier Configuration" tab.

Note: the "Carrier Configuration" button in the "Physical Settings" tab also opens the "Carrier Configuration" tab.

For more information on the LTE Mode, Test Model, Channel Bandwidth and Cyclic Prefix see "Selecting the LTE Mode", "Using Test Models", "Channel Bandwidth / Number of Resource Blocks" and "Cyclic Prefix".

└ Carrier Aggregation


Carrier Aggregation

LTE Uplink (R&S FSW-K10x) > Configuration > Configuring Frequency Sweep Measurements > MC ACLR Signal Description > Carrier Aggregation
Carrier Aggregation

The application allows you to define different characteristics for each carrier in the system (the number of component carriers is always "2" for MC ACLR measurements).

The center frequency defines the carrier frequency of the first carrier. The center frequency of the second carrier is calculated automatically based on the bandwidths you have selected for both carriers. For the second carrier, the application also shows the frequency offset relative to the center frequency of the first carrier. If you define a different frequency offset, the application adjusts the center frequency accordingly. Note that the actual measurement frequency differs from the two carrier frequencies: the application calculates that frequency based on the two carrier frequencies. It is somewhere in between the two carrier frequencies. The measurement frequency is displayed at the bottom of the diagram area.

Selecting the channel bandwidths of each carrier is possible in two ways.
  • Predefined bandwidth combinations
    Select a typical combination of channel bandwidths from the dropdown menu.
    This way, you just have to define the center frequency of the first carrier. The application calculates the rest of the frequency characteristics.
  • User Defined
    Select "User Defined" from the dropdown menu to test a system with channel bandwidths not in the list of predefined combinations.
    When you select a user defined combination, you can select the channel bandwidth for each carrier from the "Bandwidth" dropdown menus.

The diagram at the bottom of the dialog box represents the current configuration. When you change the bandwidth of a carrier (represented by blue bars), the application adjusts the bandwidth of the carriers in the diagram accordingly. The characteristics of the neighboring channels are defined in 3GPP 36.251.

Remote command:

Carrier frequency: [SENSe]:​FREQuency:​CENTer[:​CC<cci>]

Measurement frequency: SENSe:FREQuency:CENTer?

Offset: [SENSe]:​FREQuency:​CENTer:​CC<cci>:​OFFSet

Channel bandwidth: CONFigure[:​LTE]:​UL:​CABW

Channel bandwidth: CONFigure[:​LTE]:​UL[:​CC<cci>]:​BW


Analysis

LTE Uplink (R&S FSW-K10x) > Analysis
Analysis
Contents
  • Configuring Tables / Numerical Results
  • Analyzing I/Q Measurements
  • Analyzing Frequency Sweep Measurements


Configuring Tables / Numerical Results

LTE Uplink (R&S FSW-K10x) > Analysis > Configuring Tables / Numerical Results
Configuring Tables / Numerical Results

The application allows you to customize the number of columns for some numeric result displays, for example the Allocation Summary.

►

Tap somewhere in the header row of the table.

The application opens a dialog box to add or remove columns.


Analyzing I/Q Measurements

LTE Uplink (R&S FSW-K10x) > Analysis > Analyzing I/Q Measurements
Analyzing I/Q Measurements
Contents
  • Evaluation Range
  • Scale
  • Result Settings
  • Markers


Evaluation Range

LTE Uplink (R&S FSW-K10x) > Analysis > Analyzing I/Q Measurements > Evaluation Range
Evaluation Range

The evaluation range defines the signal parts that are considered during signal analysis.

└ Subframe Selection
└ Slot Selection
└ Preamble Selection
└ Evaluation Range for the Constellation Diagram


Subframe Selection

LTE Uplink (R&S FSW-K10x) > Analysis > Analyzing I/Q Measurements > Evaluation Range > Subframe Selection
Subframe Selection

Selects a particular subframe whose results the application displays.

You can select a particular subframe for the following measurements.

Result Summary, EVM vs. Carrier, EVM vs. Symbol, EVM vs. Symbol x Carrier, Inband Emission, Channel Flatness, Spectrum Flatness SRS, Channel Group Delay, Spectrum Flatness Difference, Power vs Symbol x Carrier, Constellation Diagram, DFT Precoded Constellation, Allocation Summary, Bit Stream and Time Alignment. If ---All--- is selected, either the results from all subframes are displayed at once or a statistic is calculated over all analyzed subframes.

Selecting "All" either displays the results over all subframes or calculates a statistic over all subframes that have been analyzed.

Example: Subframe selection

If you select all subframes ("All"), the application shows three traces. One trace shows the subframe with the minimum level characteristics, the second trace shows the subframe with the maximum level characteristics and the third subframe shows the averaged level characteristics of all subframes.

  • PK: peak value
  • AV: average value
  • MI: minimum value

If you select a specific subframe, the application shows one trace. This trace contains the results for that subframe only.

Remote command:

[SENSe][:​LTE]:​SUBFrame:​SELect


Slot Selection

LTE Uplink (R&S FSW-K10x) > Analysis > Analyzing I/Q Measurements > Evaluation Range > Slot Selection
Slot Selection

Selects a particular slot whose measurement results you want to see.

You can select a particular slot for the following measurements.

Result Summary, EVM vs Carrier, EVM vs Symbol, EVM vs Symbol x Carrier, Inband Emission, Channel Flatness, Spectrum Flatness SRS, Channel Group Delay, Spectrum Flatness Difference, Power vs Symbol x Carrier, Constellation Diagram, DFT Precoded Constellation Diagram and Time Alignment.

In PRACH analysis mode, you can not select a particular slot.

Remote command:

[SENSe][:​LTE]:​SLOT:​SELect


Preamble Selection

LTE Uplink (R&S FSW-K10x) > Analysis > Analyzing I/Q Measurements > Evaluation Range > Preamble Selection
Preamble Selection

Selects a particular preamble for measurements that analyze individual preambles.

Selecting preambles is available in PRACH analysis mode.

Remote command:

[SENSe][:​LTE]:​PREamble:​SELect


Evaluation Range for the Constellation Diagram

LTE Uplink (R&S FSW-K10x) > Analysis > Analyzing I/Q Measurements > Evaluation Range > Evaluation Range for the Constellation Diagram
Evaluation Range for the Constellation Diagram

The "Evaluation Range" dialog box defines the type of constellation points that are displayed in the Constellation Diagram.

By default the application displays all constellation points of the data that have been evaluated. However, you can filter the results by several aspects.

  • Modulation
    Filters the results to include only the selected type of modulation.
  • Allocation
    Filters the results to include only a particular type of allocation.
  • Symbol
    Filters the results to include only a particular OFDM symbol.
  • Carrier
    Filters the results to include only a particular subcarrier.

The result display is updated as soon as you make the changes.

Note that the constellation selection is applied to all windows in split screen mode if the windows contain constellation diagrams.

Remote command:

Modulation: [SENSe][:​LTE]:​MODulation:​SELect

Allocation: [SENSe][:​LTE]:​ALLocation:​SELect

Symbol: [SENSe][:​LTE]:​SYMBol:​SELect

Carrier: [SENSe][:​LTE]:​CARRier:​SELect


Scale

LTE Uplink (R&S FSW-K10x) > Analysis > Analyzing I/Q Measurements > Scale
Scale
└ Y-Axis Scale


Y-Axis Scale

LTE Uplink (R&S FSW-K10x) > Analysis > Analyzing I/Q Measurements > Scale > Y-Axis Scale
Y-Axis Scale

The y-axis scaling determines the vertical resolution of the measurement results. The scaling you select always applies to the currently active screen and the corresponding result display.

Usually, the best way to view the results is if they fit ideally in the diagram area in order to view the complete trace. This is the way the application scales the y-axis if you are using the automatic scale function.

But it may become necessary to see a more detailed version of the results. In that case, turn on fixed scaling for the y-axis by defining the minimum and maximum values displayed on the vertical axis. Possible values and units depend on the result display you want to adjust the scale of.

You can restore the default scale at any time with "Restore Scale".

Tip:

Alternatively, you can scale the windows in the "Auto Set" menu. In addition to scaling the window currently in focus ("Auto Scale Window"), there you can scale all windows at the same time ("Auto Scale All").

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​AUTO ONCE

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​MAXimum

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​MINimum


Result Settings

LTE Uplink (R&S FSW-K10x) > Analysis > Analyzing I/Q Measurements > Result Settings
Result Settings

Result settings define the way certain measurement results are displayed.

└ EVM Unit
└ Bit Stream Format
└ Carrier Axes
└ Subwindow Coupling
└ Marker Coupling


EVM Unit

LTE Uplink (R&S FSW-K10x) > Analysis > Analyzing I/Q Measurements > Result Settings > EVM Unit
EVM Unit

Selects the unit for graphic and numerical EVM measurement results.

Possible units are dB and %.

Remote command:

UNIT:​EVM


Bit Stream Format

LTE Uplink (R&S FSW-K10x) > Analysis > Analyzing I/Q Measurements > Result Settings > Bit Stream Format
Bit Stream Format

Selects the way the bit stream is displayed.

The bit stream is either a stream of raw bits or of symbols. In case of the symbol format, the bits that belong to a symbol are shown as hexadecimal numbers with two digits.

Examples:

Bit stream display in uplink application if the bit stream format is set to "symbols"
Bit stream display in uplink application if the bit stream format is set to "bits"
Remote command:

UNIT:​BSTR


Carrier Axes

LTE Uplink (R&S FSW-K10x) > Analysis > Analyzing I/Q Measurements > Result Settings > Carrier Axes
Carrier Axes

Selects the scale of the x-axis for result displays that show results of OFDM subcarriers.

  • X-axis shows the frequency of the subcarrier
  • X-axis shows the number of the subcarrier
Remote command:

UNIT:​CAXes


Subwindow Coupling

LTE Uplink (R&S FSW-K10x) > Analysis > Analyzing I/Q Measurements > Result Settings > Subwindow Coupling
Subwindow Coupling

Couples or decouples result display tabs (subwindows).

If the coupling is on and you select another tab in a result display, the application automatically selects the same tab for all result displays

Subwindow coupling is available for measurements with multiple data streams (MIMO).


Marker Coupling

LTE Uplink (R&S FSW-K10x) > Analysis > Analyzing I/Q Measurements > Result Settings > Marker Coupling
Marker Coupling

Couples or decouples markers that are active in multiple result displays.

When you turn this feature on, the application moves the marker to its new position in all active result displays.

When you turn it off, you can move the markers in different result displays independent from each other.

Remote command:

CALCulate:​MARKer:​COUPling


Markers

LTE Uplink (R&S FSW-K10x) > Analysis > Analyzing I/Q Measurements > Markers
Markers

Markers are available for most of the I/Q measurement result displays and for the frequency sweep measurements. The functionality (setting and positioning) is the same as in Spectrum mode.

Markers in result displays with a third aspect

In result displays that have a third dimension (EVM vs Symbol x Carrier etc.), you can position a marker on a particular symbol in a particular carrier.

When you activate a marker, you can select the symbol and carrier you want to position the marker on. Alternatively, you can define the marker position in the "Marker Configuration" dialog box, which is expanded accordingly.

Marker Configuration dialog, the "Carrier" firld is only available for result displays with a third dimension.

For a comprehensive description of the marker functionality see the corresponding chapters in the documentation of the R&S FSW.


Analyzing Frequency Sweep Measurements

LTE Uplink (R&S FSW-K10x) > Analysis > Analyzing Frequency Sweep Measurements
Analyzing Frequency Sweep Measurements

The LTE application supports the same functionality to analyze the results of frequency sweep measurements (Spectrum Emission mask and Adjacent Channel Leakage Ratio) as the R&S FSW base unit does for those measurements.

Please refer to the User Manual of the R&S FSW for a detailed description on how to analyze ACLR and SEM measurements.


Remote Control

LTE Uplink (R&S FSW-K10x) > Remote Control
Remote Control

The following remote control commands are required to configure and perform noise figure measurements in a remote environment. The R&S FSW must already be set up for remote operation in a network as described in the base unit manual.

Universal functionality

Note that basic tasks that are also performed in the base unit in the same way are not described here. For a description of such tasks, see the R&S FSW User Manual.

In particular, this includes:

  • Managing Settings and Results, i.e. storing and loading settings and result data.
  • Basic instrument configuration, e.g. checking the system configuration, customizing the screen layout, or configuring networks and remote operation.
  • Using the common status registers (specific status registers for Pulse measurements are not used).
Contents
  • Overview of Remote Command Suffixes
  • Introduction
  • Remote Commands to Select the LTE Application
  • General Window Commands
  • Working with Windows in the Display
  • Performing Measurements
  • Remote Commands to Read Trace Data
  • Remote Commands to Read Numeric Results
  • Remote Commands to Read Limit Check Results
  • Remote Commands to Configure the Application
  • Analysis


Overview of Remote Command Suffixes

LTE Uplink (R&S FSW-K10x) > Remote Control > Overview of Remote Command Suffixes
Overview of Remote Command Suffixes

The remote commands for the LTE Measurement application support the following suffixes.

Suffix | Description
<allocation> | Selects an allocation.
<analyzer> | No effect.
<antenna> | Selects an antenna for MIMO measurements.
<cluster> | Selects a cluster (uplink only).
<cwnum> | Selects a codeword.
<k> | Selects a limit line. Irrelevant for the LTE application.
<m> | Selects a marker.
<n> | Selects a measurement window.
<subframe> | Selects a subframe.
<t> | Selects a trace. Irrelevant for the LTE application.


Introduction

LTE Uplink (R&S FSW-K10x) > Remote Control > Introduction
Introduction

Commands are program messages that a controller (e.g. a PC) sends to the instrument or software. They operate its functions ('setting commands' or 'events') and request information ('query commands'). Some commands can only be used in one way, others work in two ways (setting and query). If not indicated otherwise, the commands can be used for settings and queries.

The syntax of a SCPI command consists of a header and, in most cases, one or more parameters. To use a command as a query, you have to append a question mark after the last header element, even if the command contains a parameter.

A header contains one or more keywords, separated by a colon. Header and parameters are separated by a "white space" (ASCII code 0 to 9, 11 to 32 decimal, e.g. blank). If there is more than one parameter for a command, these are separated by a comma from one another.

Only the most important characteristics that you need to know when working with SCPI commands are described here. For a more complete description, refer to the User Manual of the R&S FSW.

Remote command examples

Note that some remote command examples mentioned in this general introduction may not be supported by this particular application.

Contents
  • Long and Short Form
  • Numeric Suffixes
  • Optional Keywords
  • Alternative Keywords
  • SCPI Parameters


Long and Short Form

LTE Uplink (R&S FSW-K10x) > Remote Control > Introduction > Long and Short Form
Long and Short Form

The keywords have a long and a short form. You can use either the long or the short form, but no other abbreviations of the keywords.

The short form is emphasized in upper case letters. Note however, that this emphasis only serves the purpose to distinguish the short from the long form in the manual. For the instrument, the case does not matter.

Example:

SENSe:FREQuency:CENTer is the same as SENS:FREQ:CENT.


Numeric Suffixes

LTE Uplink (R&S FSW-K10x) > Remote Control > Introduction > Numeric Suffixes
Numeric Suffixes

Some keywords have a numeric suffix if the command can be applied to multiple instances of an object. In that case, the suffix selects a particular instance (e.g. a measurement window).

Numeric suffixes are indicated by angular brackets (<n>) next to the keyword.

If you don't quote a suffix for keywords that support one, a 1 is assumed.

Example:

DISPlay[:WINDow<1...4>]:ZOOM:STATe enables the zoom in a particular measurement window, selected by the suffix at WINDow.

DISPlay:WINDow4:ZOOM:STATe ON refers to window 4.


Optional Keywords

LTE Uplink (R&S FSW-K10x) > Remote Control > Introduction > Optional Keywords
Optional Keywords

Some keywords are optional and are only part of the syntax because of SCPI compliance. You can include them in the header or not.

Note that if an optional keyword has a numeric suffix and you need to use the suffix, you have to include the optional keyword. Otherwise, the suffix of the missing keyword is assumed to be the value 1.

Optional keywords are emphasized with square brackets.

Example:

Without a numeric suffix in the optional keyword:

[SENSe:]FREQuency:CENTer is the same as FREQuency:CENTer

With a numeric suffix in the optional keyword:

DISPlay[:WINDow<1...4>]:ZOOM:STATe

DISPlay:ZOOM:STATe ON enables the zoom in window 1 (no suffix).

DISPlay:WINDow4:ZOOM:STATe ON enables the zoom in window 4.


Alternative Keywords

LTE Uplink (R&S FSW-K10x) > Remote Control > Introduction > Alternative Keywords
Alternative Keywords

A vertical stroke indicates alternatives for a specific keyword. You can use both keywords to the same effect.

Example:

[SENSe:]BANDwidth|BWIDth[:RESolution]

In the short form without optional keywords, BAND 1MHZ would have the same effect as BWID 1MHZ.


SCPI Parameters

LTE Uplink (R&S FSW-K10x) > Remote Control > Introduction > SCPI Parameters
SCPI Parameters

Many commands feature one or more parameters.

If a command supports more than one parameter, these are separated by a comma.

Example:

LAYout:ADD:WINDow Spectrum,LEFT,MTABle

Parameters may have different forms of values.

Contents
  • Numeric Values
  • Boolean
  • Character Data
  • Character Strings
  • Block Data


Numeric Values

LTE Uplink (R&S FSW-K10x) > Remote Control > Introduction > SCPI Parameters > Numeric Values
Numeric Values

Numeric values can be entered in any form, i.e. with sign, decimal point or exponent. In case of physical quantities, you can also add the unit. If the unit is missing, the command uses the basic unit.

Example:

with unit: SENSe:FREQuency:CENTer 1GHZ

without unit: SENSe:FREQuency:CENTer 1E9 would also set a frequency of 1 GHz.

Values exceeding the resolution of the instrument are rounded up or down.

If the number you have entered is not supported (e.g. in case of discrete steps), the command returns an error.

Instead of a number, you can also set numeric values with a text parameter in special cases.

  • MIN/MAX
    Defines the minimum or maximum numeric value that is supported.
  • DEF
    Defines the default value.
  • UP/DOWN
    Increases or decreases the numeric value by one step. The step size depends on the setting. In some cases you can customize the step size with a corresponding command.
Querying numeric values

When you query numeric values, the system returns a number. In case of physical quantities, it applies the basic unit (e.g. Hz in case of frequencies). The number of digits after the decimal point depends on the type of numeric value.

Example:

Setting: SENSe:FREQuency:CENTer 1GHZ

Query: SENSe:FREQuency:CENTer? would return 1E9

In some cases, numeric values may be returned as text.

  • INF/NINF
    Infinity or negative infinity. Represents the numeric values 9.9E37 or -9.9E37.
  • NAN
    Not a number. Represents the numeric value 9.91E37. NAN is returned in case of errors.


Boolean

LTE Uplink (R&S FSW-K10x) > Remote Control > Introduction > SCPI Parameters > Boolean
Boolean

Boolean parameters represent two states. The "ON" state (logically true) is represented by "ON" or a numeric value 1. The "OFF" state (logically untrue) is represented by "OFF" or the numeric value 0.

Querying boolean parameters

When you query boolean parameters, the system returns either the value 1 ("ON") or the value 0 ("OFF").

Example:

Setting: DISPlay:WINDow:ZOOM:STATe ON

Query: DISPlay:WINDow:ZOOM:STATe? would return 1


Character Data

LTE Uplink (R&S FSW-K10x) > Remote Control > Introduction > SCPI Parameters > Character Data
Character Data

Character data follows the syntactic rules of keywords. You can enter text using a short or a long form. For more information see "Long and Short Form".

Querying text parameters

When you query text parameters, the system returns its short form.

Example:

Setting: SENSe:BANDwidth:RESolution:TYPE NORMal

Query: SENSe:BANDwidth:RESolution:TYPE? would return NORM


Character Strings

LTE Uplink (R&S FSW-K10x) > Remote Control > Introduction > SCPI Parameters > Character Strings
Character Strings

Strings are alphanumeric characters. They have to be in straight quotation marks. You can use a single quotation mark ( ' ) or a double quotation mark ( " ).

Example:

INSTRument:DELete 'Spectrum'


Block Data

LTE Uplink (R&S FSW-K10x) > Remote Control > Introduction > SCPI Parameters > Block Data
Block Data

Block data is a format which is suitable for the transmission of large amounts of data.

The ASCII character # introduces the data block. The next number indicates how many of the following digits describe the length of the data block. In the example the 4 following digits indicate the length to be 5168 bytes. The data bytes follow. During the transmission of these data bytes all end or other control signs are ignored until all bytes are transmitted. #0 specifies a data block of indefinite length. The use of the indefinite format requires a NL^END message to terminate the data block. This format is useful when the length of the transmission is not known or if speed or other considerations prevent segmentation of the data into blocks of definite length.


Remote Commands to Select the LTE Application

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Select the LTE Application
Remote Commands to Select the LTE Application
List of Commands
INSTrument:CREate:DUPLicate
INSTrument:CREate[:NEW]
INSTrument:CREate:REPLace
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]


INSTrument:CREate:DUPLicate

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Select the LTE Application > INSTrument:CREate:DUPLicate
INSTrument:CREate:DUPLicate

This command duplicates the currently selected measurement channel, i.e starts a new measurement channel of the same type and with the identical measurement settings. The name of the new channel is the same as the copied channel, extended by a consecutive number (e.g. "Spectrum" -> "Spectrum 2").

The channel to be duplicated must be selected first using the INST:SEL command.

(See INSTrument[:​SELect] ).

This command is not available if the MSRA Master channel is selected.

Example: | INST:SEL 'Spectrum' INST:CRE:DUPL Duplicates the channel named 'Spectrum' and creates a new measurement channel named 'Spectrum 2'.
Usage: | Event


INSTrument:CREate[:NEW]

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Select the LTE Application > INSTrument:CREate[:NEW]
INSTrument:CREate[:NEW] <ChannelType>, <ChannelName>

This command adds an additional measurement channel. The number of measurement channels you can configure at the same time depends on available memory.

Parameters:
<ChannelType>

Channel type of the new channel.

For a list of available channel types see INSTrument:​LIST?.

<ChannelName>

String containing the name of the channel. The channel name is displayed as the tab label for the measurement channel.

Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).

Example: INST:CRE SAN, 'Spectrum 2'

Adds an additional spectrum display named "Spectrum 2".

Example:

See "I/Q Analysis with Graphical Evaluation" .

Example:

See "Programming Example: Performing a Sequence of Measurements" .


INSTrument:CREate:REPLace

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Select the LTE Application > INSTrument:CREate:REPLace
INSTrument:CREate:REPLace <ChannelName1>,<ChannelType>,<ChannelName2>

This command replaces a measurement channel with another one.

Parameters:
<ChannelName1> | String containing the name of the measurement channel you want to replace.
<ChannelType> | Channel type of the new channel. For a list of available channel types see INSTrument:​LIST?.
<ChannelName2> | String containing the name of the new channel. Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).
Example: | INST:CRE:REPL 'Spectrum2',IQ,'IQAnalyzer' Replaces the channel named 'Spectrum2' by a new measurement channel of type 'IQ Analyzer' named 'IQAnalyzer'.


INSTrument:DELete

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Select the LTE Application > INSTrument:DELete
INSTrument:DELete <ChannelName>

This command deletes a measurement channel. If you delete the last measurement channel, the default "Spectrum" channel is activated.

Parameters:
<ChannelName> | String containing the name of the channel you want to delete. A measurement channel must exist in order to be able delete it.
Example: | INST:DEL 'Spectrum4' Deletes the spectrum channel with the name 'Spectrum4'.


INSTrument:LIST?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Select the LTE Application > INSTrument:LIST?
INSTrument:LIST?

This command queries all active measurement channels. This is useful in order to obtain the names of the existing measurement channels, which are required in order to replace or delete the channels.

Return values:
<ChannelType>, <ChannelName> | For each channel, the command returns the channel type and channel name (see tables below). Tip: to change the channel name, use the INSTrument:​REName command.
Example: | INST:LIST? Result for 3 measurement channels: 'ADEM','Analog Demod','IQ','IQ Analyzer','SANALYZER','Spectrum'
Usage: | Query only
Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode
Application | <ChannelType> Parameter | Default Channel Name*)
Spectrum | SANALYZER | Spectrum
I/Q Analyzer | IQ | IQ Analyzer
Pulse (R&S FSW-K6) | PULSE | Pulse
Analog Demodulation (R&S FSW-K7) | ADEM | Analog Demod
GSM (R&S FSW-K10) | GSM | GSM
Multi-Carrier Group Delay (R&S FSW-K17) | MCGD | MC Group Delay
Noise (R&S FSW-K30) | NOISE | Noise
Phase Noise (R&S FSW-K40) | PNOISE | Phase Noise
Transient Analysis (R&S FSW-K60) | TA | Transient Analysis
VSA (R&S FSW-K70) | DDEM | VSA
3GPP FDD BTS (R&S FSW-K72) | BWCD | 3G FDD BTS
3GPP FDD UE (R&S FSW-K73) | MWCD | 3G FDD UE
TD-SCDMA BTS (R&S FSW-K76) | BTDS | TD-SCDMA BTS
TD-SCDMA UE (R&S FSW-K77) | MTDS | TD-SCDMA UE
cdma2000 BTS (R&S FSW-K82) | BC2K | CDMA2000 BTS
cdma2000 MS (R&S FSW-K83) | MC2K | CDMA2000 MS
1xEV-DO BTS (R&S FSW-K84) | BDO | 1xEV-DO BTS
1xEV-DO MS (R&S FSW-K85) | MDO | 1xEV-DO MS
WLAN (R&S FSW-K91) | WLAN | WLAN
LTE (R&S FSW-K10x) | LTE | LTE
Realtime Spectrum (R&S FSW-K160R) | RTIM | Realtime Spectrum
Note: the default channel name is also listed in the table. If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel.


INSTrument:REName

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Select the LTE Application > INSTrument:REName
INSTrument:REName <ChannelName1>, <ChannelName2>

This command renames a measurement channel.

Parameters:
<ChannelName1> | String containing the name of the channel you want to rename.
<ChannelName2> | String containing the new channel name. Note that you can not assign an existing channel name to a new channel; this will cause an error.
Example: | INST:REN 'Spectrum2','Spectrum3' Renames the channel with the name 'Spectrum2' to 'Spectrum3'.


INSTrument[:SELect]

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Select the LTE Application > INSTrument[:SELect]
INSTrument[:SELect] <ChannelType>

This command selects a new measurement channel with the defined channel type.

Parameters:
<ChannelType> | LTE LTE measurement channel (R&S FSW-K10x)
Example: | INST LTE Selects the LTE application.


General Window Commands

LTE Uplink (R&S FSW-K10x) > Remote Control > General Window Commands
General Window Commands

The following commands are required to configure general window layout, independent of the application.

List of Commands
DISPlay:FORMat
DISPlay[:WINDow<n>]:SIZE


DISPlay:FORMat

LTE Uplink (R&S FSW-K10x) > Remote Control > General Window Commands > DISPlay:FORMat
DISPlay:FORMat <Format>

This command determines which tab is displayed.

Parameters:
<Format>
SPLit

Displays the MultiView tab with an overview of all active channels

(See "R&S MultiView" ).

SINGle

Displays the measurement channel that was previously focused.

*RST: SING
Example: DISP:FORM SPL


DISPlay[:WINDow<n>]:SIZE

LTE Uplink (R&S FSW-K10x) > Remote Control > General Window Commands > DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:SIZE <Size>

This command maximizes the size of the selected result display window temporarily. To change the size of several windows on the screen permanently, use the LAY:SPL command (see LAYout:​SPLitter).

Parameters:
<Size>
LARGe

Maximizes the selected window to full screen.

Other windows are still active in the background.

SMALl

Reduces the size of the selected window to its original size.

If more than one measurement window was displayed originally, these are visible again.

*RST: SMALl
Example: DISP:WIND2:LARG
Example:

See "Example 1: Adding and Arranging Windows" .


Working with Windows in the Display

LTE Uplink (R&S FSW-K10x) > Remote Control > Working with Windows in the Display
Working with Windows in the Display

The following commands are required to change the evaluation type and rearrange the screen layout for a measurement channel as you do using the SmartGrid in manual operation. Since the available evaluation types depend on the selected application, some parameters for the following commands also depend on the selected measurement channel.

List of Commands
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace


LAYout:ADD[:WINDow]?

LTE Uplink (R&S FSW-K10x) > Remote Control > Working with Windows in the Display > LAYout:ADD[:WINDow]?
LAYout:ADD[:WINDow]? <WindowName>,<Direction>,<WindowType>

This command adds a window to the display.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

To replace an existing window, use the LAYout:​REPLace[:​WINDow] command.

Parameters:
<WindowName>

String containing the name of the existing window the new window is inserted next to.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<Direction>
LEFT | RIGHt | ABOVe | BELow

Direction the new window is added relative to the existing window.

<WindowType>
text value

Type of result display (evaluation method) you want to add.

See the table below for available parameter values.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:ADD? '1',LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example:

For a detailed example see "Example 1: Adding and Arranging Windows" and "Example 2: Replacing and Removing Windows" .

Example:

See "Programming Example" .

Usage: Query only
Manual operation: See "Capture Buffer"
See "EVM vs Carrier"
See "EVM vs Symbol"
See "EVM vs Subframe"
See "Power Spectrum"
See "Inband Emission"
See "Spectrum Flatness"
See "Spectrum Flatness SRS"
See "Channel Group Delay"
See "Spectrum Flatness Difference"
See "Constellation Diagram"
See "CCDF"
See "Allocation Summary"
See "Bit Stream"
See "Result Summary"
See "Marker Table"
<WindowType> parameter values for LTE Uplink Measurement application
Parameter value | Window type
ASUM | Allocation Summary
BSTR | Bitstream
CBUF | Capture Buffer
CCDF | CCDF
CONS | Constellation Diagram
EVCA | EVM vs Carrier
EVSU | EVM vs Subframe
EVSY | EVM vs Symbol
FEVS | Frequency Error vs Symbol
GDEL | Group Delay
IE | Inband Emission
IEA | Inband Emission All
MTAB | Marker Table
PSPE | Power Spectrum
RSUM | Result Summary
SFD | Spectrum Flatness Difference
SFL | Spectrum Flatness
SFSR | Spectrum Flatness SRS


LAYout:CATalog[:WINDow]?

LTE Uplink (R&S FSW-K10x) > Remote Control > Working with Windows in the Display > LAYout:CATalog[:WINDow]?
LAYout:CATalog[:WINDow]?

This command queries the name and index of all active windows from top left to bottom right. The result is a comma-separated list of values for each window, with the syntax:

<WindowName_1>,<WindowIndex_1>..<WindowName_n>,<WindowIndex_n>

Return values:
<WindowName>
string

Name of the window.

In the default state, the name of the window is its index.

<WindowIndex>
numeric value

Index of the window.

Example: LAY:CAT?

Result:

'2',2,'1',1

Two windows are displayed, named '2' (at the top or left), and '1' (at the bottom or right).

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:IDENtify[:WINDow]?

LTE Uplink (R&S FSW-K10x) > Remote Control > Working with Windows in the Display > LAYout:IDENtify[:WINDow]?
LAYout:IDENtify[:WINDow]? <WindowName>

This command queries the index of a particular display window.

Note: to query the name of a particular window, use the LAYout:​WINDow<n>:​IDENtify? query.

Query parameters:
<WindowName> | String containing the name of a window.
Return values:
<WindowIndex> | Index number of the window.
Usage: | Query only


LAYout:REMove[:WINDow]

LTE Uplink (R&S FSW-K10x) > Remote Control > Working with Windows in the Display > LAYout:REMove[:WINDow]
LAYout:REMove[:WINDow] <WindowName>

This command removes a window from the display.

Parameters:
<WindowName>

String containing the name of the window.

In the default state, the name of the window is its index.

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Event


LAYout:REPLace[:WINDow]

LTE Uplink (R&S FSW-K10x) > Remote Control > Working with Windows in the Display > LAYout:REPLace[:WINDow]
LAYout:REPLace[:WINDow] <WindowName>,<WindowType>

This command replaces the window type (for example from "Diagram" to "Result Summary") of an already existing window while keeping its position, index and window name.

To add a new window, use the LAYout:​ADD[:​WINDow]? command.

Parameters:
<WindowName>

String containing the name of the existing window.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<WindowType>

Type of result display you want to use in the existing window.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Example: LAY:REPL:WIND '1',MTAB

Replaces the result display in window 1 with a marker table.

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:SPLitter

LTE Uplink (R&S FSW-K10x) > Remote Control > Working with Windows in the Display > LAYout:SPLitter
LAYout:SPLitter <Index1>,<Index2>,<Position>

This command changes the position of a splitter and thus controls the size of the windows on each side of the splitter.

As opposed to the DISPlay[:​WINDow<n>]:​SIZE command, the LAYout:SPLitter changes the size of all windows to either side of the splitter permanently, it does not just maximize a single window temporarily.

Note that windows must have a certain minimum size. If the position you define conflicts with the minimum size of any of the affected windows, the command will not work, but does not return an error.

SmartGrid coordinates for remote control of the splitters
Parameters:
<Index1>

The index of one window the splitter controls.

<Index2>

The index of a window on the other side of the splitter.

<Position>

New vertical or horizontal position of the splitter as a fraction of the screen area (without channel and status bar and softkey menu).

The point of origin (x = 0, y = 0) is in the lower left corner of the screen. The end point (x = 100, y = 100) is in the upper right corner of the screen. (See figure "SmartGrid coordinates for remote control of the splitters".)

The direction in which the splitter is moved depends on the screen layout. If the windows are positioned horizontally, the splitter also moves horizontally. If the windows are positioned vertically, the splitter also moves vertically.

Range: 0 to 100
Example: LAY:SPL 1,3,50

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Table') to the center (50%) of the screen, i.e. in the figure above, to the left.

Example: LAY:SPL 1,4,70

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Peak List') towards the top (70%) of the screen.

The following commands have the exact same effect, as any combination of windows above and below the splitter moves the splitter vertically.

LAY:SPL 3,2,70
LAY:SPL 4,1,70
LAY:SPL 2,1,70
Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:WINDow<n>:ADD?

LTE Uplink (R&S FSW-K10x) > Remote Control > Working with Windows in the Display > LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:ADD? <Direction>,<WindowType>

This command adds a measurement window to the display. Note that with this command, the suffix <n> determines the existing window next to which the new window is added, as opposed to LAYout:​ADD[:​WINDow]?, for which the existing window is defined by a parameter.

To replace an existing window, use the LAYout:​WINDow<n>:​REPLace command.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

Parameters:
<Direction>
LEFT | RIGHt | ABOVe | BELow
<WindowType>

Type of measurement window you want to add.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:WIND1:ADD? LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:WINDow<n>:IDENtify?

LTE Uplink (R&S FSW-K10x) > Remote Control > Working with Windows in the Display > LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:IDENtify?

This command queries the name of a particular display window (indicated by the <n> suffix).

Note: to query the index of a particular window, use the LAYout:​IDENtify[:​WINDow]? command.

Return values:
<WindowName> | String containing the name of a window. In the default state, the name of the window is its index.
Usage: | Query only


LAYout:WINDow<n>:REMove

LTE Uplink (R&S FSW-K10x) > Remote Control > Working with Windows in the Display > LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REMove

This command removes the window specified by the suffix <n> from the display.

The result of this command is identical to the LAYout:​REMove[:​WINDow] command.

Usage: Event


LAYout:WINDow<n>:REPLace

LTE Uplink (R&S FSW-K10x) > Remote Control > Working with Windows in the Display > LAYout:WINDow<n>:REPLace
LAYout:WINDow<n>:REPLace <WindowType>

This command changes the window type of an existing window (specified by the suffix <n>).

The result of this command is identical to the LAYout:​REPLace[:​WINDow] command.

To add a new window, use the LAYout:​WINDow<n>:​ADD? command.

Parameters:
<WindowType>

Type of measurement window you want to replace another one with.

See LAYout:​ADD[:​WINDow]? for a list of available window types.


Performing Measurements

LTE Uplink (R&S FSW-K10x) > Remote Control > Performing Measurements
Performing Measurements
Contents
  • Measurements
  • Measurement Sequences


Measurements

LTE Uplink (R&S FSW-K10x) > Remote Control > Performing Measurements > Measurements
Measurements
List of Commands
ABORt
INITiate:CONTinuous
INITiate[:IMMediate]
[SENSe][:LTE]:OOPower:ATIMing
[SENSe]:SYNC[:STATe]?


ABORt

LTE Uplink (R&S FSW-K10x) > Remote Control > Performing Measurements > Measurements > ABORt
ABORt

This command aborts a current measurement and resets the trigger system.

To prevent overlapping execution of the subsequent command before the measurement has been aborted successfully, use the *OPC? or *WAI command after ABOR and before the next command.

For details see "Preventing Overlapping Execution" .

To abort a sequence of measurements by the Sequencer, use the INITiate:​SEQuencer:​ABORt command.

Note on blocked remote control programs:

If a sequential command cannot be completed, for example because a triggered sweep never receives a trigger, the remote control program will never finish and the remote channel to the R&S FSW is blocked for further commands. In this case, you must interrupt processing on the remote channel first in order to abort the measurement.

To do so, send a "Device Clear" command from the control instrument to the R&S FSW on a parallel channel to clear all currently active remote channels. Depending on the used interface and protocol, send the following commands:

  • Visa: viClear()
  • GPIB: ibclr()
  • RSIB: RSDLLibclr()

Now you can send the ABORt command on the remote channel performing the measurement.

Example: | ABOR;:INIT:IMM Aborts the current measurement and immediately starts a new one.
Example: | ABOR;*WAI INIT:IMM Aborts the current measurement and starts a new one once abortion has been completed.
Usage: | SCPI confirmed


INITiate:CONTinuous

LTE Uplink (R&S FSW-K10x) > Remote Control > Performing Measurements > Measurements > INITiate:CONTinuous
INITiate:CONTinuous <State>

This command controls the measurement mode.

Note that in single measurement mode, you can synchronize to the end of the measurement with *OPC, *OPC? or *WAI. In continuous measurement mode, synchronization to the end of the measurement is not possible. Thus, it is not recommended that you use continuous measurement mode in remote control, as results like trace data or markers are only valid after a single measurement end synchronization.

For details on synchronization see "Command Sequence and Synchronization"

If the measurement mode is changed for a measurement channel while the Sequencer is active (see INITiate:​SEQuencer:​IMMediate) the mode is only considered the next time the measurement in that channel is activated by the Sequencer.

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

Continuous measurement

OFF | 0

Single sweep

*RST: 1
Example: INIT:CONT OFF

Switches the measurement mode to single measurement.

INIT:CONT ON

Switches the measurement mode to continuous measurement.


INITiate[:IMMediate]

LTE Uplink (R&S FSW-K10x) > Remote Control > Performing Measurements > Measurements > INITiate[:IMMediate]
INITiate[:IMMediate]

This command starts a (single) new measurement.

You can synchronize to the end of the measurement with *OPC, *OPC? or *WAI.

For details on synchronization see "Command Sequence and Synchronization"

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .


[SENSe][:LTE]:OOPower:ATIMing

LTE Uplink (R&S FSW-K10x) > Remote Control > Performing Measurements > Measurements > [SENSe][:LTE]:OOPower:ATIMing
[SENSe][:LTE]:OOPower:ATIMing

This command adjusts the timing for On/Off Power measurements.

Example: | OOP:ATIM Adjusts the On/Off Power timing.
Usage: | Event


[SENSe]:SYNC[:STATe]?

LTE Uplink (R&S FSW-K10x) > Remote Control > Performing Measurements > Measurements > [SENSe]:SYNC[:STATe]?
[SENSe]:SYNC[:STATe]?

This command queries the current synchronization state.

Return values:
<State> | The string contains the following information. A zero represents a failure and a one represents a successful synchronization.
Example: | SYNC:STAT? Would return, e.g. '1' for successful synchronization.
Usage: | Query only


Measurement Sequences

LTE Uplink (R&S FSW-K10x) > Remote Control > Performing Measurements > Measurement Sequences
Measurement Sequences
List of Commands
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
SYSTem:SEQuencer


INITiate:SEQuencer:ABORt

LTE Uplink (R&S FSW-K10x) > Remote Control > Performing Measurements > Measurement Sequences > INITiate:SEQuencer:ABORt
INITiate:SEQuencer:ABORt

This command stops the currently active sequence of measurements. The Sequencer itself is not deactivated, so you can start a new sequence immediately using INITiate:​SEQuencer:​IMMediate.

To deactivate the Sequencer use SYSTem:​SEQuencer.

Usage: Event


INITiate:SEQuencer:IMMediate

LTE Uplink (R&S FSW-K10x) > Remote Control > Performing Measurements > Measurement Sequences > INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:IMMediate

This command starts a new sequence of measurements by the Sequencer. Its effect is similar to the INITiate[:​IMMediate] command used for a single measurement.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .

Usage: Event


INITiate:SEQuencer:MODE

LTE Uplink (R&S FSW-K10x) > Remote Control > Performing Measurements > Measurement Sequences > INITiate:SEQuencer:MODE
INITiate:SEQuencer:MODE <Mode>

This command selects the way the R&S FSW application performs measurements sequentially.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Note: In order to synchronize to the end of a sequential measurement using *OPC, *OPC? or *WAI you must use SINGle Sequence mode.

For details on the Sequencer see "The Sequencer Concept" .

For details on synchronization see "Command Sequence and Synchronization"

Parameters:
<Mode>
SINGle

Each measurement is performed once (regardless of the channel's sweep mode), considering each channels' sweep count, until all measurements in all active channels have been performed.

CONTinuous

The measurements in each active channel are performed one after the other, repeatedly (regardless of the channel's sweep mode), in the same order, until the Sequencer is stopped.

CDEFined

First, a single sequence is performed. Then, only those channels in continuous sweep mode (INIT:CONT ON) are repeated.

*RST: CONTinuous
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .


SYSTem:SEQuencer

LTE Uplink (R&S FSW-K10x) > Remote Control > Performing Measurements > Measurement Sequences > SYSTem:SEQuencer
SYSTem:SEQuencer <State>

This command turns the Sequencer on and off. The Sequencer must be active before any other Sequencer commands (INIT:SEQ...) are executed, otherwise an error will occur.

For details on the Sequencer see "The Sequencer Concept" .

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

The Sequencer is activated and a sequential measurement is started immediately.

OFF | 0

The Sequencer is deactivated. Any running sequential measurements are stopped. Further Sequencer commands (INIT:SEQ...) are not available.

*RST: 0
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single Sequencer mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

SYST:SEQ OFF
Example:

See "Programming Example: Performing a Sequence of Measurements" .


Remote Commands to Read Trace Data

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Trace Data
Remote Commands to Read Trace Data
Contents
  • Using the TRACe[:DATA] Command
  • Remote Commands to Read Measurement Results


Using the TRACe[:DATA] Command

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Trace Data > Using the TRACe[:DATA] Command
Using the TRACe[:DATA] Command

This chapter contains information on the TRACe:DATA command and a detailed description of the characteristics of that command.

The TRACe:DATA command queries the trace data or results of the currently active measurement or result display. The type, number and structure of the return values are specific for each result display. In case of results that have any kind of unit, the command returns the results in the unit you have currently set for that result display.

Note also that return values for results that are available for both downlink and uplink may be different.

For several result displays, the command also supports various SCPI parameters in combination with the query. If available, each SCPI parameter returns a different aspect of the results. If SCPI parameters are supported, you have to quote one in the query.

Example:

TRAC2:DATA? TRACE1

The format of the return values is either in ASCII or binary characters and depends on the format you have set with FORMat[:​DATA].

Following this detailed description, you will find a short summary of the most important functions of the command (TRACe<n>[:​DATA]?).

Selecting a measurement window

Compared to the LTE application on the R&S FSQ or R&S FSV, you have to select the measurement window directly with the suffix <n> at TRACe. The range of <n> depends on the number of active measurement windows.

On an R&S FSQ or R&S FSV, the suffix <n> was not supported. On these instruments, you had to select the measurement window with DISPlay:WINDow<n>:SELect first.

Contents
  • Adjacent Channel Leakage Ratio
  • Allocation Summary
  • Bit Stream
  • Capture Buffer
  • CCDF
  • Channel and Spectrum Flatness
  • Channel and Spectrum Flatness Difference
  • Channel Flatness SRS
  • Channel Group Delay
  • Constellation Diagram
  • EVM vs Carrier
  • EVM vs Subframe
  • EVM vs Symbol
  • Frequency Error vs Symbol
  • Inband Emission
  • Power Spectrum
  • Spectrum Emission Mask
  • Return Value Codes


Adjacent Channel Leakage Ratio

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Trace Data > Using the TRACe[:DATA] Command > Adjacent Channel Leakage Ratio
Adjacent Channel Leakage Ratio

For the ACLR result display, the number and type of returns values depend on the parameter.

  • TRACE1
    Returns one value for each trace point.
  • LIST
    Returns the contents of the ACLR table.
    For each channel, it returns six values.
    <channel type>, <bandwidth>, <spacing offset>, <power of lower channel>, <power of upper channel>, <limit>, ...
    The unit of the <bandwidth> and <spacing offset> is Hz.
    The unit of the power values is either dBm for the TX channel or dB for the neighboring channels.
    The unit of the limit is dB.
    The <channel type> is encoded. For the code assignment see "Return Value Codes".
    Note that the TX channel does not have a <spacing offset>, <power of lower channel> and <limit>. NaN is returned instead.


Allocation Summary

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Trace Data > Using the TRACe[:DATA] Command > Allocation Summary
Allocation Summary

For the Allocation Summary, the command returns seven values for each line of the table.

<subframe>, <allocation ID>, <number of RB>, <offset RB>, <modulation>, <absolute power>, <EVM>, ...

The unit for <absolute power> is always dBm. The unit for <EVM> depends on UNIT:​EVM. All other values have no unit.

The <allocation ID> and <modulation> are encoded. For the code assignment see "Return Value Codes".

Note that the data format of the return values is always ASCII.

Example:

TRAC:DATA? TRACE1 would return:

0, -40, 10, 2, 2, -84.7431947342849, 2.68723483754626E-06,

0, -41, 0, 0, 6, -84.7431432845264, 2.37549449584568E-06,

0, -42, 0, 0, 6, -80.9404231343884, 3.97834623871343E-06,

...


Bit Stream

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Trace Data > Using the TRACe[:DATA] Command > Bit Stream
Bit Stream

For the Bit Stream result display, the command returns five values and the bitstream for each line of the table.

<subframe>, <modulation>, <# of symbols/bits>, <hexadecimal/binary numbers>,...

All values have no unit. The format of the bitstream depends on "Bit Stream Format".

The <modulation> is encoded. For the code assignment see "Return Value Codes".

For symbols or bits that are not transmitted, the command returns
  • "FFF" if the bit stream format is "Symbols"
  • "9" if the bit stream format is "Bits".
For symbols or bits that could not be decoded because the number of layer exceeds the number of receive antennas, the command returns
  • "FFE" if the bit stream format is "Symbols"
  • "8" if the bit stream format is "Bits".

Note that the data format of the return values is always ASCII.

Example:

TRAC:DATA? TRACE1 would return:

0, -40, 0, 2, 0, 03, 01, 02, 03, 03, 00, 00, 00, 01, 02, 02, ...

<continues like this until the next data block starts or the end of data is reached>

0, -40, 0, 2, 32, 03, 03, 00, 00, 03, 01, 02, 00, 01, 00, ...


Capture Buffer

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Trace Data > Using the TRACe[:DATA] Command > Capture Buffer
Capture Buffer

For the Capture Buffer result display, the command returns one value for each I/Q sample in the capture buffer.

<absolute power>, ...

The unit is always dBm.

The following parameters are supported.
  • TRACE1


CCDF

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Trace Data > Using the TRACe[:DATA] Command > CCDF
CCDF

For the CCDF result display, the type of return values depends on the parameter.

  • TRACE1
    Returns the probability values (y-axis).
    <# of values>, <probability>, ...
    The unit is always %.
    The first value that is returned is the number of the following values.
  • TRACE2
    Returns the corresponding power levels (x-axis).
    <# of values>, <relative power>, ...
    The unit is always dB.
    The first value that is returned is the number of the following values.


Channel and Spectrum Flatness

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Trace Data > Using the TRACe[:DATA] Command > Channel and Spectrum Flatness
Channel and Spectrum Flatness

For the Channel Flatness result display, the command returns one value for each trace point.

<relative power>, ...

The unit is always dB.

The following parameters are supported.
  • TRACE1
    Returns the average power over all subframes.
  • TRACE2
    Returns the minimum power found over all subframes. If you are analyzing a particular subframe, it returns nothing.
  • TRACE3
    Returns the maximum power found over all subframes. If you are analyzing a particular subframe, it returns nothing.


Channel and Spectrum Flatness Difference

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Trace Data > Using the TRACe[:DATA] Command > Channel and Spectrum Flatness Difference
Channel and Spectrum Flatness Difference

For the Channel Flatness Difference result display, the command returns one value for each trace point.

<relative power>, ...

The unit is always dB. The number of values depends on the selected LTE bandwidth.

The following parameters are supported.
  • TRACE1
    Returns the average power over all subframes.
  • TRACE2
    Returns the minimum power found over all subframes. If you are analyzing a particular subframe, it returns nothing.
  • TRACE3
    Returns the maximum power found over all subframes. If you are analyzing a particular subframe, it returns nothing.


Channel Flatness SRS

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Trace Data > Using the TRACe[:DATA] Command > Channel Flatness SRS
Channel Flatness SRS

For the Channel Flatness SRS result display, the command returns one value for each trace point.

<relative power>, ...

The unit is always dB.

The following parameters are supported.
  • TRACE1
    Returns the average power over all subframes.
  • TRACE2
    Returns the minimum power found over all subframes. If you are analyzing a particular subframe, it returns nothing.
  • TRACE3
    Returns the maximum power found over all subframes. If you are analyzing a particular subframe, it returns nothing.


Channel Group Delay

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Trace Data > Using the TRACe[:DATA] Command > Channel Group Delay
Channel Group Delay

For the Channel Group Delay result display, the command returns one value for each trace point.

<group delay>, ...

The unit is always ns. The number of values depends on the selected LTE bandwidth.

The following parameters are supported.
  • TRACE1
    Returns the average group delay over all subframes.
  • TRACE2
    Returns the minimum group delay found over all subframes. If you are analyzing a particular subframe, it returns nothing.
  • TRACE3
    Returns the maximum group delay found over all subframes. If you are analyzing a particular subframe, it returns nothing.


Constellation Diagram

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Trace Data > Using the TRACe[:DATA] Command > Constellation Diagram
Constellation Diagram

For the Constellation Diagram, the command returns two values for each constellation point.

<I[SF0][Sym0][Carrier1]>, <Q[SF0][Sym0][Carrier1]>, ..., <I[SF0][Sym0][Carrier(n)]>, <Q[SF0][Sym0][Carrier(n)]>,

<I[SF0][Sym1][Carrier1]>, <Q[SF0][Sym1][Carrier1]>, ..., <I[SF0][Sym1][Carrier(n)]>, <Q[SF0][Sym1][Carrier(n)]>,

<I[SF0][Sym(n)][Carrier1]>, <Q[SF0][Sym(n)][Carrier1]>, ..., <I[SF0][Sym(n)][Carrier(n)]>, <Q[SF0][Sym(n)][Carrier(n)]>,

<I[SF1][Sym0][Carrier1]>, <Q[SF1][Sym0][Carrier1]>, ..., <I[SF1][Sym0][Carrier(n)]>, <Q[SF1][Sym0][Carrier(n)]>,

<I[SF1][Sym1][Carrier1]>, <Q[SF1][Sym1][Carrier1]>, ..., <I[SF1][Sym1][Carrier(n)]>, <Q[SF1][Sym1][Carrier(n)]>,

<I[SF(n)][Sym(n)][Carrier1]>, <Q[SF(n)][Sym(n)][Carrier1]>, ..., <I[SF(n)][Sym(n)][Carrier(n)]>, <Q[SF(n)][Sym(n)][Carrier(n)]>

With SF = subframe and Sym = symbol of that subframe.

The I and Q values have no unit.

The number of return values depends on the constellation selection. By default, it returns all resource elements including the DC carrier.

The following parameters are supported.
  • TRACE1
    Returns all constellation points included in the selection.
  • TRACE2
    Returns the constellation points of the reference symbols included in the selection.
  • TRACE3
    Returns the constellation points of the SRS included in the selection.


EVM vs Carrier

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Trace Data > Using the TRACe[:DATA] Command > EVM vs Carrier
EVM vs Carrier

For the EVM vs Carrier result display, the command returns one value for each subcarrier that has been analyzed.

<EVM>, ...

The unit depends on UNIT:​EVM.

The following parameters are supported.
  • TRACE1
    Returns the average EVM over all subframes
  • TRACE2
    Returns the minimum EVM found over all subframes. If you are analyzing a particular subframe, it returns nothing.
  • TRACE3
    Returns the maximum EVM found over all subframes. If you are analyzing a particular subframe, it returns nothing.


EVM vs Subframe

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Trace Data > Using the TRACe[:DATA] Command > EVM vs Subframe
EVM vs Subframe

For the EVM vs Subframe result display, the command returns one value for each subframe that has been analyzed.

<EVM>, ...

The unit depends on UNIT:​EVM.

The following parameters are supported.
  • TRACE1


EVM vs Symbol

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Trace Data > Using the TRACe[:DATA] Command > EVM vs Symbol
EVM vs Symbol

For the EVM vs Symbol result display, the command returns one value for each OFDM symbol that has been analyzed.

<EVM>, ...

For measurements on a single subframe, the command returns the symbols of that subframe only.

The unit depends on UNIT:​EVM.

The following parameters are supported.
  • TRACE1


Frequency Error vs Symbol

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Trace Data > Using the TRACe[:DATA] Command > Frequency Error vs Symbol
Frequency Error vs Symbol

For the Frequency Error vs Symbol result display, the command returns one value for each OFDM symbol that has been analyzed.

<frequency error>,...

The unit is always Hz.

The following parameters are supported.
  • TRACE1


Inband Emission

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Trace Data > Using the TRACe[:DATA] Command > Inband Emission
Inband Emission

For the Inband Emission result display, the number and type of returns values depend on the parameter.

  • TRACE1
    Returns the relative resource block indices (x-axis values).
    <RB index>, ...
    The resource block index has no unit.
  • TRACE2
    Returns one value for each resource block index.
    <relative power>, ...
    The unit of the relative inband emission is dB.
  • TRACE3
    Returns the data points of the upper limit line.
    <limit>, ...
    The unit is always dB.

Note that you have to select a particular subframe to get results.


Power Spectrum

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Trace Data > Using the TRACe[:DATA] Command > Power Spectrum
Power Spectrum

For the Power Spectrum result display, the command returns one value for each trace point.

<power>,...

The unit is always dBm/Hz.

The following parameters are supported.
  • TRACE1


Spectrum Emission Mask

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Trace Data > Using the TRACe[:DATA] Command > Spectrum Emission Mask
Spectrum Emission Mask

For the SEM measurement, the number and type of returns values depend on the parameter.

  • TRACE1
    Returns one value for each trace point.
    <absolute power>, ...
    The unit is always dBm.
  • LIST
    Returns the contents of the SEM table. For every frequency in the spectrum emission mask, it returns 11 values.
    <index>, <start frequency in Hz>, <stop frequency in Hz>, <RBW in Hz>, <limit fail frequency in Hz>, <absolute power in dBm>, <relative power in dBc>, <limit distance in dB>, <limit check result>, <reserved>, <reserved>...
    The <limit check result> is either a 0 (for PASS) or a 1 (for FAIL).


Return Value Codes

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Trace Data > Using the TRACe[:DATA] Command > Return Value Codes
Return Value Codes

This chapter contains a list for encoded return values.

<allocation ID>
Represents the allocation ID. The value is a number in the range {1...-70}.
  • 1 = Reference symbol
  • 0 = Data symbol
  • -1 = Invalid
  • -40 = PUSCH
  • -41 = DMRS PUSCH
  • -42 = SRS PUSCH
  • -50 = PUCCH
  • -51 = DMRS PUCCH
  • -70 = PRACH
<channel type>
  • 0 = TX channel
  • 1 = adjacent channel
  • 2 = alternate channel
<codeword>
Represents the codeword of an allocation. The range is {0...6}.
  • 0 = 1/1
  • 1 = 1/2
  • 2 = 2/2
  • 3 = 1/4
  • 4 = 2/4
  • 5 = 3/4
  • 6 = 4/4
<modulation>
Represents the modulation scheme. The range is {0...8}.
  • 0 = unrecognized
  • 1 = RBPSK
  • 2 = QPSK
  • 3 = 16QAM
  • 4 = 64QAM
  • 5 = 8PSK
  • 6 = PSK
  • 7 = mixed modulation
  • 8 = BPSK
<number of symbols or bits>

In hexadecimal mode, this represents the number of symbols to be transmitted. In binary mode, it represents the number of bits to be transmitted.

List of Commands
TRACe<n>[:DATA]?


TRACe<n>[:DATA]?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Trace Data > Using the TRACe[:DATA] Command > Return Value Codes > TRACe<n>[:DATA]?
TRACe<n>[:DATA]? <Result>

This command returns the trace data for the current measurement or result display.

For more information see "Using the TRACe[:DATA] Command".

Query parameters:
<TraceNumber> | TRACE1 | TRACE2 | TRACE3
LIST |
Example: | TRAC2? TRACE1 Queries results of the second measurement window. The type of data that is returned by the parameter (TRACE1) depends on the result display shown in measurement window 2.
Usage: | Query only


Remote Commands to Read Measurement Results

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Trace Data > Remote Commands to Read Measurement Results
Remote Commands to Read Measurement Results
List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:POWer:RESult[:CURRent]?
FORMat[:DATA]


CALCulate<n>:MARKer<m>:FUNCtion:POWer:RESult[:CURRent]?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Trace Data > Remote Commands to Read Measurement Results > CALCulate<n>:MARKer<m>:FUNCtion:POWer:RESult[:CURRent]?
CALCulate<n>:MARKer<m>:FUNCtion:POWer:RESult[:CURRent]? <ResultType>

This command queries the current results of the ACLR measurement or the total signal power level of the SEM measurement.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps.

Suffix: |
<m> | 1
Query parameters:
<ResultType> | CPOW This parameter queries the channel power of the reference range.
Return values:
<Result> | SEMResults Power level in dBm. ACLRResults Relative power levels of the ACLR channels. The number of return values depends on the number of transmission and adjacent channels. The order of return values is: • <TXChannelPower> is the power of the transmission channel in dBm • <LowerAdjChannelPower> is the relative power of the lower adjacent channel in dB • <UpperAdjChannelPower> is the relative power of the upper adjacent channel in dB • <1stLowerAltChannelPower> is the relative power of the first lower alternate channel in dB • <1stUpperAltChannelPower> is the relative power of the first lower alternate channel in dB (...) • <nthLowerAltChannelPower> is the relative power of a subsequent lower alternate channel in dB • <nthUpperAltChannelPower> is the relative power of a subsequent lower alternate channel in dB
Example: | CALC1:MARK:FUNC:POW:RES? Returns the current ACLR measurement results.
Usage: | Query only
Manual operation: | See "ACLR" See "Multi Carrier ACLR"


FORMat[:DATA]

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Trace Data > Remote Commands to Read Measurement Results > FORMat[:DATA]
FORMat[:DATA] [<Format>]

This command specifies the data format for the data transmission between the LTE measurement application and the remote client. Supported formats are ASCII or REAL32.

Parameters:
<Format>
ASCii | REAL
*RST: ASCii
Example: FORM REAL

The software will send binary data in Real32 data format.


Remote Commands to Read Numeric Results

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results
Remote Commands to Read Numeric Results
Contents
  • Frame Results
  • Result for Selection
  • Marker Table


Frame Results

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results > Frame Results
Frame Results
List of Commands
FETCh:SUMMary:EVM:SDQP[:AVERage]?
FETCh:SUMMary:EVM:SDSF[:AVERage]?
FETCh:SUMMary:EVM:SDST[:AVERage]?
FETCh:SUMMary:EVM:UCCD[:AVERage]?
FETCh:SUMMary:EVM:UCCH[:AVERage]?
FETCh:SUMMary:EVM:UPRA[:AVERage]?
FETCh:SUMMary:EVM:USQP[:AVERage]?
FETCh:SUMMary:EVM:USSF[:AVERage]?
FETCh:SUMMary:EVM:USST[:AVERage]?


FETCh:SUMMary:EVM:SDQP[:AVERage]?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results > Frame Results > FETCh:SUMMary:EVM:SDQP[:AVERage]?
FETCh:SUMMary:EVM:SDQP[:AVERage]?

This command queries the EVM of all DMRS resource elements with QPSK modulation of the PUSCH.

Return values:
<EVM> | <numeric value> EVM in % or dB, depending on the unit you have set.
Example: | FETC:SUMM:EVM:SDQP? Returns the EVM of all DMRS resource elements with QPSK modulation.
Usage: | Query only
Manual operation: | See "Result Summary"


FETCh:SUMMary:EVM:SDSF[:AVERage]?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results > Frame Results > FETCh:SUMMary:EVM:SDSF[:AVERage]?
FETCh:SUMMary:EVM:SDSF[:AVERage]?

This command queries the EVM of all DMRS resource elements with 64QAM modulation of the PUSCH.

Return values:
<EVM> | <numeric value> EVM in % or dB, depending on the unit you have set.
Example: | FETC:SUMM:EVM:SDSF? Returns the maximum EVM of all DMRS resource elements with 64QAM modulation.
Usage: | Query only
Manual operation: | See "Result Summary"


FETCh:SUMMary:EVM:SDST[:AVERage]?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results > Frame Results > FETCh:SUMMary:EVM:SDST[:AVERage]?
FETCh:SUMMary:EVM:SDST[:AVERage]?

This command queries the EVM of all DMRS resource elements with 16QAM modulation of the PUSCH.

Return values:
<EVM> | <numeric value> EVM in % or dB, depending on the unit you have set.
Example: | FETC:SUMM:EVM:SDST? Returns the EVM of all DMRS resource elements with 16QAM modulation.
Usage: | Query only
Manual operation: | See "Result Summary"


FETCh:SUMMary:EVM:UCCD[:AVERage]?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results > Frame Results > FETCh:SUMMary:EVM:UCCD[:AVERage]?
FETCh:SUMMary:EVM:UCCD[:AVERage]?

This command queries the EVM of all DMRS resource elements of the PUCCH as shown in the result summary.

Return values:
<EVM> | EVM in % or dB, depending on the unit you have set.
Example: | FETC:SUMM:EVM:UCCD? Returns the average EVM of all DMRS resource elements.
Usage: | Query only
Manual operation: | See "Result Summary"


FETCh:SUMMary:EVM:UCCH[:AVERage]?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results > Frame Results > FETCh:SUMMary:EVM:UCCH[:AVERage]?
FETCh:SUMMary:EVM:UCCH[:AVERage]?

This command queries the EVM of all resource elements of the PUCCH as shown in the result summary.

Return values:
<EVM> | EVM in % or dB, depending on the unit you have set.
Example: | FETC:SUMM:EVM:UCCH? Returns the average EVM of all resource elements.
Usage: | Query only
Manual operation: | See "Result Summary"


FETCh:SUMMary:EVM:UPRA[:AVERage]?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results > Frame Results > FETCh:SUMMary:EVM:UPRA[:AVERage]?
FETCh:SUMMary:EVM:UPRA[:AVERage]?

This command queries the EVM of all resource elements of the PRACH as shown in the result summary.

Return values:
<EVM> | EVM in % or dB, depending on the unit you have set.
Example: | FETC:SUMM:EVM:UPRA? Returns the average EVM of all resource elements.
Usage: | Query only
Manual operation: | See "Result Summary"


FETCh:SUMMary:EVM:USQP[:AVERage]?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results > Frame Results > FETCh:SUMMary:EVM:USQP[:AVERage]?
FETCh:SUMMary:EVM:USQP[:AVERage]?

This query returns the EVM for all QPSK-modulated resource elements of the PUSCH.

Return values:
<EVM> | <numeric value> EVM in % or dB, depending on the unit you have set.
Example: | FETC:SUMM:EVM:USQP? Queries the PUSCH QPSK EVM.
Usage: | Query only
Manual operation: | See "Result Summary"


FETCh:SUMMary:EVM:USSF[:AVERage]?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results > Frame Results > FETCh:SUMMary:EVM:USSF[:AVERage]?
FETCh:SUMMary:EVM:USSF[:AVERage]?

This command queries the EVM for all 64QAM-modulated resource elements of the PUSCH.

Return values:
<EVM> | <numeric value> EVM in % or dB, depending on the unit you have set.
Example: | FETC:SUMM:EVM:USSF? Queries the PUSCH 64QAM EVM.
Usage: | Query only
Manual operation: | See "Result Summary"


FETCh:SUMMary:EVM:USST[:AVERage]?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results > Frame Results > FETCh:SUMMary:EVM:USST[:AVERage]?
FETCh:SUMMary:EVM:USST[:AVERage]?

This query returns the the EVM for all 16QAM-modulated resource elements of the PUSCH.

Return values:
<EVM> | EVM in % or dB, depending on the unit you have set.
Example: | FETC:SUMM:EVM:USST? Queries the PUSCH 16QAM EVM.
Usage: | Query only
Manual operation: | See "Result Summary"


Result for Selection

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results > Result for Selection
Result for Selection
List of Commands
FETCh:SUMMary:CRESt[:AVERage]?
FETCh:SUMMary:EVM[:ALL]:MAXimum?
FETCh:SUMMary:EVM[:ALL]:MINimum?
FETCh:SUMMary:EVM[:ALL][:AVERage]?
FETCh:SUMMary:EVM:PCHannel:MAXimum?
FETCh:SUMMary:EVM:PCHannel:MINimum?
FETCh:SUMMary:EVM:PCHannel[:AVERage]?
FETCh:SUMMary:EVM:PSIGnal:MAXimum?
FETCh:SUMMary:EVM:PSIGnal:MINimum?
FETCh:SUMMary:EVM:PSIGnal[:AVERage]?
FETCh:SUMMary:FERRor:MAXimum?
FETCh:SUMMary:FERRor:MINimum?
FETCh:SUMMary:FERRor[:AVERage]?
FETCh:SUMMary:GIMBalance:MAXimum?
FETCh:SUMMary:GIMBalance:MINimum?
FETCh:SUMMary:GIMBalance[:AVERage]?
FETCh:SUMMary:IQOFfset:MAXimum?
FETCh:SUMMary:IQOFfset:MINimum?
FETCh:SUMMary:IQOFfset[:AVERage]?
FETCh:SUMMary:POWer:MAXimum?
FETCh:SUMMary:POWer:MINimum?
FETCh:SUMMary:POWer[:AVERage]?
FETCh:SUMMary:QUADerror:MAXimum?
FETCh:SUMMary:QUADerror:MINimum?
FETCh:SUMMary:QUADerror[:AVERage]?
FETCh:SUMMary:SERRor:MAXimum?
FETCh:SUMMary:SERRor:MINimum?
FETCh:SUMMary:SERRor[:AVERage]?
FETCh:SUMMary:TFRame?


FETCh:SUMMary:CRESt[:AVERage]?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results > Result for Selection > FETCh:SUMMary:CRESt[:AVERage]?
FETCh:SUMMary:CRESt[:AVERage]?

This command queries the average crest factor as shown in the result summary.

Return values:
<CrestFactor> | <numeric value> Crest Factor in dB.
Example: | FETC:SUMM:CRES? Returns the current crest factor in dB.
Usage: | Query only
Manual operation: | See "Result Summary"


FETCh:SUMMary:EVM[:ALL]:MAXimum?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results > Result for Selection > FETCh:SUMMary:EVM[:ALL]:MAXimum?
FETCh:SUMMary:EVM[:ALL]:MAXimum?
FETCh:SUMMary:EVM[:ALL]:MINimum?
FETCh:SUMMary:EVM[:ALL][:AVERage]?

This command queries the EVM of all resource elements.

Return values:
<EVM> | <numeric value> Minimum, maximum or average EVM, depending on the last command syntax element. The unit is % or dB, depending on your selection.
Example: | FETC:SUMM:EVM? Returns the mean value.
Usage: | Query only
Manual operation: | See "Result Summary"


FETCh:SUMMary:EVM:PCHannel:MAXimum?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results > Result for Selection > FETCh:SUMMary:EVM:PCHannel:MAXimum?
FETCh:SUMMary:EVM:PCHannel:MAXimum?
FETCh:SUMMary:EVM:PCHannel:MINimum?
FETCh:SUMMary:EVM:PCHannel[:AVERage]?

This command queries the EVM of all physical channel resource elements.

Return values:
<EVM> | <numeric value> Minimum, maximum or average EVM, depending on the last command syntax element. The unit is % or dB, depending on your selection.
Example: | FETC:SUMM:EVM:PCH? Returns the mean value.
Usage: | Query only
Manual operation: | See "Result Summary"


FETCh:SUMMary:EVM:PSIGnal:MAXimum?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results > Result for Selection > FETCh:SUMMary:EVM:PSIGnal:MAXimum?
FETCh:SUMMary:EVM:PSIGnal:MAXimum?
FETCh:SUMMary:EVM:PSIGnal:MINimum?
FETCh:SUMMary:EVM:PSIGnal[:AVERage]?

This command queries the EVM of all physical signal resource elements.

Return values:
<EVM> | <numeric value> Minimum, maximum or average EVM, depending on the last command syntax element. The unit is % or dB, depending on your selection.
Example: | FETC:SUMM:EVM:PSIG? Returns the mean value.
Usage: | Query only
Manual operation: | See "Result Summary"


FETCh:SUMMary:FERRor:MAXimum?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results > Result for Selection > FETCh:SUMMary:FERRor:MAXimum?
FETCh:SUMMary:FERRor:MAXimum?
FETCh:SUMMary:FERRor:MINimum?
FETCh:SUMMary:FERRor[:AVERage]?

This command queries the frequency error.

Return values:
<FreqError>
<numeric value>

Minimum, maximum or average frequency error, depending on the last command syntax element.

Default unit: Hz
Example: FETC:SUMM:FERR?

Returns the average frequency error in Hz.

Usage: Query only
Manual operation: See "Result Summary"


FETCh:SUMMary:GIMBalance:MAXimum?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results > Result for Selection > FETCh:SUMMary:GIMBalance:MAXimum?
FETCh:SUMMary:GIMBalance:MAXimum?
FETCh:SUMMary:GIMBalance:MINimum?
FETCh:SUMMary:GIMBalance[:AVERage]?

This command queries the I/Q gain imbalance.

Return values:
<GainImbalance>
<numeric value>

Minimum, maximum or average I/Q imbalance, depending on the last command syntax element.

Default unit: dB
Example: FETC:SUMM:GIMB?

Returns the current gain imbalance in dB.

Usage: Query only
Manual operation: See "Result Summary"


FETCh:SUMMary:IQOFfset:MAXimum?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results > Result for Selection > FETCh:SUMMary:IQOFfset:MAXimum?
FETCh:SUMMary:IQOFfset:MAXimum?
FETCh:SUMMary:IQOFfset:MINimum?
FETCh:SUMMary:IQOFfset[:AVERage]?

This command queries the I/Q offset.

Return values:
<IQOffset>
<numeric value>

Minimum, maximum or average I/Q offset, depending on the last command syntax element.

Default unit: dB
Example: FETC:SUMM:IQOF?

Returns the current IQ-offset in dB

Usage: Query only
Manual operation: See "Result Summary"


FETCh:SUMMary:POWer:MAXimum?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results > Result for Selection > FETCh:SUMMary:POWer:MAXimum?
FETCh:SUMMary:POWer:MAXimum?
FETCh:SUMMary:POWer:MINimum?
FETCh:SUMMary:POWer[:AVERage]?

This command queries the total power.

Return values:
<Power>
<numeric value>

Minimum, maximum or average power, depending on the last command syntax element.

Default unit: dBm
Example: FETC:SUMM:POW?

Returns the total power in dBm

Usage: Query only
Manual operation: See "Result Summary"


FETCh:SUMMary:QUADerror:MAXimum?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results > Result for Selection > FETCh:SUMMary:QUADerror:MAXimum?
FETCh:SUMMary:QUADerror:MAXimum?
FETCh:SUMMary:QUADerror:MINimum?
FETCh:SUMMary:QUADerror[:AVERage]?

This command queries the quadrature error.

Return values:
<QuadError>
<numeric value>

Minimum, maximum or average quadrature error, depending on the last command syntax element.

Default unit: deg
Example: FETC:SUMM:QUAD?

Returns the current mean quadrature error in degrees.

Usage: Query only
Manual operation: See "Result Summary"


FETCh:SUMMary:SERRor:MAXimum?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results > Result for Selection > FETCh:SUMMary:SERRor:MAXimum?
FETCh:SUMMary:SERRor:MAXimum?
FETCh:SUMMary:SERRor:MINimum?
FETCh:SUMMary:SERRor[:AVERage]?

This command queries the sampling error.

Return values:
<SamplingError>
<numeric value>

Minimum, maximum or average sampling error, depending on the last command syntax element.

Default unit: ppm
Example: FETC:SUMM:SERR?

Returns the current mean sampling error in ppm.

Usage: Query only
Manual operation: See "Result Summary"


FETCh:SUMMary:TFRame?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results > Result for Selection > FETCh:SUMMary:TFRame?
FETCh:SUMMary:TFRame?

This command queries the (sub)frame start offset as shown in the Capture Buffer result display.

Note that you have to select a particular subframe; otherwise the command returns an error.

Return values:
<Offset>

Time difference between the (sub)frame start and capture buffer start.

Default unit: s
Example: FETC:SUMM:TFR?

Returns the (sub)frame start offset.

Usage: Query only
Manual operation: See "Capture Buffer"


Marker Table

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results > Marker Table
Marker Table
List of Commands
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:Y?


CALCulate<n>:DELTamarker<m>:X

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results > Marker Table > CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X <Position>

This command moves a delta marker to a particular coordinate on the x-axis.

If necessary, the command activates the delta marker and positions a reference marker to the peak power.

Example: CALC:DELT:X?

Outputs the absolute x-value of delta marker 1.


CALCulate<n>:DELTamarker<m>:Y?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results > Marker Table > CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:DELTamarker<m>:Y?

This command queries the relative position of a delta marker on the y-axis.

If necessary, the command activates the delta marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

The unit depends on the application of the command.

Return values:
<Position> | Position of the delta marker in relation to the reference marker or the fixed reference.
Example: | INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a sweep and waits for its end. CALC:DELT2 ON Switches on delta marker 2. CALC:DELT2:Y? Outputs measurement value of delta marker 2.
Usage: | Query only


CALCulate<n>:MARKer<m>:X

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results > Marker Table > CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:X <Position>

This command moves a marker to a particular coordinate on the x-axis.

If necessary, the command activates the marker.

If the marker has been used as a delta marker, the command turns it into a normal marker.

Parameters:
<Position>

Numeric value that defines the marker position on the x-axis.

Range: The range depends on the current x-axis range.
Example: CALC:MARK2:X 1.7MHz

Positions marker 2 to frequency 1.7 MHz.

Manual operation: See "Marker Table"


CALCulate<n>:MARKer<m>:Y?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Numeric Results > Marker Table > CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>:Y?

This command queries the position of a marker on the y-axis.

If necessary, the command activates the marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Result> | Result at the marker position.
Example: | INIT:CONT OFF Switches to single measurement mode. CALC:MARK2 ON Switches marker 2. INIT;*WAI Starts a measurement and waits for the end. CALC:MARK2:Y? Outputs the measured value of marker 2.
Usage: | Query only
Manual operation: | See "Marker Table"


Remote Commands to Read Limit Check Results

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Limit Check Results
Remote Commands to Read Limit Check Results
Contents
  • Checking Limits for Graphical Result Displays
  • Checking Limits for Numerical Result Display


Checking Limits for Graphical Result Displays

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Limit Check Results > Checking Limits for Graphical Result Displays
Checking Limits for Graphical Result Displays
List of Commands
CALCulate<n>:LIMit<k>:ACPower:ACHannel:RESult?
CALCulate<n>:LIMit<k>:ACPower:ALTernate:RESult?
CALCulate<n>:LIMit<k>:FAIL?


CALCulate<n>:LIMit<k>:ACPower:ACHannel:RESult?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Limit Check Results > Checking Limits for Graphical Result Displays > CALCulate<n>:LIMit<k>:ACPower:ACHannel:RESult?
CALCulate<n>:LIMit<k>:ACPower:ACHannel:RESult? <Result>

This command queries the limit check results for the adjacent channels during ACLR measurements.

Return values:
<LimitCheck> | Returns two values, one for the upper and one for the lower adjacent channel. PASSED Limit check has passed. FAILED Limit check has failed.
Example: | CALC:LIM:ACP:ACH:RES? ALL Queries the results of the adjacent channel limit check.
Usage: | Query only
Manual operation: | See "Multi Carrier ACLR"


CALCulate<n>:LIMit<k>:ACPower:ALTernate:RESult?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Limit Check Results > Checking Limits for Graphical Result Displays > CALCulate<n>:LIMit<k>:ACPower:ALTernate:RESult?
CALCulate<n>:LIMit<k>:ACPower:ALTernate:RESult? <Result>

This command queries the limit check results for the alternate channels during ACLR measurements.

Return values:
<LimitCheck> | Returns two values, one for the upper and one for the lower alternate channel. PASSED Limit check has passed. FAILED Limit check has failed.
Example: | CALC:LIM:ACP:ALT:RES? ALL Queries the results of the alternate channel limit check.
Usage: | Query only
Manual operation: | See "Multi Carrier ACLR"


CALCulate<n>:LIMit<k>:FAIL?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Limit Check Results > Checking Limits for Graphical Result Displays > CALCulate<n>:LIMit<k>:FAIL?
CALCulate<n>:LIMit<k>:FAIL?

This command queries the limit check results for all measurements that feature a limit check.

Return values:
<LimitCheck> | Returns two values, one for the upper and one for the lower adjacent or alternate channel. 0 Limit check has passed. 1 Limit check has failed.
Example: | CALC:LIM:FAIL? Queries the limit check of the active result display.
Usage: | Query only
Manual operation: | See "Multi Carrier ACLR"


Checking Limits for Numerical Result Display

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Limit Check Results > Checking Limits for Numerical Result Display
Checking Limits for Numerical Result Display
List of Commands
CALCulate<n>:LIMit<k>:SUMMary:EVM[:ALL]:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:EVM[:ALL][:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:PCHannel:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:EVM:PCHannel[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:PSIGnal:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:EVM:PSIGnal[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:SDQP[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:SDSF[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:SDST[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:UCCD[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:UCCH[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:UPRA[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:USQP[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:USSF[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:USST[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:FERRor:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:FERRor[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:GIMBalance:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:GIMBalance[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:IQOFfset:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:IQOFfset[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:QUADerror:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:QUADerror[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:SERRor:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:SERRor[:AVERage]:RESult?


CALCulate<n>:LIMit<k>:SUMMary:EVM[:ALL]:MAXimum:RESult

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Limit Check Results > Checking Limits for Numerical Result Display > CALCulate<n>:LIMit<k>:SUMMary:EVM[:ALL]:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:EVM[:ALL]:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:EVM[:ALL][:AVERage]:RESult?

This command queries the results of the EVM limit check of all resource elements.

Return values:
<LimitCheck> | The type of limit (average or maximum) that is queried depends on the last syntax element. FAILED Limit check has failed. PASSED Limit check has passed. NOTEVALUATED Limits have not been evaluated.
Example: | CALC:LIM:SUMM:EVM:RES? Queries the limit check.
Usage: | Query only


CALCulate<n>:LIMit<k>:SUMMary:EVM:PCHannel:MAXimum:RESult

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Limit Check Results > Checking Limits for Numerical Result Display > CALCulate<n>:LIMit<k>:SUMMary:EVM:PCHannel:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:EVM:PCHannel:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:EVM:PCHannel[:AVERage]:RESult?

This command queries the results of the EVM limit check of all physical channel resource elements.

Return values:
<LimitCheck> | The type of limit (average or maximum) that is queried depends on the last syntax element. FAILED Limit check has failed. PASSED Limit check has passed. NOTEVALUATED Limits have not been evaluated.
Example: | CALC:LIM:SUMM:EVM:PCH:RES? Queries the limit check.
Usage: | Query only


CALCulate<n>:LIMit<k>:SUMMary:EVM:PSIGnal:MAXimum:RESult

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Limit Check Results > Checking Limits for Numerical Result Display > CALCulate<n>:LIMit<k>:SUMMary:EVM:PSIGnal:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:EVM:PSIGnal:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:EVM:PSIGnal[:AVERage]:RESult?

This command queries the results of the EVM limit check of all physical signal resource elements.

Return values:
<LimitCheck> | The type of limit (average or maximum) that is queried depends on the last syntax element. FAILED Limit check has failed. PASSED Limit check has passed. NOTEVALUATED Limits have not been evaluated.
Example: | CALC:LIM:SUMM:EVM:PSIG:RES? Queries the limit check.
Usage: | Query only


CALCulate<n>:LIMit<k>:SUMMary:EVM:SDQP[:AVERage]:RESult?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Limit Check Results > Checking Limits for Numerical Result Display > CALCulate<n>:LIMit<k>:SUMMary:EVM:SDQP[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:SDQP[:AVERage]:RESult?

This command queries the results of the EVM limit check of all PUSCH DMRS resource elements with a QPSK modulation.

Return values:
<LimitCheck> | FAILED Limit check has failed. PASSED Limit check has passed. NOTEVALUATED Limits have not been evaluated.
Example: | CALC:LIM:SUMM:EVM:SDQP:RES? Queries the limit check.
Usage: | Query only


CALCulate<n>:LIMit<k>:SUMMary:EVM:SDSF[:AVERage]:RESult?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Limit Check Results > Checking Limits for Numerical Result Display > CALCulate<n>:LIMit<k>:SUMMary:EVM:SDSF[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:SDSF[:AVERage]:RESult?

This command queries the results of the EVM limit check of all PUSCH DMRS resource elements with a 64QAM modulation.

Return values:
<LimitCheck> | FAILED Limit check has failed. PASSED Limit check has passed. NOTEVALUATED Limits have not been evaluated.
Example: | CALC:LIM:SUMM:EVM:SDSF:RES? Queries the limit check.
Usage: | Query only


CALCulate<n>:LIMit<k>:SUMMary:EVM:SDST[:AVERage]:RESult?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Limit Check Results > Checking Limits for Numerical Result Display > CALCulate<n>:LIMit<k>:SUMMary:EVM:SDST[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:SDST[:AVERage]:RESult?

This command queries the results of the EVM limit check of all PUSCH DMRS resource elements with a 16QAM modulation.

Return values:
<LimitCheck> | FAILED Limit check has failed. PASSED Limit check has passed. NOTEVALUATED Limits have not been evaluated.
Example: | CALC:LIM:SUMM:EVM:SDST:RES? Queries the limit check.
Usage: | Query only


CALCulate<n>:LIMit<k>:SUMMary:EVM:UCCD[:AVERage]:RESult?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Limit Check Results > Checking Limits for Numerical Result Display > CALCulate<n>:LIMit<k>:SUMMary:EVM:UCCD[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:UCCD[:AVERage]:RESult?

This command queries the results of the EVM limit check of all PUCCH DMRS resource elements.

Return values:
<LimitCheck> | FAILED Limit check has failed. PASSED Limit check has passed. NOTEVALUATED Limits have not been evaluated.
Example: | CALC:LIM:SUMM:EVM:UCCD:RES? Queries the limit check.
Usage: | Query only


CALCulate<n>:LIMit<k>:SUMMary:EVM:UCCH[:AVERage]:RESult?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Limit Check Results > Checking Limits for Numerical Result Display > CALCulate<n>:LIMit<k>:SUMMary:EVM:UCCH[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:UCCH[:AVERage]:RESult?

This command queries the results of the EVM limit check of all PUCCH resource elements.

Return values:
<LimitCheck> | FAILED Limit check has failed. PASSED Limit check has passed. NOTEVALUATED Limits have not been evaluated.
Example: | CALC:LIM:SUMM:EVM:UCCH:RES? Queries the limit check.
Usage: | Query only


CALCulate<n>:LIMit<k>:SUMMary:EVM:UPRA[:AVERage]:RESult?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Limit Check Results > Checking Limits for Numerical Result Display > CALCulate<n>:LIMit<k>:SUMMary:EVM:UPRA[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:UPRA[:AVERage]:RESult?

This command queries the results of the EVM limit check of all PRACH resource elements.

Return values:
<LimitCheck> | FAILED Limit check has failed. PASSED Limit check has passed. NOTEVALUATED Limits have not been evaluated.
Example: | CALC:LIM:SUMM:EVM:UPRA:RES? Queries the limit check.
Usage: | Query only


CALCulate<n>:LIMit<k>:SUMMary:EVM:USQP[:AVERage]:RESult?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Limit Check Results > Checking Limits for Numerical Result Display > CALCulate<n>:LIMit<k>:SUMMary:EVM:USQP[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:USQP[:AVERage]:RESult?

This command queries the results of the EVM limit check of all PUSCH resource elements with a QPSK modulation

Return values:
<LimitCheck> | FAILED Limit check has failed. PASSED Limit check has passed. NOTEVALUATED Limits have not been evaluated.
Example: | CALC:LIM:SUMM:EVM:USQP:RES? Queries the limit check.
Usage: | Query only


CALCulate<n>:LIMit<k>:SUMMary:EVM:USSF[:AVERage]:RESult?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Limit Check Results > Checking Limits for Numerical Result Display > CALCulate<n>:LIMit<k>:SUMMary:EVM:USSF[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:USSF[:AVERage]:RESult?

This command queries the results of the EVM limit check of all PUSCH resource elements with a 64QAM modulation.

Return values:
<LimitCheck> | FAILED Limit check has failed. PASSED Limit check has passed. NOTEVALUATED Limits have not been evaluated.
Example: | CALC:LIM:SUMM:EVM:USSF:RES? Queries the limit check.
Usage: | Query only


CALCulate<n>:LIMit<k>:SUMMary:EVM:USST[:AVERage]:RESult?

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Limit Check Results > Checking Limits for Numerical Result Display > CALCulate<n>:LIMit<k>:SUMMary:EVM:USST[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:USST[:AVERage]:RESult?

This command queries the results of the EVM limit check of all PUSCH resource elements with a 16QAM modulation.

Return values:
<LimitCheck> | FAILED Limit check has failed. PASSED Limit check has passed. NOTEVALUATED Limits have not been evaluated.
Example: | CALC:LIM:SUMM:EVM:USST:RES? Queries the limit check.
Usage: | Query only


CALCulate<n>:LIMit<k>:SUMMary:FERRor:MAXimum:RESult

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Limit Check Results > Checking Limits for Numerical Result Display > CALCulate<n>:LIMit<k>:SUMMary:FERRor:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:FERRor:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:FERRor[:AVERage]:RESult?

This command queries the result of the frequency error limit check.

Return values:
<LimitCheck> | The type of limit (average or maximum) that is queried depends on the last syntax element. FAILED Limit check has failed. PASSED Limit check has passed. NOTEVALUATED Limits have not been evaluated.
Example: | CALC:LIM:SUMM:SERR:RES? Queries the limit check.
Usage: | Query only


CALCulate<n>:LIMit<k>:SUMMary:GIMBalance:MAXimum:RESult

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Limit Check Results > Checking Limits for Numerical Result Display > CALCulate<n>:LIMit<k>:SUMMary:GIMBalance:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:GIMBalance:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:GIMBalance[:AVERage]:RESult?

This command queries the result of the gain imbalance limit check.

Return values:
<LimitCheck> | The type of limit (average or maximum) that is queried depends on the last syntax element. FAILED Limit check has failed. PASSED Limit check has passed. NOTEVALUATED Limits have not been evaluated.
Example: | CALC:LIM:SUMM:GIMB:RES? Queries the limit check.
Usage: | Query only


CALCulate<n>:LIMit<k>:SUMMary:IQOFfset:MAXimum:RESult

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Limit Check Results > Checking Limits for Numerical Result Display > CALCulate<n>:LIMit<k>:SUMMary:IQOFfset:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:IQOFfset:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:IQOFfset[:AVERage]:RESult?

This command queries the result of the I/Q offset limit check.

Return values:
<LimitCheck> | The type of limit (average or maximum) that is queried depends on the last syntax element. FAILED Limit check has failed. PASSED Limit check has passed. NOTEVALUATED Limits have not been evaluated.
Example: | CALC:LIM:SUMM:IQOF:MAX:RES? Queries the limit check.
Usage: | Query only


CALCulate<n>:LIMit<k>:SUMMary:QUADerror:MAXimum:RESult

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Limit Check Results > Checking Limits for Numerical Result Display > CALCulate<n>:LIMit<k>:SUMMary:QUADerror:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:QUADerror:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:QUADerror[:AVERage]:RESult?

This command queries the result of the quadrature error limit check.

Return values:
<LimitCheck> | The type of limit (average or maximum) that is queried depends on the last syntax element. FAILED Limit check has failed. PASSED Limit check has passed. NOTEVALUATED Limits have not been evaluated.
Example: | CALC:LIM:SUMM:QUAD:RES? Queries the limit check.
Usage: | Query only


CALCulate<n>:LIMit<k>:SUMMary:SERRor:MAXimum:RESult

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Read Limit Check Results > Checking Limits for Numerical Result Display > CALCulate<n>:LIMit<k>:SUMMary:SERRor:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:SERRor:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:SERRor[:AVERage]:RESult?

This command queries the results of the sampling error limit check.

Return values:
<LimitCheck> | The type of limit (average or maximum) that is queried depends on the last syntax element. FAILED Limit check has failed. PASSED Limit check has passed. NOTEVALUATED Limits have not been evaluated.
Example: | CALC:LIM:SUMM:SERR:RES? Queries the limit check.
Usage: | Query only


Remote Commands to Configure the Application

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application
Remote Commands to Configure the Application
Contents
  • General Configuration
  • Configuring I/Q Measurements
  • Configuring Frequency Sweep Measurements


General Configuration

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > General Configuration
General Configuration

The following remote control command control general configration of the application.

The remote control commands to select the result displays for I/Q measurements are described in "Working with Windows in the Display".

List of Commands
CONFigure[:LTE]:MEASurement
MMEMory:LOAD:IQ:STATe
SYSTem:PRESet:CHANnel[:EXECute]


CONFigure[:LTE]:MEASurement

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > General Configuration > CONFigure[:LTE]:MEASurement
CONFigure[:LTE]:MEASurement <Measurement>

This command selects the measurement.

Parameters:
<Measurement> | ACLR Selects the Adjacent Channel Leakage Ratio measurement. ESPectrum Selects the Spectrum Emission Mask measurement. EVM Selects I/Q measurements with the "EVM" display configuration. MCAClr Selects Multi-Carrier ACLR measurement.. TAERor Selects the Time Alignment Error measurement. TPOO Selects the Transmit On/Off Power measurement.
Example: | CONF:MEAS ACLR Selects the ACLR measurement.
Manual operation: | See "ACLR" See "Spectrum Mask" See "Multi Carrier ACLR"


MMEMory:LOAD:IQ:STATe

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > General Configuration > MMEMory:LOAD:IQ:STATe
MMEMory:LOAD:IQ:STATe <Path>

This command restores I/Q data from a file.

Setting parameters:
<Path> | String containing the path and name of the source file.
Example: | MMEM:LOAD:IQ:STAT 'C:\R_S\Instr\user\data.iq.tar' Loads I/Q data from the specified file.
Usage: | Setting only


SYSTem:PRESet:CHANnel[:EXECute]

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > General Configuration > SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:PRESet:CHANnel[:EXECute]

This command restores the default instrument settings in the current channel.

Use INST:SEL to select the channel.

For details see "Factory Default Configuration" .

Example: | INST 'Spectrum2' Selects the channel for "Spectrum2". SYST:PRES:CHAN:EXEC Restores the factory default settings to the "Spectrum2" channel.
Usage: | Event
Manual operation: | See "Preset Channel"


Configuring I/Q Measurements

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements
Configuring I/Q Measurements
Contents
  • Signal Description
  • Input / Frontend
  • Signal Capture
  • Demodulation
  • Tracking


Signal Description

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description
Signal Description
Contents
  • Signal Characteristics
  • MIMO Configuration
  • Subframe Configuration
  • Global Settings
  • Demodulation Reference Signal
  • Sounding Reference Signal
  • PUSCH Structure
  • PUCCH Structure
  • PRACH Structure


Signal Characteristics

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Signal Characteristics
Signal Characteristics
List of Commands
CONFigure[:LTE]:DUPLexing
CONFigure[:LTE]:LDIRection
CONFigure[:LTE]:UL[:CC<cci>]:BW
CONFigure[:LTE]:UL:CYCPrefix
CONFigure[:LTE]:UL:PLC:CID
CONFigure[:LTE]:UL:PLC:CIDGroup
CONFigure[:LTE]:UL:PLC:PLID
CONFigure[:LTE]:UL:TDD:SPSC
CONFigure[:LTE]:UL:TDD:UDConf
MMEMory:LOAD:DEModsetting
MMEMory:LOAD:TMOD:DL
[SENSe][:LTE]:SFLatness:ECONditions
[SENSe][:LTE]:SFLatness:OBANd


CONFigure[:LTE]:DUPLexing

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Signal Characteristics > CONFigure[:LTE]:DUPLexing
CONFigure[:LTE]:DUPLexing <Duplexing>

This command selects the duplexing mode.

Parameters:
<Duplexing>
TDD

Time division duplex

FDD

Frequency division duplex

*RST: FDD
Example: CONF:DUPL TDD

Activates time division duplex.

Manual operation: See "Selecting the LTE Mode"


CONFigure[:LTE]:LDIRection

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Signal Characteristics > CONFigure[:LTE]:LDIRection
CONFigure[:LTE]:LDIRection <Direction>

This command selects the link direction

Parameters:
<Direction> | DL Downlink UL Uplink
Example: | CONF:LDIR DL EUTRA/LTE option is configured to analyze downlink signals.
Manual operation: | See "Selecting the LTE Mode"


CONFigure[:LTE]:UL[:CC<cci>]:BW

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Signal Characteristics > CONFigure[:LTE]:UL[:CC<cci>]:BW
CONFigure[:LTE]:UL[:CC<cci>]:BW <Bandwidth>

This command selects the channel bandwidth.

Parameters:
<Bandwidth> | BW1_40 | BW3_00 | BW5_00 | BW10_00 | BW15_00 | BW20_00
Example: | Single carrier measurement: CONF:UL:BW BW1_40 Defines a channel bandwidth of 1.4 MHz.
Example: | Aggregated carrier measurement: CONF:UL:CC1:BW BW5_00 Defines a channel bandwidth of 5 MHz for the first carrier.
Manual operation: | See "Channel Bandwidth / Number of Resource Blocks" See "Carrier Aggregation"


CONFigure[:LTE]:UL:CYCPrefix

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Signal Characteristics > CONFigure[:LTE]:UL:CYCPrefix
CONFigure[:LTE]:UL:CYCPrefix <PrefixLength>

This command selects the cyclic prefix for uplink signals.

Parameters:
<PrefixLength>
NORM

Normal cyclic prefix length

EXT

Extended cyclic prefix length

AUTO

Automatic cyclic prefix length detection

*RST: AUTO
Example: CONF:UL:CYCP EXT

Sets cyclic prefix type to extended.

Manual operation: See "Cyclic Prefix"


CONFigure[:LTE]:UL:PLC:CID

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Signal Characteristics > CONFigure[:LTE]:UL:PLC:CID
CONFigure[:LTE]:UL:PLC:CID <CellId>

This command defines the cell ID.

Parameters:
<CellId>
AUTO

Automatically defines the cell ID.

<numeric value>

Number of the cell ID.

Range: 0 to 503
Manual operation: See "Configuring the Physical Layer Cell Identity"


CONFigure[:LTE]:UL:PLC:CIDGroup

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Signal Characteristics > CONFigure[:LTE]:UL:PLC:CIDGroup
CONFigure[:LTE]:UL:PLC:CIDGroup <GroupNumber>

This command selects the cell identity group for uplink signals.

Parameters:
<GroupNumber>
Range: | 1 to 167
*RST: | 0
Example: CONF:UL:PLCI:CIDG 12

Selects cell identity group 12.

Manual operation: See "Configuring the Physical Layer Cell Identity"


CONFigure[:LTE]:UL:PLC:PLID

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Signal Characteristics > CONFigure[:LTE]:UL:PLC:PLID
CONFigure[:LTE]:UL:PLC:PLID <Identity>

This command selects the physical layer identity for uplink signals.

Parameters:
<Identity>
AUTO

Automatic selection

0...2

Manual selection

*RST: AUTO
Example: CONF:DL:PLC:PLID 2

Sets the physical layer identity to 2.

CONF:DL:PLC:PLID AUTO

Physical layer ID is selected automatically.

Manual operation: See "Configuring the Physical Layer Cell Identity"


CONFigure[:LTE]:UL:TDD:SPSC

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Signal Characteristics > CONFigure[:LTE]:UL:TDD:SPSC
CONFigure[:LTE]:UL:TDD:SPSC <Configuration>

This command selects the special subframe configuration for LTE uplink signals.

Parameters:
<Configuration> | <numeric value>
Example: | CONF:UL:TDD:SPSC 2 Selects special subframe configuration 2.
Manual operation: | See "Configuring TDD Frames"


CONFigure[:LTE]:UL:TDD:UDConf

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Signal Characteristics > CONFigure[:LTE]:UL:TDD:UDConf
CONFigure[:LTE]:UL:TDD:UDConf <Configuration>

This command selects the UL/DL TDD subframe configuration for uplink signals.

Parameters:
<Configuration>
Range: | 0 to 6
*RST: | 0
Example: CONF:UL:TDD:UDC 4

Selects allocation configuration number 4.

Manual operation: See "Configuring TDD Frames"


MMEMory:LOAD:DEModsetting

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Signal Characteristics > MMEMory:LOAD:DEModsetting
MMEMory:LOAD:DEModsetting <Path>

This command restores previously saved demodulation settings.

The file must be of type "*.allocation" and depends on the link direction that was currently selected when the file was saved. You can load only files with correct link directions.

Setting parameters:
<Path> | String containing the path and name of the file.
Example: | MMEM:LOAD:DEM 'D:\USER\Settingsfile.allocation'
Usage: | Setting only


MMEMory:LOAD:TMOD:DL

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Signal Characteristics > MMEMory:LOAD:TMOD:DL
MMEMory:LOAD:TMOD:DL <TestModel>

This command loads an EUTRA test model (E-TM).

The test models are in accordance with 3GPP TS 36.141.

Setting parameters:
<TestModel> | 'E-TM1_1__20MHz' EUTRA Test Model 1.1 (E-TM1.1) 'E-TM1_2__20MHz' EUTRA Test Model 1.2 (E-TM1.2) 'E-TM2__20MHz' EUTRA Test Model 2 (E-TM2) 'E-TM3_1__20MHz' EUTRA Test Model 3.1 (E-TM3.1) 'E-TM3_2__20MHz' EUTRA Test Model 3.2 (E-TM3.2) 'E-TM3_3__20MHz' EUTRA Test Model 3.3 (E-TM3.3) To select a test model for a different bandwidth, replace "20MHz" with either "1_4MHz", "3MHz", "5MHz", "10MHz" or "15MHz".
Example: | MMEM:LOAD:TMOD:DL 'E-TM2__10MHz' Selects test model 2 for a 10 MHz bandwidth.
Usage: | Setting only


[SENSe][:LTE]:SFLatness:ECONditions

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Signal Characteristics > [SENSe][:LTE]:SFLatness:ECONditions
[SENSe][:LTE]:SFLatness:ECONditions <State>

This command turns extreme conditions for spectrum flatness measurements on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: SFL:ECON ON

Turns extreme conditions on.

Manual operation: See "Extreme Conditions"


[SENSe][:LTE]:SFLatness:OBANd

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Signal Characteristics > [SENSe][:LTE]:SFLatness:OBANd
[SENSe][:LTE]:SFLatness:OBANd <NofSubbands>

This command selects the operating band for spectrum flatness Measurements.

Parameters:
<NofSubbands>
<numeric value>
Range: | 1 to 40
*RST: | 1
Example: SFL:OBAN 10

Selects operating band 10.

Manual operation: See "Operating Band Index"


MIMO Configuration

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > MIMO Configuration
MIMO Configuration
List of Commands
CONFigure[:LTE]:UL:MIMO:ASELection


CONFigure[:LTE]:UL:MIMO:ASELection

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > MIMO Configuration > CONFigure[:LTE]:UL:MIMO:ASELection
CONFigure[:LTE]:UL:MIMO:ASELection <Antenna>

This command selects the antenna for measurements with MIMO setups.

Parameters:
<Antenna> | ANT1 | ANT2 | ANT3 | ANT4 Select a single antenna to be analyzed ALL Select all antennas to be analyzed
Example: | CONF:UL:MIMO:ASEL ANT2 Selects antenna 2 to be analyzed.
Manual operation: | See "MIMO Configuration"


Subframe Configuration

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Subframe Configuration
Subframe Configuration
List of Commands
CONFigure[:LTE]:UL:CSUBframes
CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:CONT
CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:MODulation
CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:PUCCh:FORMat
CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:PUCCh:NPAR
CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:PUSCh:CSField
CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:PUSCh:NDMRs
CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:RATO
CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:RBCount
CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:RBOFfset
[SENSe][:LTE]:UL:DEMod:ACON
[SENSe][:LTE]:UL:FORMat:SCD


CONFigure[:LTE]:UL:CSUBframes

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Subframe Configuration > CONFigure[:LTE]:UL:CSUBframes
CONFigure[:LTE]:UL:CSUBframes <NofSubframes>

This command selects the number of configurable subframes in the uplink signal.

Parameters:
<NofSubframes>
Range: | 1 to 10
*RST: | 1
Example: CONF:UL:CSUB 5

Sets the number of configurable subframes to 5.


CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:CONT

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Subframe Configuration > CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:CONT
CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:CONT <Content>

This command allocates a PUCCH or PUSCH to an uplink allocation.

Parameters:
<Content>
NONE

Turns off the PUSCH and the PUCCH.

PUCCh

Turns on the PUCCH.

PUSCh

Turns on the PUSCH.

PSCC

Turns on the PUCCH as well as the PUSCH.

*RST: PUSC
Example: CONF:UL:SUBF8:ALL:CONT PUCC

Subframe 8 contains a PUCCH.

Manual operation: See "Enable PUCCH"
See "Enable PUSCH"


CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:MODulation

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Subframe Configuration > CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:MODulation
CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:MODulation <Modulation>

This command selects the modulation of an uplink allocation.

Parameters:
<Modulation>
QPSK | QAM16 | QAM64
*RST: QPSK
Example: CONF:UL:SUBF8:ALL:MOD QPSK

The modulation of the allocation in subframe 8 is QPSK.

Manual operation: See "Modulation"


CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:PUCCh:FORMat

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Subframe Configuration > CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:PUCCh:FORMat
CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:PUCCh:FORMat <Format>

This command selects the PUCCH format for a particular subframe.

The command is available if you have selected PUCCH format selection on subframe basis with CONFigure[:LTE]:UL:PUCCh:FORMat.

Parameters:
<Format> | F1N (F1 normal) F1S (F1 shortened) F1AN (F1a normal) F1AS (F1a shortened) F1BN (F1b normal) F1BS (F1b shortened) F2 (F2) F2A (F2a) F2B (F2b) F3 (F3)
Example: | CONF:UL:SUBF4:ALL:PUCC:FORM F3 Selects format F3 for the PUCCH in subframe 4.
Manual operation: | See "Enhanced PUCCH Configuration"


CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:PUCCh:NPAR

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Subframe Configuration > CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:PUCCh:NPAR
CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:PUCCh:NPAR <Parameter>

This command defines N_PUCCH on a subframe basis.

The command is available if CONFigure[:​LTE]:​UL:​PUCCh:​NPAR is turned on.

Parameters:
<Parameter> | <numeric value>
Example: | CONF:UL:SUBF:ALL:PUCC:NPAR 2 Sets N_PUCCH to 2.
Manual operation: | See "Enhanced PUCCH Configuration"


CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:PUSCh:CSField

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Subframe Configuration > CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:PUSCh:CSField
CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:PUSCh:CSField <CyclicShiftField>

This command defines the cyclic shift field of the demodulation reference signal.

Available if CONFigure[:​LTE]:​UL:​DRS:​AOCC has been turned on.

Parameters:
<CyclicShiftField>
Range: | 0 to 7
*RST: | 0
Example: CONF:UL:SUBF:ALL:PUSC:CSF 4

Defines cyclic shift field 4.

Manual operation: See "Enhanced Demodulation Reference Signal Configuration"


CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:PUSCh:NDMRs

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Subframe Configuration > CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:PUSCh:NDMRs
CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:PUSCh:NDMRs <PuschNDMRS>

This command defines the part of the DMRS index that is used for the uplink scheduling assignment.

Parameters:
<PuschNDMRS>
<numeric value>
Range: | 0 to 11
*RST: | 0
Example: CONF:UL:SUBF:ALL:PUSC:NDMR 2

Defines index 2.

Manual operation: See "Enhanced Demodulation Reference Signal Configuration"


CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:RATO

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Subframe Configuration > CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:RATO
CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:RATO <State>

This command turns the resource allocation type 1 on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CONF:UL:SUBF:ALL:RATO ON

Turns resource allocation type 1 on.

Manual operation: See "Enhanced PUSCH Configuration"


CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:RBCount

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Subframe Configuration > CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:RBCount
CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:RBCount <NofRBs>

This command selects the number of resource blocks in an uplink subframe.

Parameters:
<NofRBs>
<numeric value>
*RST: 11
Example: CONF:UL:SUBF8:ALL:RBC 8

Subframe 8 consists of 8 resource blocks.

Manual operation: See "Number of RB"


CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:RBOFfset

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Subframe Configuration > CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:RBOFfset
CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:RBOFfset <RBOffset>

This command defines the resource block offset in an uplink subframe.

Parameters:
<RBOffset>
<numeric value>
*RST: 2
Example: CONF:UL:SUBF8:ALL:RBOF 5

Subframe 8 has a resource block offset of 5.

Manual operation: See "Offset RB"


[SENSe][:LTE]:UL:DEMod:ACON

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Subframe Configuration > [SENSe][:LTE]:UL:DEMod:ACON
[SENSe][:LTE]:UL:DEMod:ACON <Type>

This command selects the method of automatic demodulation for uplink signals.

Parameters:
<Type> | ALL Automatically detects and demodulates the PUSCH and SRS. OFF Automatic demodulation is off. SCON Automatically detects and demodulates the values available in the subframe configuration table.
Example: | UL:DEM:ACON OFF Turns automatic demodulation off.
Manual operation: | See "Auto Demodulation"


[SENSe][:LTE]:UL:FORMat:SCD

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Subframe Configuration > [SENSe][:LTE]:UL:FORMat:SCD
[SENSe][:LTE]:UL:FORMat:SCD <State>

This command turns detection of the subframe configuration on and off.

The command is available if "Auto Demodulation" is turned off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: UL:FORM:SCD ON

Turns detection of the subframe configuration on.

Manual operation: See "Subframe Configuration Detection"


Global Settings

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Global Settings
Global Settings
List of Commands
CONFigure[:LTE]:UL:SFNO
CONFigure[:LTE]:UL:UEID


CONFigure[:LTE]:UL:SFNO

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Global Settings > CONFigure[:LTE]:UL:SFNO
CONFigure[:LTE]:UL:SFNO <Offset>

This command defines the system frame number offset.

The application uses the offset to demodulate the frame.

Parameters:
<Offset>
<numeric value>
*RST: 0
Example: CONF:UL:SFNO 2

Selects frame number offset 2.

Manual operation: See "Frame Number Offset"


CONFigure[:LTE]:UL:UEID

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Global Settings > CONFigure[:LTE]:UL:UEID
CONFigure[:LTE]:UL:UEID <ID>

Sets the radio network temporary identifier (RNTI) of the UE.

Parameters:
<ID>
<numeric value>
*RST: 0
Example: CONF:UL:UEID 2

Sets the UE ID to 2.

Manual operation: See "UE ID/n_RNTI"


Demodulation Reference Signal

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Demodulation Reference Signal
Demodulation Reference Signal
List of Commands
CONFigure[:LTE]:UL:DRS:AOCC
CONFigure[:LTE]:UL:DRS:GRPHopping
CONFigure[:LTE]:UL:DRS:SEQHopping
CONFigure[:LTE]:UL:DRS:PUCCh:POWer
CONFigure[:LTE]:UL:DRS[:PUSCh]:POWer
CONFigure[:LTE]:UL:DRS:NDMRs
CONFigure[:LTE]:UL:DRS:DSSHift


CONFigure[:LTE]:UL:DRS:AOCC

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Demodulation Reference Signal > CONFigure[:LTE]:UL:DRS:AOCC
CONFigure[:LTE]:UL:DRS:AOCC <State>

This command turns the configuration of the demodulation reference signal on a subframe basis via the "Cyclic Field Shift" on and off.

Parameters:
<State> | ON | OFF
Example: | CONF:UL:DRS:AOCC ON Turns Activate-DMRS-with OCC on.
Manual operation: | See "Activate-DMRS-With OCC"


CONFigure[:LTE]:UL:DRS:GRPHopping

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Demodulation Reference Signal > CONFigure[:LTE]:UL:DRS:GRPHopping
CONFigure[:LTE]:UL:DRS:GRPHopping <State>

This command turns group hopping for uplink signals on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CONF:UL:DRS:GRPHopping ON

Activates group hopping.

Manual operation: See "Group Hopping"


CONFigure[:LTE]:UL:DRS:SEQHopping

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Demodulation Reference Signal > CONFigure[:LTE]:UL:DRS:SEQHopping
CONFigure[:LTE]:UL:DRS:SEQHopping <State>

This command turns sequence hopping for uplink signals on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CONF:UL:DRS:SEQH ON

Activates sequence hopping.

Manual operation: See "Sequence Hopping"


CONFigure[:LTE]:UL:DRS:PUCCh:POWer

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Demodulation Reference Signal > CONFigure[:LTE]:UL:DRS:PUCCh:POWer
CONFigure[:LTE]:UL:DRS:PUCCh:POWer <Power>

This command sets the relative power of the PUCCH.

Parameters:
<Power>
*RST: | 0
Default unit: | DB
Example: CONF:UL:DRS:PUCC:POW 2

Sets the power of the PUCCH to 2 dB.

Manual operation: See "Relative Power PUCCH"


CONFigure[:LTE]:UL:DRS[:PUSCh]:POWer

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Demodulation Reference Signal > CONFigure[:LTE]:UL:DRS[:PUSCh]:POWer
CONFigure[:LTE]:UL:DRS[:PUSCh]:POWer <Power>

This command sets the relative power of the PUSCH.

Parameters:
<Power>
*RST: | 0
Default unit: | DB
Example: CONF:UL:DRS:POW 2

Sets the relative power of the PUSCH to 2 dB.

Manual operation: See "Relative Power PUSCH"


CONFigure[:LTE]:UL:DRS:NDMRs

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Demodulation Reference Signal > CONFigure[:LTE]:UL:DRS:NDMRs
CONFigure[:LTE]:UL:DRS:NDMRs <nDMRS>

This command defines the nDMRS.

Parameters:
<nDMRS> | <numeric value>
Example: | CONF:UL:DRS:NDMR 0 Selects nDMRS 0.
Manual operation: | See "n(1)_DMRS"


CONFigure[:LTE]:UL:DRS:DSSHift

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Demodulation Reference Signal > CONFigure[:LTE]:UL:DRS:DSSHift
CONFigure[:LTE]:UL:DRS:DSSHift <Shift>

This command selects the delta sequence shift of the uplink signal.

Parameters:
<Shift>
<numeric value>
*RST: 0
Example: CONF:UL:DRS:DSSH 3

Sets the delta sequence shift to 3.

Manual operation: See "Delta Sequence Shift"


Sounding Reference Signal

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Sounding Reference Signal
Sounding Reference Signal
List of Commands
CONFigure[:LTE]:UL:SRS:ANST
CONFigure[:LTE]:UL:SRS:BHOP
CONFigure[:LTE]:UL:SRS:BSRS
CONFigure[:LTE]:UL:SRS:CSRS
CONFigure[:LTE]:UL:SRS:CYCS
CONFigure[:LTE]:UL:SRS:ISRS
CONFigure[:LTE]:UL:SRS:MUPT
CONFigure[:LTE]:UL:SRS:NRRC
CONFigure[:LTE]:UL:SRS:POWer
CONFigure[:LTE]:UL:SRS:STAT
CONFigure[:LTE]:UL:SRS:SUConfig
CONFigure[:LTE]:UL:SRS:TRComb


CONFigure[:LTE]:UL:SRS:ANST

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Sounding Reference Signal > CONFigure[:LTE]:UL:SRS:ANST
CONFigure[:LTE]:UL:SRS:ANST <State>

This command turns simultaneous transmission of the Sounding Reference Signal (SRS) and ACK/NACK messages (via PUCCH) on and off.

Simultaneous transmission works only if the PUCCH format ist either 1, 1a, 1b or 3.

Parameters:
<State> | ON Allows simultaneous transmission of SRS and PUCCH. OFF SRS not transmitted in the subframe for which you have configured simultaneous transmission of PUCCH and SRS.
Example: | CONF:UL:SRS:ANST ON Turns simultaneous transmission of the SRS and PUCCH in one subframe on.
Manual operation: | See "A/N + SRS Simultaneous TX"


CONFigure[:LTE]:UL:SRS:BHOP

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Sounding Reference Signal > CONFigure[:LTE]:UL:SRS:BHOP
CONFigure[:LTE]:UL:SRS:BHOP <Bandwidth>

This command defines the frequency hopping bandwidth bhop.

Parameters:
<Bandwidth>
<numeric value>
*RST: 0
Example: CONF:UL:SRS:BHOP 1

Sets the frequency hopping bandwidth to 1.

Manual operation: See "Hopping BW b_hop"


CONFigure[:LTE]:UL:SRS:BSRS

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Sounding Reference Signal > CONFigure[:LTE]:UL:SRS:BSRS
CONFigure[:LTE]:UL:SRS:BSRS <Bandwidth>

This command defines the bandwidth of the SRS (BSRS).

Parameters:
<Bandwidth>
<numeric value>
*RST: 0
Example: CONF:UL:SRS:BSRS 1

Sets the SRS bandwidth to 1.

Manual operation: See "SRS Bandwidth B_SRS"


CONFigure[:LTE]:UL:SRS:CSRS

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Sounding Reference Signal > CONFigure[:LTE]:UL:SRS:CSRS
CONFigure[:LTE]:UL:SRS:CSRS <Configuration>

This command defines the SRS bandwidth configuration (CSRS).

Parameters:
<Configuration>
<numeric value>
*RST: 0
Example: CONF:UL:SRS:CSRS 2

Sets the SRS bandwidth configuration to 2.

Manual operation: See "SRS BW Conf. C_SRS"


CONFigure[:LTE]:UL:SRS:CYCS

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Sounding Reference Signal > CONFigure[:LTE]:UL:SRS:CYCS
CONFigure[:LTE]:UL:SRS:CYCS <CyclicShift>

Sets the cyclic shift n_CS used for the generation of the sounding reference signal CAZAC sequence.

Parameters:
<CyclicShift>
<numeric value>
*RST: 0
Example: CONF:UL:SRS:CYCS 2

Sets the cyclic shift to 2.

Manual operation: See "SRS Cyclic Shift N_CS"


CONFigure[:LTE]:UL:SRS:ISRS

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Sounding Reference Signal > CONFigure[:LTE]:UL:SRS:ISRS
CONFigure[:LTE]:UL:SRS:ISRS <ConfIndex>

This command defines the SRS configuration index (ISRS).

Parameters:
<ConfIndex>
<numeric value>
*RST: 0
Example: CONF:UL:SRS:ISRS 1

Sets the configuration index to 1.

Manual operation: See "Conf. Index I_SRS"


CONFigure[:LTE]:UL:SRS:MUPT

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Sounding Reference Signal > CONFigure[:LTE]:UL:SRS:MUPT
CONFigure[:LTE]:UL:SRS:MUPT <State>

This command turns SRS MaxUpPts on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "SRS MaxUpPts"


CONFigure[:LTE]:UL:SRS:NRRC

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Sounding Reference Signal > CONFigure[:LTE]:UL:SRS:NRRC
CONFigure[:LTE]:UL:SRS:NRRC <FreqDomPos>

Sets the UE specific parameter Freq. Domain Position nRRC.

Parameters:
<FreqDomPos>
<numeric value>
*RST: 0
Example: CONF:UL:SRS:NRRC 1

Sets nRRC to 1.

Manual operation: See "Freq. Domain Pos. n_RRC"


CONFigure[:LTE]:UL:SRS:POWer

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Sounding Reference Signal > CONFigure[:LTE]:UL:SRS:POWer
CONFigure[:LTE]:UL:SRS:POWer <Power>

Defines the relative power of the sounding reference signal.

Parameters:
<Power>
<numeric value>
*RST: | 0
Default unit: | DB
Example: CONF:UL:SRS:POW -1.2

Sets the power to -1.2 dB.

Manual operation: See "SRS Rel Power"


CONFigure[:LTE]:UL:SRS:STAT

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Sounding Reference Signal > CONFigure[:LTE]:UL:SRS:STAT
CONFigure[:LTE]:UL:SRS:STAT <State>

Activates or deactivates the sounding reference signal.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CONF:UL:SRS:STAT ON

Activates the sounding reference signal.

Manual operation: See "Present"


CONFigure[:LTE]:UL:SRS:SUConfig

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Sounding Reference Signal > CONFigure[:LTE]:UL:SRS:SUConfig
CONFigure[:LTE]:UL:SRS:SUConfig <Configuration>

This command defines the SRS subframe configuration.

Parameters:
<Configuration>
<numeric value>
*RST: 0
Example: CONF:UL:SRS:SUC 4

Sets SRS subframe configuration to 4.

Manual operation: See "SRS Subframe Conf."


CONFigure[:LTE]:UL:SRS:TRComb

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > Sounding Reference Signal > CONFigure[:LTE]:UL:SRS:TRComb
CONFigure[:LTE]:UL:SRS:TRComb <TransComb>

This command defines the transmission comb (kTC).

Parameters:
<TransComb>
<numeric value>
*RST: 0
Example: CONF:UL:SRS:TRC 1

Sets transmission comb to 1.

Manual operation: See "Transm. Comb. k_TC"


PUSCH Structure

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > PUSCH Structure
PUSCH Structure
List of Commands
CONFigure[:LTE]:UL:PUSCh:FHMode
CONFigure[:LTE]:UL:PUSCh:FHOFfset
CONFigure[:LTE]:UL:PUSCh:FHOP:IIHB
CONFigure[:LTE]:UL:PUSCh:NOSM


CONFigure[:LTE]:UL:PUSCh:FHMode

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > PUSCH Structure > CONFigure[:LTE]:UL:PUSCh:FHMode
CONFigure[:LTE]:UL:PUSCh:FHMode <HoppingMode>

This command selects the frequency hopping mode in the PUSCH structure.

Parameters:
<HoppingMode>
NONE

No hopping

INTer

Inter subframe hopping

INTRa

Intra subframe hopping

*RST: NONE
Example: CONF:UL:PUSC:FHM NONE

Deactivates frequency hopping for the PUSCH.

Manual operation: See "Frequency Hopping Mode"


CONFigure[:LTE]:UL:PUSCh:FHOFfset

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > PUSCH Structure > CONFigure[:LTE]:UL:PUSCh:FHOFfset
CONFigure[:LTE]:UL:PUSCh:FHOFfset <Offset>

This command defines the frequency hopping offset for the PUSCH.

Parameters:
<Offset>
<numeric value>
*RST: 4
Example: CONF:UL:PUSC:FHOF 5

Sets the hopping offset to 5.

Manual operation: See "PUSCH Hopping Offset"


CONFigure[:LTE]:UL:PUSCh:FHOP:IIHB

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > PUSCH Structure > CONFigure[:LTE]:UL:PUSCh:FHOP:IIHB
CONFigure[:LTE]:UL:PUSCh:FHOP:IIHB <HBInfo>

This command defines the information in hopping bits of the PUSCH.

Parameters:
<HBInfo>
<numeric value>
Range: | 0 to 3
*RST: | 0
Example: CONF:UL:PUSC:FHOP:IIHB 1

Defines type 1 as the information in hopping bits.

Manual operation: See "Info. in Hopping Bits"


CONFigure[:LTE]:UL:PUSCh:NOSM

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > PUSCH Structure > CONFigure[:LTE]:UL:PUSCh:NOSM
CONFigure[:LTE]:UL:PUSCh:NOSM <NofSubbands>

This command defines the number of subbands/M of the PUSCH.

Parameters:
<NofSubbands>
<numeric value>
*RST: 4
Example: CONF:UL:PUSC:NOSM 2

Sets the number of subbands to 2.

Manual operation: See "Number of Subbands"


PUCCH Structure

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > PUCCH Structure
PUCCH Structure
List of Commands
CONFigure[:LTE]:UL:PUCCh:DESHift
CONFigure[:LTE]:UL:PUCCh:FORMat
CONFigure[:LTE]:UL:PUCCh:N1CS
CONFigure[:LTE]:UL:PUCCh:N2RB
CONFigure[:LTE]:UL:PUCCh:NORB
CONFigure[:LTE]:UL:PUCCh:NPAR


CONFigure[:LTE]:UL:PUCCh:DESHift

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > PUCCH Structure > CONFigure[:LTE]:UL:PUCCh:DESHift
CONFigure[:LTE]:UL:PUCCh:DESHift <Shift>

This command defines the delta shift of the PUCCH.

Parameters:
<Shift>
<numeric value>
Range: | 1 to 3
*RST: | 2
Example: CONF:UL:PUCC:DESH 3

Sets the delta shift of the PUCCH to 3.

Manual operation: See "Delta Shift"


CONFigure[:LTE]:UL:PUCCh:FORMat

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > PUCCH Structure > CONFigure[:LTE]:UL:PUCCh:FORMat
CONFigure[:LTE]:UL:PUCCh:FORMat <Format>

This command selects the PUCCH format.

Note that formats 2a and 2b are available for normal cyclic prefix length only.

Parameters:
<Format>
F1 (F1)
F1A (F1a)
F1B (F1b)
F2 (F2)
F2A (F2a)
F2B (F2b)
F3 (F3)
SUBF

Allows you to define the PUCCH format for each subframe separately with .

*RST: F1
Example: CONF:UL:PUCC:FORM F1B

Sets the PUCCH format to F1B.

Manual operation: See "Format"


CONFigure[:LTE]:UL:PUCCh:N1CS

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > PUCCH Structure > CONFigure[:LTE]:UL:PUCCh:N1CS
CONFigure[:LTE]:UL:PUCCh:N1CS <N1cs>

This command defines the N(1)_cs of the PUCCH.

Parameters:
<N1cs>
<numeric value>
*RST: 6
Example: CONF:UL:PUCC:N1CS 4

Sets N(1)_cs to 4.

Manual operation: See "N(1)_cs"


CONFigure[:LTE]:UL:PUCCh:N2RB

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > PUCCH Structure > CONFigure[:LTE]:UL:PUCCh:N2RB
CONFigure[:LTE]:UL:PUCCh:N2RB <N2RB>

This command defines the N(2)_RB of the PUCCH.

Parameters:
<N2RB>
<numeric value>
*RST: 1
Example: CONF:UL:PUCC:N2RB 2

Sets N2_RB to 2.

Manual operation: See "N(2)_RB"


CONFigure[:LTE]:UL:PUCCh:NORB

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > PUCCH Structure > CONFigure[:LTE]:UL:PUCCh:NORB
CONFigure[:LTE]:UL:PUCCh:NORB <ResourceBlocks>

This command selects the number of resource blocks for the PUCCH.

Parameters:
<ResourceBlocks>
<numeric value>

Selects the number of RBs.

AUTO

Detects the number of RBs automatically.

*RST: 0
Example: CONF:UL:PUCC:NORB 6

Sets the number of resource blocks to 6.

Manual operation: See "No. of RBs for PUCCH"


CONFigure[:LTE]:UL:PUCCh:NPAR

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > PUCCH Structure > CONFigure[:LTE]:UL:PUCCh:NPAR
CONFigure[:LTE]:UL:PUCCh:NPAR <NPUCCH>

This command defines the N_PUCCH parameter in the PUCCH structure settings.

Parameters:
<NPUCCH>
<numeric value>
<numeric value>
SUBF

Selects the definition of N_PUCCH on subframe level.

*RST: 0
Example: CONF:UL:PUCC:NPAR 2

Sets N_PUCCH to 2.

Manual operation: See "N_PUCCH"


PRACH Structure

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > PRACH Structure
PRACH Structure
List of Commands
CONFigure[:LTE]:UL:PRACh:APM
CONFigure[:LTE]:UL:PRACh:CONF
CONFigure[:LTE]:UL:PRACh:FOFFset
CONFigure[:LTE]:UL:PRACh:FRINdex
CONFigure[:LTE]:UL:PRACh:HFINdicator
CONFigure[:LTE]:UL:PRACh:NCSC
CONFigure[:LTE]:UL:PRACh:RSEQ
CONFigure[:LTE]:UL:PRACh:RSET
CONFigure[:LTE]:UL:PRACh:SINDex


CONFigure[:LTE]:UL:PRACh:APM

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > PRACH Structure > CONFigure[:LTE]:UL:PRACh:APM
CONFigure[:LTE]:UL:PRACh:APM <State>

This command turns automatic preamble mapping for the PRACH on and off.

Parameters:
<State> | ON | OFF
Example: | CONF:UL:PRAC:APM ON Turns automatic preamble mapping on.
Manual operation: | See "PRACH Preamble Mapping"


CONFigure[:LTE]:UL:PRACh:CONF

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > PRACH Structure > CONFigure[:LTE]:UL:PRACh:CONF
CONFigure[:LTE]:UL:PRACh:CONF <Configuration>

This command selects the PRACH preamble format.

Parameters:
<Configuration> | <numeric value>
Example: | CONF:UL:PRAC:CONF 2 Selects PRACH configuration 2.
Manual operation: | See "PRACH Configuration"


CONFigure[:LTE]:UL:PRACh:FOFFset

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > PRACH Structure > CONFigure[:LTE]:UL:PRACh:FOFFset
CONFigure[:LTE]:UL:PRACh:FOFFset <Offset>

This command defines the PRACH frequency offset.

The command is available for preamble formats 0 to 3.

Parameters:
<Offset> | Resource block offset.
Example: | CONF:UL:PRAC:FOFF 5 Defines a frequency offset of 5 resource blocks.
Manual operation: | See "Frequency Offset"


CONFigure[:LTE]:UL:PRACh:FRINdex

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > PRACH Structure > CONFigure[:LTE]:UL:PRACh:FRINdex
CONFigure[:LTE]:UL:PRACh:FRINdex <FRINdex>

This command selects the PRACH frequency index.

Parameters:
<FRINdex> | <numeric value>
Example: | CONF:UL:PRAC:FRIN 10 Selects the frequency index 10.
Manual operation: | See "PRACH Preamble Mapping"


CONFigure[:LTE]:UL:PRACh:HFINdicator

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > PRACH Structure > CONFigure[:LTE]:UL:PRACh:HFINdicator
CONFigure[:LTE]:UL:PRACh:HFINdicator <HFINdicator>

This command defines the PRACH half frame indicator.

Parameters:
<HFINdicator> | <numeric value>
Example: | CONF:UL:PRAC:HFIN 5 Selects half frame indicator 5.
Manual operation: | See "PRACH Preamble Mapping"


CONFigure[:LTE]:UL:PRACh:NCSC

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > PRACH Structure > CONFigure[:LTE]:UL:PRACh:NCSC
CONFigure[:LTE]:UL:PRACh:NCSC <Configuration>

This command defines the Ncs configuration for the PRACH.

Parameters:
<Configuration> | <numeric value>
Example: | CONF:UL:PRAC:NCSC 1 Selects Ncs configuration 1.
Manual operation: | See "Ncs Conf"


CONFigure[:LTE]:UL:PRACh:RSEQ

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > PRACH Structure > CONFigure[:LTE]:UL:PRACh:RSEQ
CONFigure[:LTE]:UL:PRACh:RSEQ <RootSeqIdx>

This command defines the PRACH logical root sequence index.

Parameters:
<RootSeqIdx> | <numeric value>
Example: | CONF:UL:PRAC:RSEQ 2 Selects logical root sequence index 2.
Manual operation: | See "Logical Root Sequ. Idx"


CONFigure[:LTE]:UL:PRACh:RSET

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > PRACH Structure > CONFigure[:LTE]:UL:PRACh:RSET
CONFigure[:LTE]:UL:PRACh:RSET <State>

This command turns the restricted preamble set for PRACH on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CONF:UL:PRAC:RSET ON

Turns the restricted set on.

Manual operation: See "Restricted Set"


CONFigure[:LTE]:UL:PRACh:SINDex

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Description > PRACH Structure > CONFigure[:LTE]:UL:PRACh:SINDex
CONFigure[:LTE]:UL:PRACh:SINDex <Index>

This command selects the PRACH sequence index.

Parameters:
<Index> | <IndexValue> Number that defines the index manually. AUTO Automatcailly determines the index.
Example: | CONF:UL:PRAC:SIND 2 Selects sequence index 2.
Manual operation: | See "Sequence Index (v)"


Input / Frontend

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend
Input / Frontend
Contents
  • Configuring the Input
  • Defining the Frequency
  • Configuring the Vertical Axis


Configuring the Input

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Configuring the Input
Configuring the Input
Remote commands to configure the input described elsewhere:
  • INPut:​COUPling
  • INPut:​IMPedance
  • [SENSe]:​SWAPiq
List of Commands
INPut:DIQ:CDEVice
INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:SRATe
INPut:DIQ:SRATe:AUTO
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:IQ:BALanced[:STATe]
INPut:IQ:TYPE
INPut:SELect


INPut:DIQ:CDEVice

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Configuring the Input > INPut:DIQ:CDEVice
INPut:DIQ:CDEVice

This command queries the current configuration and the status of the digital I/Q input from the optional Digital Baseband Interface (R&S FSW-B17).

For details see "Interface Status Information" .

Return values:
<ConnState>

Defines whether a device is connected or not.

0

No device is connected.

1

A device is connected.

<DeviceName>

Device ID of the connected device

<SerialNumber>

Serial number of the connected device

<PortName>

Port name used by the connected device

<SampleRate>

Maximum or currently used sample rate of the connected device in Hz (depends on the used connection protocol version; indicated by <SampleRateType> parameter)

<MaxTransferRate>

Maximum data transfer rate of the connected device in Hz

<ConnProtState>

State of the connection protocol which is used to identify the connected device.

Not Started
Has to be Started
Started
Passed
Failed
Done
<PRBSTestState>

State of the PRBS test.

Not Started
Has to be Started
Started
Passed
Failed
Done
<SampleRateType>
0

Maximum sample rate is displayed

1

Current sample rate is displayed

<FullScaleLevel>

The level (in dBm) that should correspond to an I/Q sample with the magnitude "1" (if transferred from connected device);

If not available, 9.97e37 is returned

Example: INP:DIQ:CDEV?

Result:

1,SMU200A,103634,Out A,70000000,100000000,Passed,Not Started,0,0
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .


INPut:DIQ:RANGe[:UPPer]:AUTO

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Configuring the Input > INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe[:UPPer]:AUTO <State>

If enabled, the digital input full scale level is automatically set to the value provided by the connected device (if available).

This command is only available if the optional Digital Baseband interface (option R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF


INPut:DIQ:RANGe:COUPling

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Configuring the Input > INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe:COUPling <State>

If enabled, the reference level for digital input is adjusted to the full scale level automatically if the full scale level changes.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .


INPut:DIQ:RANGe[:UPPer]

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Configuring the Input > INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer] <Level>

Defines or queries the "Full Scale Level", i.e. the level that corresponds to an I/Q sample with the magnitude "1".

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<Level>
<numeric value>
Range: | 1 μV to 7.071 V
*RST: | 1 V
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .


INPut:DIQ:RANGe[:UPPer]:UNIT

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Configuring the Input > INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:RANGe[:UPPer]:UNIT <Unit>

Defines the unit of the full scale level (see "Full Scale Level" ). The availability of units depends on the measurement application you are using.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<Level>
VOLT | DBM | DBPW | WATT | DBMV | DBUV | DBUA | AMPere
*RST: Volt


INPut:DIQ:SRATe

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Configuring the Input > INPut:DIQ:SRATe
INPut:DIQ:SRATe <SampleRate>

This command specifies or queries the sample rate of the input signal from the Digital Baseband Interface (R&S FSW-B17, see "Input Sample Rate" ).

Parameters:
<SampleRate>
Range: | 1 Hz to 10 GHz
*RST: | 32 MHz
Example:

INP:DIQ:SRAT 200 MHz


INPut:DIQ:SRATe:AUTO

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Configuring the Input > INPut:DIQ:SRATe:AUTO
INPut:DIQ:SRATe:AUTO <State>

If enabled, the sample rate of the digital I/Q input signal is set automatically by the connected device.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .


INPut:FILTer:HPASs[:STATe]

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Configuring the Input > INPut:FILTer:HPASs[:STATe]
INPut:FILTer:HPASs[:STATe] <State>

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Parameters:
<State>
ON | OFF
*RST: OFF
Usage: SCPI confirmed


INPut:FILTer:YIG[:STATe]

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Configuring the Input > INPut:FILTer:YIG[:STATe]
INPut:FILTer:YIG[:STATe] <State>

This command turns the YIG-preselector on and off.

Note the special conditions and restrictions for the YIG filter described in "YIG-Preselector" .

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1 (0 for I/Q Analyzer, GSM, VSA and MC Group Delay measurements)
Example: INP:FILT:YIG OFF

Deactivates the YIG-preselector.


INPut:IQ:BALanced[:STATe]

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Configuring the Input > INPut:IQ:BALanced[:STATe]
INPut:IQ:BALanced[:STATe] <State>

This command defines whether the input is provided as a differential signal via all 4 Analog Baseband connectors or as a plain I/Q signal via 2 simple-ended lines.

Parameters:
<State>
ON

Differential

OFF

Simple-ended

*RST: ON
Example: INP:IQ:BAL OFF
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .


INPut:IQ:TYPE

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Configuring the Input > INPut:IQ:TYPE
INPut:IQ:TYPE <DataType>

This command defines the format of the input signal.

Parameters:
<DataType>
IQ | I | Q
IQ

The input signal is filtered and resampled to the sample rate of the application.

Two input channels are required for each input signal, one for the in-phase component, and one for the quadrature component.

I

The quadrature component of the input signal is filtered and resampled to the sample rate of the application. If the center frequency is not 0, the quadrature component of the input signal is down-converted first (Low IF Q).

Q

The quadrature component of the input signal is filtered and resampled to the sample rate of the application. If the center frequency is not 0, the quadrature component of the input signal is down-converted first (Low IF Q).

*RST: IQ
Example:

INP:IQ:TYPE Q

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .


INPut:SELect

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Configuring the Input > INPut:SELect
INPut:SELect <Source>

This command selects the signal source for measurements, i.e. it defines which connector is used to input data to the R&S FSW. If no additional options are installed, only RF input is supported.

Parameters:
<Source>
RF

Radio Frequency ("RF INPUT" connector)

DIQ

Digital IQ data (only available with optional Digital Baseband Interface R&S FSW-B17)

For details on I/Q input see "Digital Input" .

AIQ

Analog Baseband signal (only available with optional Analog Baseband Interface R&S FSW-B71)

For details on Analog Baseband input see "Processing Data From the Analog Baseband Interface" .

*RST: RF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .


Defining the Frequency

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Defining the Frequency
Defining the Frequency
List of Commands
[SENSe]:FREQuency:CENTer[:CC<cci>]
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:LINK
[SENSe:]FREQuency:CENTer:STEP:LINK:FACTor
[SENSe:]FREQuency:OFFSet


[SENSe]:FREQuency:CENTer[:CC<cci>]

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Defining the Frequency > [SENSe]:FREQuency:CENTer[:CC<cci>]
[SENSe]:FREQuency:CENTer[:CC<cci>] <Frequency>

This command sets the center frequency for RF measurements.

MC ACLR measurements
  • Defining or querying the frequency of the first carrier is possible with FREQ:CENT:CC1. The CC1 part of the syntax is mandatory in that case.
  • FREQ:CENT? queries the measurement frequency (center of the two carriers).
Parameters:
<Frequency>
<numeric value>
Range: | fmin to fmax
*RST: | 1 GHz
Default unit: | Hz
Example:

Measurement on one carrier:

FREQ:CENT 1GHZ

Defines a center frequency of 1 GHz

Example:

Measurement on aggregated carriers:

FREQ:CENT:CC1 850MHZ

Defines a center frequency of 850 MHz for the first carrier.

Manual operation: See "Carrier Aggregation"


[SENSe:]FREQuency:CENTer:STEP

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Defining the Frequency > [SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP <StepSize>

This command defines the center frequency step size.

You can increase or decrease the center frequency quickly in fixed steps using the SENS:FREQ UP and SENS:FREQ DOWN commands, see [SENSe]:​FREQuency:​CENTer[:​CC<cci>].

Parameters:
<StepSize>

fmax is specified in the data sheet.

Range: | 1 to fMAX
*RST: | 0.1 x span
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.


[SENSe:]FREQuency:CENTer:STEP:LINK

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Defining the Frequency > [SENSe:]FREQuency:CENTer:STEP:LINK
[SENSe:]FREQuency:CENTer:STEP:LINK <CouplingType>

This command couples and decouples the center frequency step size to the span or the resolution bandwidth.

Parameters:
<CouplingType>
SPAN

Couples the step size to the span. Available for measurements in the frequency domain.

OFF

Decouples the step size.

*RST: SPAN
Example: FREQ:CENT:STEP:LINK SPAN


[SENSe:]FREQuency:CENTer:STEP:LINK:FACTor

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Defining the Frequency > [SENSe:]FREQuency:CENTer:STEP:LINK:FACTor
[SENSe:]FREQuency:CENTer:STEP:LINK:FACTor <Factor>
Parameters:
<Factor>
1 to 100 PCT
*RST: 10
Example: FREQ:CENT:STEP:LINK:FACT 20PCT


[SENSe:]FREQuency:OFFSet

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Defining the Frequency > [SENSe:]FREQuency:OFFSet
[SENSe:]FREQuency:OFFSet <Offset>

This command defines a frequency offset.

If this value is not 0 Hz, the application assumes that the input signal was frequency shifted outside the application. All results of type "frequency" will be corrected for this shift numerically by the application.

Note: In MSRA mode, the setting command is only available for the MSRA Master. For MSRA applications, only the query command is available.

Parameters:
<Offset>
Range: | -100 GHz to 100 GHz
*RST: | 0 Hz
Example: FREQ:OFFS 1GHZ
Usage: SCPI confirmed


Configuring the Vertical Axis

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Configuring the Vertical Axis
Configuring the Vertical Axis
List of Commands
CALCulate<n>:UNIT:POWer
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:COUPling
INPut:GAIN[:VALue]
INPut:GAIN:STATe
INPut:IMPedance
INPut<n>:EATT
INPut<n>:EATT:AUTO
INPut<n>:EATT:STATe
[SENSe:]ADJust:LEVel


CALCulate<n>:UNIT:POWer

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Configuring the Vertical Axis > CALCulate<n>:UNIT:POWer
CALCulate<n>:UNIT:POWer <Unit>

This command selects the unit of the y-axis.

The unit applies to all measurement windows.

Parameters:
<Unit>
DBM | V | A | W | DBPW | WATT | DBUV | DBMV | VOLT | DBUA | AMPere
*RST: dBm
Example: CALC:UNIT:POW DBM

Sets the power unit to dBm.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Defining a Reference Level"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Configuring the Vertical Axis > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel <ReferenceLevel>

This command defines the reference level.

With a reference level offset ≠ 0, the value range of the reference level is modified by the offset.

Parameters:
<ReferenceLevel>

The unit is variable.

Range: | see datasheet
*RST: | 0 dBm
Example: DISP:TRAC:Y:RLEV -60dBm
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Defining a Reference Level"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Configuring the Vertical Axis > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet <Offset>

This command defines a reference level offset.

Parameters:
<Offset>
Range: | -200 dB to 200 dB
*RST: | 0dB
Example: DISP:TRAC:Y:RLEV:OFFS -10dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Defining a Reference Level"


INPut:ATTenuation

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Configuring the Vertical Axis > INPut:ATTenuation
INPut:ATTenuation <Attenuation>

This command defines the total attenuation for RF input.

If you set the attenuation manually, it is no longer coupled to the reference level, but the reference level is coupled to the attenuation. Thus, if the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

Parameters:
<Attenuation>
Range: | see data sheet
Increment: | 5 dB
*RST: | 10 dB (AUTO is set to ON)
Example: INP:ATT 30dB

Defines a 30 dB attenuation and decouples the attenuation from the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuating the Signal"


INPut:ATTenuation:AUTO

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Configuring the Vertical Axis > INPut:ATTenuation:AUTO
INPut:ATTenuation:AUTO <State>

This command couples or decouples the attenuation to the reference level. Thus, when the reference level is changed, the R&S FSW determines the signal level for optimal internal data processing and sets the required attenuation accordingly.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:ATT:AUTO ON

Couples the attenuation to the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuating the Signal"


INPut:COUPling

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Configuring the Vertical Axis > INPut:COUPling
INPut:COUPling <CouplingType>

This command selects the coupling type of the RF input.

Parameters:
<CouplingType>
AC

AC coupling

DC

DC coupling

*RST: AC
Example: INP:COUP DC
Usage: SCPI confirmed
Manual operation: See "Input Coupling"


INPut:GAIN[:VALue]

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Configuring the Vertical Axis > INPut:GAIN[:VALue]
INPut:GAIN[:VALue] <Gain>

This command selects the preamplification level if the preamplifier is activated (INP:GAIN:STAT ON, see INPut:​GAIN:​STATe).

The command requires option R&S FSW-B24.

Parameters:
<Gain>
15 dB | 30 dB

The availability of preamplification levels depends on the R&S FSW model.

R&S FSW8/13: 15dB and 30 dB

R&S FSW26 or higher: 30 dB

All other values are rounded to the nearest of these two.

*RST: OFF
Example: INP:GAIN:VAL 30

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


INPut:GAIN:STATe

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Configuring the Vertical Axis > INPut:GAIN:STATe
INPut:GAIN:STATe <State>

This command turns the preamplifier on and off.

The command requires option R&S FSW-B24.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:GAIN:STAT ON

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


INPut:IMPedance

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Configuring the Vertical Axis > INPut:IMPedance
INPut:IMPedance <Impedance>

This command selects the nominal input impedance of the RF input.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a matching pad of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The power loss correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

Parameters:
<Impedance>
50 | 75
*RST: 50 Ω
Example: INP:IMP 75
Usage: SCPI confirmed
Manual operation: See "Impedance"


INPut<n>:EATT

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Configuring the Vertical Axis > INPut<n>:EATT
INPut<n>:EATT <Attenuation>

This command defines the electronic attenuation level.

If the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

This command is available with option R&S FSW-B25, but not if R&S FSW-B17 is active.

Parameters:
<Attenuation>

Attenuation level in dB.

Default unit: dB
Example: INP:EATT 10

Defines an attenuation level of 10 dB.

Manual operation: See "Attenuating the Signal"


INPut<n>:EATT:AUTO

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Configuring the Vertical Axis > INPut<n>:EATT:AUTO
INPut<n>:EATT:AUTO <State>

This command turns automatic selection of the electronic attenuation on and off.

If on, electronic attenuation reduces the mechanical attenuation whenever possible.

This command is available with option R&S FSW-B25, but not if R&S FSW-B17 is active.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:EATT:AUTO ON

Turns automatic selection of electronic attenuation level on.

Manual operation: See "Attenuating the Signal"


INPut<n>:EATT:STATe

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Configuring the Vertical Axis > INPut<n>:EATT:STATe
INPut<n>:EATT:STATe <State>

This command turns the electronic attenuator on and off.

This command is available with option R&S FSW-B25, but not if R&S FSW-B17 is active.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:EATT:STAT ON

Turns the electronic attenuator on.

Manual operation: See "Attenuating the Signal"


[SENSe:]ADJust:LEVel

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Input / Frontend > Configuring the Vertical Axis > [SENSe:]ADJust:LEVel
[SENSe:]ADJust:LEVel

This command initiates a single (internal) measurement that evaluates and sets the ideal reference level for the current input data and measurement settings. This ensures that the settings of the RF attenuation and the reference level are optimally adjusted to the signal level without overloading the R&S FSW or limiting the dynamic range by an S/N ratio that is too small.

Example: | ADJ:LEV
Usage: | Event
Manual operation: | See "Defining a Reference Level"


Signal Capture

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Capture
Signal Capture
Contents
  • Data Capture
  • Trigger


Data Capture

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Capture > Data Capture
Data Capture
List of Commands
[SENSe][:LTE]:FRAMe:COUNt
[SENSe][:LTE]:FRAMe:COUNt:AUTO
[SENSe][:LTE]:FRAMe:COUNt:STATe
[SENSe]:SWAPiq
[SENSe]:SWEep:TIME


[SENSe][:LTE]:FRAMe:COUNt

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Capture > Data Capture > [SENSe][:LTE]:FRAMe:COUNt
[SENSe][:LTE]:FRAMe:COUNt <Subframes>

This command sets the number of frames you want to analyze.

Parameters:
<Subframes>
<numeric value>
*RST: 1
Example: FRAM:COUN:STAT ON
FRAM:COUN:AUTO OFF

Activates manual input of frames to be analyzed.

FRAM:COUN 20

Analyzes 20 frames.

Manual operation: See "Number of Frames to Analyze"


[SENSe][:LTE]:FRAMe:COUNt:AUTO

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Capture > Data Capture > [SENSe][:LTE]:FRAMe:COUNt:AUTO
[SENSe][:LTE]:FRAMe:COUNt:AUTO <State>

This command turns automatic selection of the number of frames to analyze on and off.

Parameters:
<State> | ON Selects the number of frames to analyze according to the LTE standard. OFF Turns manual selection of the frame number on.
Example: | FRAM:COUN:AUTO ON Turns automatic selection of the analyzed frames on.
Manual operation: | See "Auto According to Standard"


[SENSe][:LTE]:FRAMe:COUNt:STATe

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Capture > Data Capture > [SENSe][:LTE]:FRAMe:COUNt:STATe
[SENSe][:LTE]:FRAMe:COUNt:STATe <State>

This command turns manual selection of the number of frames you want to analyze on and off.

Parameters:
<State>
ON

You can set the number of frames to analyze.

OFF

The R&S FSW analyzes a single sweep.

*RST: ON
Example: FRAM:COUN:STAT ON

Turns manual setting of number of frames to analyze on.

Manual operation: See "Overall Frame Count"


[SENSe]:SWAPiq

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Capture > Data Capture > [SENSe]:SWAPiq
[SENSe]:SWAPiq <State>

This command turns a swap of the I and Q branches on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: SWAP ON

Turns a swap of the I and Q branches on.

Manual operation: See "Swap I/Q"


[SENSe]:SWEep:TIME

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Capture > Data Capture > [SENSe]:SWEep:TIME
[SENSe]:SWEep:TIME <CaptLength>

This command sets the capture time.

Parameters:
<CaptLength>

Numeric value in seconds.

Default unit: s
Example: SWE:TIME 40ms

Defines a capture time of 40 milliseconds.

Manual operation: See "Capture Time"


Trigger

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Capture > Trigger
Trigger

The trigger functionality of the LTE measurement application is the same as that of the R&S FSW.

For a comprehensive description of the available remote control commands for trigger configuration see the documentation of the R&S FSW.

List of Commands
TRIGger[:SEQuence]:HOLDoff<instrument>
TRIGger[:SEQuence]:LEVel<instrument>[:EXTernal]
TRIGger[:SEQuence]:PORT<instrument>
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce


TRIGger[:SEQuence]:HOLDoff<instrument>

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Capture > Trigger > TRIGger[:SEQuence]:HOLDoff<instrument>
TRIGger[:SEQuence]:HOLDoff<instrument> <Offset>

This command defines the trigger offset.

Parameters:
<Offset>
<numeric value>
*RST: | 0 s
Default unit: | s
Example: TRIG:HOLD 5MS

Sets the trigger offset to 5 ms.


TRIGger[:SEQuence]:LEVel<instrument>[:EXTernal]

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Capture > Trigger > TRIGger[:SEQuence]:LEVel<instrument>[:EXTernal]
TRIGger[:SEQuence]:LEVel<instrument>[:EXTernal] <Level>

This command defines the level for an external trigger.

Parameters:
<Level>
Range: | 0.5 V to 3.5 V
*RST: | 1.4 V
Default unit: | V
Example: TRIG:LEV 2V

Defines a trigger level of 2 V.


TRIGger[:SEQuence]:PORT<instrument>

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Capture > Trigger > TRIGger[:SEQuence]:PORT<instrument>
TRIGger[:SEQuence]:PORT<instrument> <Port>

This command selects the trigger port for measurements with devices that have several trigger ports (e.g. the R&S FSW).

Parameters:
<Port> | PORT1 PORT2 PORT3
Example: | TRIG:PORT PORT1 Selects trigger port 1.


TRIGger[:SEQuence]:SLOPe

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Capture > Trigger > TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SLOPe <Type>

For external and time domain trigger sources you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Parameters:
<Type>
POSitive | NEGative
POSitive

Triggers when the signal rises to the trigger level (rising edge).

NEGative

Triggers when the signal drops to the trigger level (falling edge).

*RST: POSitive
Example: TRIG:SLOP NEG
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .


TRIGger[:SEQuence]:SOURce

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Signal Capture > Trigger > TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:SOURce <Source>

This command selects the trigger source.

Note on external triggers:

If a measurement is configured to wait for an external trigger signal in a remote control program, remote control is blocked until the trigger is received and the program can continue. Make sure this situation is avoided in your remote control programs.

Parameters:
<Source>
IMMediate

Free Run

EXTernal

Trigger signal from the TRIGGER INPUT connector.

EXT2

Trigger signal from the TRIGGER INPUT/OUTPUT connector.

Note: Connector must be configured for "Input".

EXT3

Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector.

Note: Connector must be configured for "Input".

RFPower

First intermediate frequency

IFPower

Second intermediate frequency

IQPower

Magnitude of sampled I/Q data

For applications that process I/Q data, such as the I/Q Analyzer or optional applications.

TIME

Time interval

BBPower

Baseband power (for digital input via the Digital Baseband Interface R&S FSW-B17)

Baseband power (for digital input via the Digital Baseband Interface R&S FSW-B17 or the Analog Baseband interface R&S FSW-B71)

PSEN

External power sensor

GP0 | GP1 | GP2 | GP3 | GP4 | GP5

For applications that process I/Q data, such as the I/Q Analyzer or optional applications, and only if the Digital Baseband Interface (R&S FSW-B17) is available.

Defines triggering of the measurement directly via the LVDS connector. The parameter specifies which general purpose bit (0 to 5) will provide the trigger data.

*RST: IMMediate
Example: TRIG:SOUR EXT

Selects the external trigger input as source of the trigger signal

Example:

See "Basic I/Q Analysis with Improved Performance" .

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Example:

See "Programming Example" .


Demodulation

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Demodulation
Demodulation
List of Commands
[SENSe][:LTE]:UL:DEMod:ATTSlots
[SENSe][:LTE]:UL:DEMod:MODE
[SENSe][:LTE]:UL:DEMod:CESTimation
[SENSe][:LTE]:UL:DEMod:EEPeriod
[SENSe][:LTE]:UL:DEMod:CDCoffset
[SENSe][:LTE]:UL:DEMod:CBSCrambling
[SENSe][:LTE]:UL:DEMod:SISYnc
[SENSe][:LTE]:UL:DEMod:MCFilter


[SENSe][:LTE]:UL:DEMod:ATTSlots

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Demodulation > [SENSe][:LTE]:UL:DEMod:ATTSlots
[SENSe][:LTE]:UL:DEMod:ATTSlots <State>

This command includes or excludes the transient slots present after a switch from downlink to uplink in the analysis.

Parameters:
<State> | ON | OFF
Example: | UL:DEM:ATTS ON Includes the transient slots in the analysis.
Manual operation: | See "Analyze TDD Transient Slots"


[SENSe][:LTE]:UL:DEMod:MODE

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Demodulation > [SENSe][:LTE]:UL:DEMod:MODE
[SENSe][:LTE]:UL:DEMod:MODE <Reference>

This command selects the uplink analysis mode.

Parameters:
<Reference>
PUSCh

Analyzes the PUSCH and PUCCH.

PRACh

Analyzes the PRACH.

*RST: PUSCh
Example: UL:DEM:MODE PRAC

Selects PRACH analysis mode.

Manual operation: See "Analysis Mode"


[SENSe][:LTE]:UL:DEMod:CESTimation

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Demodulation > [SENSe][:LTE]:UL:DEMod:CESTimation
[SENSe][:LTE]:UL:DEMod:CESTimation <Type>

This command selects the channel estimation type for uplink signals.

Parameters:
<Type>
PIL | PILPAY
PIL

Pilot only

PILP

Pilot and payload

*RST: PILP
Example: UL:DEM:CEST PIL

Uses only the pilot signal for channel estimation.

Manual operation: See "Channel Estimation Range"


[SENSe][:LTE]:UL:DEMod:EEPeriod

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Demodulation > [SENSe][:LTE]:UL:DEMod:EEPeriod
[SENSe][:LTE]:UL:DEMod:EEPeriod <State>

This command includes or excludes the exclusion period from EVM results.

Parameters:
<State> | ON | OFF
Example: | UL:DEM:EEP ON Turns the exclusion periods for EVM calculation on.
Manual operation: | See "EVM with Exclusion Period"


[SENSe][:LTE]:UL:DEMod:CDCoffset

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Demodulation > [SENSe][:LTE]:UL:DEMod:CDCoffset
[SENSe][:LTE]:UL:DEMod:CDCoffset <State>

This command turns DC offset compensation for uplink signals on and off.

Parameters:
<State>
ON | OFF
*RST: ON
Example: UL:DEM:CDC OFF

Deactivates DC offset compensation.

Manual operation: See "Compensate DC Offset"


[SENSe][:LTE]:UL:DEMod:CBSCrambling

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Demodulation > [SENSe][:LTE]:UL:DEMod:CBSCrambling
[SENSe][:LTE]:UL:DEMod:CBSCrambling <State>

This command turns scrambling of coded bits for uplink signals on and off.

Parameters:
<State>
ON | OFF
*RST: ON
Example: UL:DEM:CBSC OFF

Deactivates the scrambling.

Manual operation: See "Scrambling of Coded Bits"


[SENSe][:LTE]:UL:DEMod:SISYnc

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Demodulation > [SENSe][:LTE]:UL:DEMod:SISYnc
[SENSe][:LTE]:UL:DEMod:SISYnc <State>

This command turns suppressed interference synchronization on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: UL:DEM:SISY ON

Turns suppressed interference synchronization on.

Manual operation: See "Suppressed Interference Synchronization"


[SENSe][:LTE]:UL:DEMod:MCFilter

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Demodulation > [SENSe][:LTE]:UL:DEMod:MCFilter
[SENSe][:LTE]:UL:DEMod:MCFilter <State>

This command turns suppression of interfering neighboring carriers on and off (e.g. LTE, WCDMA, GSM etc).

Parameters:
<State>
ON | OFF
*RST: OFF
Example: UL:DEM:MCF ON

Turns suppression on of neighboring carriers on.

Manual operation: See "Multicarrier Filter"


Tracking

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Tracking
Tracking
List of Commands
[SENSe][:LTE]:UL:TRACking:PHASe
[SENSe][:LTE]:UL:TRACking:TIME


[SENSe][:LTE]:UL:TRACking:PHASe

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Tracking > [SENSe][:LTE]:UL:TRACking:PHASe
[SENSe][:LTE]:UL:TRACking:PHASe <Type>

This command selects the phase tracking type for uplink signals.

Parameters:
<Type>
OFF

Deactivate phase tracking

PIL

Pilot only

PILP

Pilot and payload

*RST: OFF
Example: SENS:UL:TRAC:PHAS PILP

Use pilots and payload for channel estimation.

Manual operation: See "Phase"


[SENSe][:LTE]:UL:TRACking:TIME

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring I/Q Measurements > Tracking > [SENSe][:LTE]:UL:TRACking:TIME
[SENSe][:LTE]:UL:TRACking:TIME <State>

This command turns timing tracking for uplink signals on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: UL:TRAC:TIME ON

Activates timing tracking.

Manual operation: See "Timing"


Configuring Frequency Sweep Measurements

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring Frequency Sweep Measurements
Configuring Frequency Sweep Measurements

Please refer to the documentation of the R&S FSW base unit for a comprehensive list and description of remote commands necessary to configure and perform frequency sweep measurements (ACLR and SEM).

All commands specific to the LTE application are listed below.

List of Commands
CONFigure[:LTE]:UL:CABW
[SENSe]:FREQuency:CENTer:CC<cci>:OFFSet
[SENSe]:POWer:ACHannel:AACHannel
[SENSe]:POWer:SEM:UL:REQuirement


CONFigure[:LTE]:UL:CABW

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring Frequency Sweep Measurements > CONFigure[:LTE]:UL:CABW
CONFigure[:LTE]:UL:CABW <Bandwidth>

This command selects the channel bandwidth(s) of the carriers in MC ACLR measurements.

Parameters:
<Bandwidth> | B520 First carrier: 5 MHz, second carrier: 20 MHz bandwidth. B1020 First carrier: 10 MHz, second carrier: 20 MHz bandwidth. B1515 First carrier: 15 MHz, second carrier: 15 MHz bandwidth. B1520 First carrier: 15 MHz, second carrier: 20 MHz bandwidth. B2020 First carrier: 20 MHz, second carrier: 20 MHz bandwidth. USER Custom combination of bandwidths. Define the bandwidths of both carriers with CONFigure[:​LTE]:​UL[:​CC<cci>]:​BW.
Example: | CONF:UL:CABW USER CONF:UL:CC1:BW BW5_00 CONF:UL:CC2:BW BW5_00 Custom bandwidth combination: first carrier 5 MHz, second carrier 5 MHz.
Manual operation: | See "Carrier Aggregation"


[SENSe]:FREQuency:CENTer:CC<cci>:OFFSet

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring Frequency Sweep Measurements > [SENSe]:FREQuency:CENTer:CC<cci>:OFFSet
[SENSe]:FREQuency:CENTer:CC<cci>:OFFSet <Frequency>

This command defines the frequency offset for a component carrier.

Parameters:
<Frequency> | Frequency offset relative to the first carrier in Hz.
Example: | FREQ:CENT:CC2:OFFS 15MHZ Defines a frequency offset of 15 MHz for the second component carrier.
Manual operation: | See "Carrier Aggregation"


[SENSe]:POWer:ACHannel:AACHannel

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring Frequency Sweep Measurements > [SENSe]:POWer:ACHannel:AACHannel
[SENSe]:POWer:ACHannel:AACHannel <Channel>

This command selects the assumed adjacent channel carrier for ACLR measurements.

Parameters:
<Channel>
EUTRA

Selects an EUTRA signal of the same bandwidth like the TX channel as assumed adjacent channel carrier.

UTRA128

Selects an UTRA signal with a bandwidth of 1.28MHz as assumed adjacent channel carrier.

UTRA384

Selects an UTRA signal with a bandwidth of 3.84MHz as assumed adjacent channel carrier.

UTRA768

Selects an UTRA signal with a bandwidth of 7.68MHz as assumed adjacent channel carrier.

*RST: EUTRA
Example: POW:ACH:AACH UTRA384

Selects an UTRA signal with a bandwidth of 3.84MHz as assumed adjacent channel carrier.

Manual operation: See "Assumed Adjacent Channel Carrier"


[SENSe]:POWer:SEM:UL:REQuirement

LTE Uplink (R&S FSW-K10x) > Remote Control > Remote Commands to Configure the Application > Configuring Frequency Sweep Measurements > [SENSe]:POWer:SEM:UL:REQuirement
[SENSe]:POWer:SEM:UL:REQuirement <Requirement>

This command selects the requirements for a spectrum emission mask.

Parameters:
<Requirement> | GEN | NS3 | NS4 | NS67 GEN General spectrum emission mask. NS3 | NS4 | NS67 Spectrum emission masks with additional requirements.
Example: | POW:SEM:UL:REQ NS3 Selects a spectrum emission mask with requirement for network signalled value NS3.
Manual operation: | See "SEM Requirement"


Analysis

LTE Uplink (R&S FSW-K10x) > Remote Control > Analysis
Analysis
Contents
  • Evaluation Range
  • Y-Axis Scale
  • Result Settings


Evaluation Range

LTE Uplink (R&S FSW-K10x) > Remote Control > Analysis > Evaluation Range
Evaluation Range
List of Commands
[SENSe][:LTE]:ALLocation:SELect
[SENSe][:LTE]:CARRier:SELect
[SENSe][:LTE]:MODulation:SELect
[SENSe][:LTE]:PREamble:SELect
[SENSe][:LTE]:SLOT:SELect
[SENSe][:LTE]:SUBFrame:SELect
[SENSe][:LTE]:SYMBol:SELect


[SENSe][:LTE]:ALLocation:SELect

LTE Uplink (R&S FSW-K10x) > Remote Control > Analysis > Evaluation Range > [SENSe][:LTE]:ALLocation:SELect
[SENSe][:LTE]:ALLocation:SELect <Allocation>

This command filters the displayed results in the constellation diagram by a particular type of allocation.

Parameters:
<Allocation>
ALL

Shows the results for all allocations.

<numeric_value>

Shows the results for a particular allocation type.

Allocation types are mapped to numeric values. For the code assignment see "Return Value Codes".

*RST: ALL
Example: ALL:SEL 2

Shows the results for PDSCH allocation 2.

Manual operation: See "Evaluation Range for the Constellation Diagram"


[SENSe][:LTE]:CARRier:SELect

LTE Uplink (R&S FSW-K10x) > Remote Control > Analysis > Evaluation Range > [SENSe][:LTE]:CARRier:SELect
[SENSe][:LTE]:CARRier:SELect <Carrier>

This command filters the displayed results in the constellation diagram by a particular subcarrier.

Parameters:
<Carrier>
ALL

Shows the results for all subcarriers.

<numeric_value>

Shows the results for a particular subcarrier.

*RST: ALL
Example: CARR:SEL 1

Shows the results for subcarrier 1.

Manual operation: See "Evaluation Range for the Constellation Diagram"


[SENSe][:LTE]:MODulation:SELect

LTE Uplink (R&S FSW-K10x) > Remote Control > Analysis > Evaluation Range > [SENSe][:LTE]:MODulation:SELect
[SENSe][:LTE]:MODulation:SELect <Modulation>

This command filters the displayed results in the constellation diagram by a particular type of modulation.

Parameters:
<Modulation>
ALL

Shows the results for all modulation types.

<numeric_value>

Shows the results for a particular modulation type.

Modulation types are mapped to numeric values. For the code assignment see "Return Value Codes".

*RST: ALL
Example: MOD:SEL 3

Shows the results for all elements with a 16QAM modulation

Manual operation: See "Evaluation Range for the Constellation Diagram"


[SENSe][:LTE]:PREamble:SELect

LTE Uplink (R&S FSW-K10x) > Remote Control > Analysis > Evaluation Range > [SENSe][:LTE]:PREamble:SELect
[SENSe][:LTE]:PREamble:SELect <Subframe>

This command selects a particular preamble for measurements that analyze individual preambles.

The command is available in PRACH analysis mode.

Parameters:
<Subframe>
ALL

Analyzes all preambles.

<numeric value>

Selects the premable to analyze.

*RST: ALL
Example: PRE:SEL ALL

Analyzes all preambles.

Manual operation: See "Preamble Selection"


[SENSe][:LTE]:SLOT:SELect

LTE Uplink (R&S FSW-K10x) > Remote Control > Analysis > Evaluation Range > [SENSe][:LTE]:SLOT:SELect
[SENSe][:LTE]:SLOT:SELect <Slot>

This command selects the slot to analyze.

Parameters:
<Slot>
S0

Slot 0

S1

Slot 1

ALL

Both slots

*RST: ALL
Example: SLOT:SEL S1

Selects slot 1 for analysis.

Manual operation: See "Slot Selection"


[SENSe][:LTE]:SUBFrame:SELect

LTE Uplink (R&S FSW-K10x) > Remote Control > Analysis > Evaluation Range > [SENSe][:LTE]:SUBFrame:SELect
[SENSe][:LTE]:SUBFrame:SELect <Subframe>

This command selects the subframe to be analyzed.

Parameters:
<Subframe>
ALL | <numeric value>
ALL

Select all subframes

0...39

Select a single subframe

*RST: ALL
Example: SUBF:SEL ALL

Select all subframes for analysis.

Manual operation: See "Subframe Selection"


[SENSe][:LTE]:SYMBol:SELect

LTE Uplink (R&S FSW-K10x) > Remote Control > Analysis > Evaluation Range > [SENSe][:LTE]:SYMBol:SELect
[SENSe][:LTE]:SYMBol:SELect <Symbol>

This command filters the displayed results in the constellation diagram by a particular OFDM symbol.

Parameters:
<Symbol>
ALL

Shows the results for all subcarriers.

<numeric_value>

Shows the results for a particular OFDM symbol.

*RST: ALL
Example: SYMB:SEL 2

Shows the results for the second OFDM symbol.

Manual operation: See "Evaluation Range for the Constellation Diagram"


Y-Axis Scale

LTE Uplink (R&S FSW-K10x) > Remote Control > Analysis > Y-Axis Scale
Y-Axis Scale
List of Commands
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE

LTE Uplink (R&S FSW-K10x) > Remote Control > Analysis > Y-Axis Scale > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE

Automatic scaling of the y-axis is performed once, then switched off again.

Usage: | SCPI confirmed
Manual operation: | See "Y-Axis Scale"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum

LTE Uplink (R&S FSW-K10x) > Remote Control > Analysis > Y-Axis Scale > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum <Value>

This command defines the maximum value of the y-axis for the selected result display.

Parameters:
<Value>
<numeric value>
*RST: depends on the result display

The unit and range depend on the result display.

Example: DISP:TRAC:Y:MIN -60
DISP:TRAC:Y:MAX 0

Defines the y-axis with a minimum value of -60 and maximum value of 0.

Manual operation: See "Y-Axis Scale"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum

LTE Uplink (R&S FSW-K10x) > Remote Control > Analysis > Y-Axis Scale > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum <Value>

This command defines the minimum value of the y-axis for the selected result display.

Parameters:
<Value>
<numeric value>
*RST: depends on the result display

The unit and range depend on the result display.

Example: DISP:TRAC:Y:MIN -60
DISP:TRAC:Y:MAX 0

Defines the y-axis with a minimum value of -60 and maximum value of 0.

Manual operation: See "Y-Axis Scale"


Result Settings

LTE Uplink (R&S FSW-K10x) > Remote Control > Analysis > Result Settings
Result Settings
List of Commands
CALCulate:MARKer:COUPling
UNIT:BSTR
UNIT:CAXes
UNIT:EVM


CALCulate:MARKer:COUPling

LTE Uplink (R&S FSW-K10x) > Remote Control > Analysis > Result Settings > CALCulate:MARKer:COUPling
CALCulate:MARKer:COUPling <State>

This command couples or decouples markers in different result displays to each other.

Parameters:
<State> | ON | OFF
Example: | CALC:MARK:COUP ON Couples the markers to each other.
Manual operation: | See "Marker Coupling"


UNIT:BSTR

LTE Uplink (R&S FSW-K10x) > Remote Control > Analysis > Result Settings > UNIT:BSTR
UNIT:BSTR <Unit>

This command selects the way the bit stream is displayed.

Parameters:
<Unit>
SYMbols

Displays the bit stream using symbols

BITs

Displays the bit stream using bits

*RST: SYMbols
Example: UNIT:BSTR BIT

Bit stream gets displayed using Bits.

Manual operation: See "Bit Stream Format"


UNIT:CAXes

LTE Uplink (R&S FSW-K10x) > Remote Control > Analysis > Result Settings > UNIT:CAXes
UNIT:CAXes <Unit>

This command selects the scale of the x-axis for result displays that show subcarrier results.

Parameters:
<Unit> | CARR Shows the number of the subcarriers on the x-axis. HZ Shows the frequency of the subcarriers on the x-axis.
Example: | UNIT:CAX HZ Selects frequency scale for the x-axis.
Manual operation: | See "Carrier Axes"


UNIT:EVM

LTE Uplink (R&S FSW-K10x) > Remote Control > Analysis > Result Settings > UNIT:EVM
UNIT:EVM <Unit>

This command selects the EVM unit.

Parameters:
<Unit>
DB

EVM results returned in dB

PCT

EVM results returned in %

*RST: PCT
Example: UNIT:EVM PCT

EVM results to be returned in %.

Manual operation: See "EVM Unit"


List of Commands

LTE Uplink (R&S FSW-K10x) > List of Commands
List of Commands
[SENSe:]ADJust:LEVel
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:LINK
[SENSe:]FREQuency:CENTer:STEP:LINK:FACTor
[SENSe:]FREQuency:OFFSet
[SENSe]:FREQuency:CENTer:CC<cci>:OFFSet
[SENSe]:FREQuency:CENTer[:CC<cci>]
[SENSe]:POWer:ACHannel:AACHannel
[SENSe]:POWer:SEM:UL:REQuirement
[SENSe]:SWAPiq
[SENSe]:SWEep:TIME
[SENSe]:SYNC[:STATe]?
[SENSe][:LTE]:ALLocation:SELect
[SENSe][:LTE]:CARRier:SELect
[SENSe][:LTE]:FRAMe:COUNt
[SENSe][:LTE]:FRAMe:COUNt:AUTO
[SENSe][:LTE]:FRAMe:COUNt:STATe
[SENSe][:LTE]:MODulation:SELect
[SENSe][:LTE]:OOPower:ATIMing
[SENSe][:LTE]:PREamble:SELect
[SENSe][:LTE]:SFLatness:ECONditions
[SENSe][:LTE]:SFLatness:OBANd
[SENSe][:LTE]:SLOT:SELect
[SENSe][:LTE]:SUBFrame:SELect
[SENSe][:LTE]:SYMBol:SELect
[SENSe][:LTE]:UL:DEMod:ACON
[SENSe][:LTE]:UL:DEMod:ATTSlots
[SENSe][:LTE]:UL:DEMod:CBSCrambling
[SENSe][:LTE]:UL:DEMod:CDCoffset
[SENSe][:LTE]:UL:DEMod:CESTimation
[SENSe][:LTE]:UL:DEMod:EEPeriod
[SENSe][:LTE]:UL:DEMod:MCFilter
[SENSe][:LTE]:UL:DEMod:MODE
[SENSe][:LTE]:UL:DEMod:SISYnc
[SENSe][:LTE]:UL:FORMat:SCD
[SENSe][:LTE]:UL:TRACking:PHASe
[SENSe][:LTE]:UL:TRACking:TIME
ABORt
CALCulate:MARKer:COUPling
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:LIMit<k>:ACPower:ACHannel:RESult?
CALCulate<n>:LIMit<k>:ACPower:ALTernate:RESult?
CALCulate<n>:LIMit<k>:FAIL?
CALCulate<n>:LIMit<k>:SUMMary:EVM:PCHannel:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:EVM:PCHannel[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:PSIGnal:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:EVM:PSIGnal[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:SDQP[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:SDSF[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:SDST[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:UCCD[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:UCCH[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:UPRA[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:USQP[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:USSF[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM:USST[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:EVM[:ALL]:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:EVM[:ALL][:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:FERRor:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:FERRor[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:GIMBalance:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:GIMBalance[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:IQOFfset:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:IQOFfset[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:QUADerror:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:QUADerror[:AVERage]:RESult?
CALCulate<n>:LIMit<k>:SUMMary:SERRor:MAXimum:RESult
CALCulate<n>:LIMit<k>:SUMMary:SERRor[:AVERage]:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:POWer:RESult[:CURRent]?
CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:UNIT:POWer
CONFigure[:LTE]:DUPLexing
CONFigure[:LTE]:LDIRection
CONFigure[:LTE]:MEASurement
CONFigure[:LTE]:UL:CABW
CONFigure[:LTE]:UL:CSUBframes
CONFigure[:LTE]:UL:CYCPrefix
CONFigure[:LTE]:UL:DRS:AOCC
CONFigure[:LTE]:UL:DRS:DSSHift
CONFigure[:LTE]:UL:DRS:GRPHopping
CONFigure[:LTE]:UL:DRS:NDMRs
CONFigure[:LTE]:UL:DRS:PUCCh:POWer
CONFigure[:LTE]:UL:DRS:SEQHopping
CONFigure[:LTE]:UL:DRS[:PUSCh]:POWer
CONFigure[:LTE]:UL:MIMO:ASELection
CONFigure[:LTE]:UL:PLC:CID
CONFigure[:LTE]:UL:PLC:CIDGroup
CONFigure[:LTE]:UL:PLC:PLID
CONFigure[:LTE]:UL:PRACh:APM
CONFigure[:LTE]:UL:PRACh:CONF
CONFigure[:LTE]:UL:PRACh:FOFFset
CONFigure[:LTE]:UL:PRACh:FRINdex
CONFigure[:LTE]:UL:PRACh:HFINdicator
CONFigure[:LTE]:UL:PRACh:NCSC
CONFigure[:LTE]:UL:PRACh:RSEQ
CONFigure[:LTE]:UL:PRACh:RSET
CONFigure[:LTE]:UL:PRACh:SINDex
CONFigure[:LTE]:UL:PUCCh:DESHift
CONFigure[:LTE]:UL:PUCCh:FORMat
CONFigure[:LTE]:UL:PUCCh:N1CS
CONFigure[:LTE]:UL:PUCCh:N2RB
CONFigure[:LTE]:UL:PUCCh:NORB
CONFigure[:LTE]:UL:PUCCh:NPAR
CONFigure[:LTE]:UL:PUSCh:FHMode
CONFigure[:LTE]:UL:PUSCh:FHOFfset
CONFigure[:LTE]:UL:PUSCh:FHOP:IIHB
CONFigure[:LTE]:UL:PUSCh:NOSM
CONFigure[:LTE]:UL:SFNO
CONFigure[:LTE]:UL:SRS:ANST
CONFigure[:LTE]:UL:SRS:BHOP
CONFigure[:LTE]:UL:SRS:BSRS
CONFigure[:LTE]:UL:SRS:CSRS
CONFigure[:LTE]:UL:SRS:CYCS
CONFigure[:LTE]:UL:SRS:ISRS
CONFigure[:LTE]:UL:SRS:MUPT
CONFigure[:LTE]:UL:SRS:NRRC
CONFigure[:LTE]:UL:SRS:POWer
CONFigure[:LTE]:UL:SRS:STAT
CONFigure[:LTE]:UL:SRS:SUConfig
CONFigure[:LTE]:UL:SRS:TRComb
CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:CONT
CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:MODulation
CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:PUCCh:FORMat
CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:PUCCh:NPAR
CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:PUSCh:CSField
CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:PUSCh:NDMRs
CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:RATO
CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:RBCount
CONFigure[:LTE]:UL:SUBFrame<subframe>:ALLoc:RBOFfset
CONFigure[:LTE]:UL:TDD:SPSC
CONFigure[:LTE]:UL:TDD:UDConf
CONFigure[:LTE]:UL:UEID
CONFigure[:LTE]:UL[:CC<cci>]:BW
DISPlay:FORMat
DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
FETCh:SUMMary:CRESt[:AVERage]?
FETCh:SUMMary:EVM:PCHannel:MAXimum?
FETCh:SUMMary:EVM:PCHannel:MINimum?
FETCh:SUMMary:EVM:PCHannel[:AVERage]?
FETCh:SUMMary:EVM:PSIGnal:MAXimum?
FETCh:SUMMary:EVM:PSIGnal:MINimum?
FETCh:SUMMary:EVM:PSIGnal[:AVERage]?
FETCh:SUMMary:EVM:SDQP[:AVERage]?
FETCh:SUMMary:EVM:SDSF[:AVERage]?
FETCh:SUMMary:EVM:SDST[:AVERage]?
FETCh:SUMMary:EVM:UCCD[:AVERage]?
FETCh:SUMMary:EVM:UCCH[:AVERage]?
FETCh:SUMMary:EVM:UPRA[:AVERage]?
FETCh:SUMMary:EVM:USQP[:AVERage]?
FETCh:SUMMary:EVM:USSF[:AVERage]?
FETCh:SUMMary:EVM:USST[:AVERage]?
FETCh:SUMMary:EVM[:ALL]:MAXimum?
FETCh:SUMMary:EVM[:ALL]:MINimum?
FETCh:SUMMary:EVM[:ALL][:AVERage]?
FETCh:SUMMary:FERRor:MAXimum?
FETCh:SUMMary:FERRor:MINimum?
FETCh:SUMMary:FERRor[:AVERage]?
FETCh:SUMMary:GIMBalance:MAXimum?
FETCh:SUMMary:GIMBalance:MINimum?
FETCh:SUMMary:GIMBalance[:AVERage]?
FETCh:SUMMary:IQOFfset:MAXimum?
FETCh:SUMMary:IQOFfset:MINimum?
FETCh:SUMMary:IQOFfset[:AVERage]?
FETCh:SUMMary:POWer:MAXimum?
FETCh:SUMMary:POWer:MINimum?
FETCh:SUMMary:POWer[:AVERage]?
FETCh:SUMMary:QUADerror:MAXimum?
FETCh:SUMMary:QUADerror:MINimum?
FETCh:SUMMary:QUADerror[:AVERage]?
FETCh:SUMMary:SERRor:MAXimum?
FETCh:SUMMary:SERRor:MINimum?
FETCh:SUMMary:SERRor[:AVERage]?
FETCh:SUMMary:TFRame?
FORMat[:DATA]
INITiate:CONTinuous
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
INITiate[:IMMediate]
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:COUPling
INPut:DIQ:CDEVice
INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:SRATe
INPut:DIQ:SRATe:AUTO
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:GAIN:STATe
INPut:GAIN[:VALue]
INPut:IMPedance
INPut:IQ:BALanced[:STATe]
INPut:IQ:TYPE
INPut:SELect
INPut<n>:EATT
INPut<n>:EATT:AUTO
INPut<n>:EATT:STATe
INSTrument:CREate:DUPLicate
INSTrument:CREate:REPLace
INSTrument:CREate[:NEW]
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace
MMEMory:LOAD:DEModsetting
MMEMory:LOAD:IQ:STATe
MMEMory:LOAD:TMOD:DL
SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:SEQuencer
TRACe<n>[:DATA]?
TRIGger[:SEQuence]:HOLDoff<instrument>
TRIGger[:SEQuence]:LEVel<instrument>[:EXTernal]
TRIGger[:SEQuence]:PORT<instrument>
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce
UNIT:BSTR
UNIT:CAXes
UNIT:EVM


Legal Notice

R&S®FSW-K10x (LTE Uplink)
LTE Uplink Measurement Application

© 2014 Rohde & Schwarz GmbH & Co. KG

Mühldorfstr. 15, 81671 München, Germany

Phone: +49 89 41 29 - 0

Fax: +49 89 41 29 12 164

E-mail: info@rohde-schwarz.com

Internet: www.rohde-schwarz.com

Subject to change – Data without tolerance limits is not binding.

R&S® is a registered trademark of Rohde & Schwarz GmbH & Co. KG.

Trade names are trademarks of the owners.